cancel
Showing results for 
Search instead for 
Did you mean: 

OpenWRT on Buffalo WBMR-HP-G300H (using BT Openreach modem)

jamcguire
Newbie
Posts: 1
Registered: ‎10-07-2017

OpenWRT on Buffalo WBMR-HP-G300H (using BT Openreach modem)

Hi there,

 

Just wondering if anyone can help me configure the Buffalo WBMR-HP-G300H running OpenWRT and using the BT Openreach modem, I can't seem to establish a PPPoE connection and see the following errors.

 

Note that the Buffalo WBMR-HP-G300H is not VDSL capable, so I am connecting via ethernet using one of the device's switch ports to the white BT Openreach modem.  I'm wondering if that's fundamentally where I'm going wrong?  The default seems to be to use nas0 which is some kind of pseudo device, and I can't find any documentation, should be I setting the physical interface to use one of the eth devices instead, or is nas0 suitable?

 

Mon Jul 10 20:17:19 2017 daemon.notice netifd: Interface 'wan' is enabled
Mon Jul 10 20:17:19 2017 daemon.notice netifd: Interface 'wan' is setting up now
Mon Jul 10 20:17:19 2017 daemon.info pppd[1882]: Plugin rp-pppoe.so loaded.
Mon Jul 10 20:17:19 2017 daemon.info pppd[1882]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Mon Jul 10 20:17:19 2017 daemon.notice pppd[1882]: pppd 2.4.7 started by root, uid 0
Mon Jul 10 20:17:34 2017 daemon.warn pppd[1882]: Timeout waiting for PADO packets
Mon Jul 10 20:17:34 2017 daemon.err pppd[1882]: Unable to complete PPPoE Discovery
Mon Jul 10 20:17:34 2017 daemon.info pppd[1882]: Exit.

 

 

The Openreach modem has a solid green DSL light i've never modified the configuration of the modem itself so I'm not sure if there are any settings I need to change here?

 

The Buffalo WBMR-HP-G300H is connected via its ethernet port 1 to the Openreach modem's LAN 1.

 

The relevant sections in /etc/network/config seem to be:

 

config atm-bridge 'atm'
option vpi '1'
option vci '32'
option encaps 'llc'
option payload 'bridged'

config interface 'wan'
option proto 'pppoe'
option delegate '0'
option _orig_ifname 'eth0.2'
option _orig_bridge 'false'
option username 'myusername@plusdsl.net'
option password 'myaccountpassword'
option service 'Plusnet'
option ifname 'nas0'

 

Not sure if this section is relevant if I'm not using the built in DSL modem, but this is also present in /etc/config/network, I have also ensured that the annex A firmware is installed:

config adsl 'dsl'
option annex 'a'
option firmware '/lib/firmware/adsl.bin'

 

Ifconfig outputs: 

 

root@OpenWrt:~# ifconfig
br-lan Link encap:Ethernet HWaddr 00:24:A5:BDCheesyC:F2
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::224:a5ff:febd:dcf2/64 Scope:Link
inet6 addr: fd4c:44de:7183::1/60 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:19299 errors:0 dropped:0 overruns:0 frame:0
TX packets:26699 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2091994 (1.9 MiB) TX bytes:25364270 (24.1 MiB)

eth0 Link encap:Ethernet HWaddr 00:24:A5:BDCheesyC:F2
inet6 addr: fe80::224:a5ff:febd:dcf2/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:6 errors:0 dropped:0 overruns:0 frame:0
TX packets:982 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:380 (380.0 B) TX bytes:88205 (86.1 KiB)

eth0.1 Link encap:Ethernet HWaddr 00:24:A5:BDCheesyC:F2
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:5 errors:0 dropped:0 overruns:0 frame:0
TX packets:975 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:230 (230.0 B) TX bytes:83487 (81.5 KiB)

nas0 Link encap:Ethernet HWaddr 00:24:A5:BDCheesyC:F3
inet6 addr: fe80::224:a5ff:febd:dcf3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:469 errors:469 dropped:0 overruns:469 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:43716 (42.6 KiB)

wlan0 Link encap:Ethernet HWaddr 00:24:A5:BDCheesyC:F2
inet addr:10.16.166.34 Bcast:10.16.166.39 Mask:255.255.255.248
inet6 addr: fe80::224:a5ff:febd:dcf2/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:24575 errors:0 dropped:0 overruns:0 frame:0
TX packets:16680 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:24602052 (23.4 MiB) TX bytes:2416711 (2.3 MiB)

wlan0-1 Link encap:Ethernet HWaddr 02:24:A5:BDCheesyC:F2
inet6 addr: fe80::24:a5ff:febd:dcf2/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:19499 errors:0 dropped:0 overruns:0 frame:0
TX packets:27506 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2404871 (2.2 MiB) TX bytes:25977171 (24.7 MiB)

 

Version:

root@OpenWrt:~# uname -a
Linux OpenWrt 3.18.23 #1 Sun Jan 31 12:02:45 CET 2016 mips GNU/Linux

DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='15.05.1'
DISTRIB_REVISION='r48532'
DISTRIB_CODENAME='chaos_calmer'
DISTRIB_TARGET='lantiq/xway'
DISTRIB_DESCRIPTION='OpenWrt Chaos Calmer 15.05.1'
DISTRIB_TAINTS=''
 

 

Help appreciated.

1 REPLY
Superuser
Superuser
Posts: 6,969
Thanks: 999
Fixes: 60
Registered: ‎30-07-2007

Re: OpenWRT on Buffalo WBMR-HP-G300H (using BT Openreach modem)

I recall some problems a while ago with OPenWrt establishing a PPPoE session, it can take a LONG time sometimes, see this thread https://community.plus.net/t5/Broadband/Configuring-OpenWRT-for-PPPoE-via-Openreach-FTTC-modem/td-p/...