cancel
Showing results for 
Search instead for 
Did you mean: 

Macbook not connecting to wi-fi when waking from sleep.

p0mme
Dabbler
Posts: 10
Registered: 25-01-2017

Macbook not connecting to wi-fi when waking from sleep.

Whenever I wake up my Macbook Pro from sleep, the wi-fi is failing to re-connect.

My router name is showing in the wifi menu; PLUSNET-SHXX; so I try and choose my Plusnet network manually, and it prompts for the password. It then keeps telling me the password’s wrong, every single time. It’s not. I’m reading it off the box. the password has been correct since I first set up the router.

To get back a connection, I have to leave the computer awake for about 3-5 minutes, before trying again to manually choose the wi-fi network, at which point it tend to start working again (with no extra password prompts!)

 

This can’t be to do with the strength of the network/distance, because it does the same when I’m right in front of the router. And it seems to just be when waking the laptop.

I’ve ensured my Plusnet is at the top of the “preferred networks” in wi-fi settings, but other than that I’m at a loss of what to do.

When I had Virgin Media, it immediately reconnected to my home network when the computer woke, with no long wait nor intervention from me.

Surely this isn’t normal? Buck2

9 REPLIES
Plusnet Staff
Plusnet Staff
Posts: 2,144
Thanks: 372
Fixes: 116
Registered: 22-08-2015

Re: Macbook not connecting to wi-fi when waking from sleep.

Hi there

If you haven't already I'd first try changing the wireless channel by logging into your router interface at http://192.168.1.254 and, assuming you're using the Hub One, to try splitting the 5Ghz frequency from the 2.4Ghz.

If you need any guidance on how to do this, this should help: https://www.plus.net/help/broadband/router-user-guides/

Feel free to let us know how you get on.
From when I joined the Plusnet Help Team in May 2017 my main Community account is @Gandalf.
If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Staff
p0mme
Dabbler
Posts: 10
Registered: 25-01-2017

Re: Macbook not connecting to wi-fi when waking from sleep.

Thanks for the reply. Sorry if it's an obvious question, but by splitting them do you mean clicking "no" to sync?

 

Sync with 2.4 GHz: Option Yes for wireless sync is unselectedOption No for wireless sync is selected
  Use the same Wireless SSID and Wireless key as 2.4 GHz
Plusnet Staff
Plusnet Staff
Posts: 2,144
Thanks: 372
Fixes: 116
Registered: 22-08-2015

Re: Macbook not connecting to wi-fi when waking from sleep.

Yep, and you'll need to change the SSID too. For example, adding 5G to the end.
From when I joined the Plusnet Help Team in May 2017 my main Community account is @Gandalf.
If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Staff
p0mme
Dabbler
Posts: 10
Registered: 25-01-2017

Re: Macbook not connecting to wi-fi when waking from sleep.

Thanks again. That seems to connect more quickly to the original one. Should I be able to join newly-appeared 5G network too? When I try it, it tells me the pass is invalid, but still kicks me off the original conenction. Or do I have to leave the 5G redundant?

Plusnet Staff
Plusnet Staff
Posts: 2,144
Thanks: 372
Fixes: 116
Registered: 22-08-2015

Re: Macbook not connecting to wi-fi when waking from sleep.

No problems. Happy to hear that splitting the networks has fixed the issue.

You should be able join the 5G network using the same wireless key. I'd verify the key in the 5Ghz settings.

Also, how far are you away from the router? Whilst this new wifi network is faster/more stable the range is considerably shorter so if the signal is weak you may have problems connecting.
From when I joined the Plusnet Help Team in May 2017 my main Community account is @Gandalf.
If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Staff
p0mme
Dabbler
Posts: 10
Registered: 25-01-2017

Re: Macbook not connecting to wi-fi when waking from sleep.


Anoush wrote:
No problems. Happy to hear that splitting the networks has fixed the issue.

You should be able join the 5G network using the same wireless key. I'd verify the key in the 5Ghz settings.

Also, how far are you away from the router? Whilst this new wifi network is faster/more stable the range is considerably shorter so if the signal is weak you may have problems connecting.

 

The wireless key on the box is the same as that's showing in the router settings, exactly the same letters/numbers in 2g and 5g.

I just tried adding the new separate 5g wifi to my phone, and it accepted the same password with no problem.

I had wondered about distance from the router, but, having been downstairs earlier, I'm now sitting with the box a couple of meters in front of me & my Macbook somehow is still being (partially) awkward with the pass key

Plusnet Staff
Plusnet Staff
Posts: 2,144
Thanks: 372
Fixes: 116
Registered: 22-08-2015

Re: Macbook not connecting to wi-fi when waking from sleep.

Hmm. Apple devices tend to be a bit awkward with connecting to wifi, I've a few of them myself.

I'd try changing the wireless channel for the 5Ghz network and then test your Mac with the 5G after each channel change.
From when I joined the Plusnet Help Team in May 2017 my main Community account is @Gandalf.
If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Staff
p0mme
Dabbler
Posts: 10
Registered: 25-01-2017

Re: Macbook not connecting to wi-fi when waking from sleep.

Well today, its being a little less temperamental and it is [on most tries] connecting to the 5G network. If it becomes a problem again, I'll try changing the wireless channel, though I'll need to look in the help section see what I'm meant to change it to!

Thanks again. Smiley

Community Veteran
Posts: 5,237
Thanks: 1,321
Fixes: 31
Registered: 16-10-2014

Re: Macbook not connecting to wi-fi when waking from sleep.

@p0mme - You may also want to disable IPv6 on your Wireless Interface, so from a root terminal:

networksetup -setv6off WiFi

If this doesn't work for your version of OSX try :

networksetup -setv6off “WiFi”

You may need to select this “Off” option in your TCP/IP Network config as seen here:

IPv6-Off.png