cancel
Showing results for 
Search instead for 
Did you mean: 

Mac issues

FIXED
Highlighted
Hooked
Posts: 7
Registered: ‎11-05-2016

Mac issues

Have had plusnet for about a month and for no apparent reason my MacBook and iMac now reject the password and lose the IP address. I tried entering it manually but it only worked as a temporary fix. No problems with PCs or mobile devices. And the MacBook works fine on other wifi connections. Weird. Annoying. Help!
14 REPLIES 14
Highlighted
Moderator
Moderator
Posts: 24,040
Thanks: 4,227
Fixes: 1,081
Registered: ‎11-01-2008

Re: Mac issues

you need to go into the Hub One web interface and split the 2.4ghx and 5ghz wireless networks into 2.

I've added a 5 on to mine to solve this issue.
Customer / Moderator
If it helped click the thumb
If it fixed it click 'This fixed my problem'
Highlighted
Hooked
Posts: 7
Registered: ‎11-05-2016

Re: Mac issues

You legend- thanks. Will try it now 🙂
Highlighted
Hooked
Posts: 7
Registered: ‎11-05-2016

Re: Mac issues

Can't find how to access the hub without a wifi connection - guessing I will need to wait till I can access it via PC. Will update...
Highlighted
Aspiring Pro
Posts: 1,873
Thanks: 63
Fixes: 3
Registered: ‎25-09-2012

Re: Mac issues

Yes, you'd have to wait until you can use a device which connects to the Hub one wirelessly or can try using an ethernet cable.

Once split the wifi you will have to reconnect all wireless devices to the new wifi name.

NE

Ex Plusnet Fibre customer. Sky Ultrafast (G.Fast) Customer using a Sky Hub 4.2. If you wish to say thanks, please click the thumbs up Thumbs_Up
Highlighted
Hooked
Posts: 7
Registered: ‎11-05-2016

Re: Mac issues

Ok. Will wait for teen with laptop. Advice appreciated, thank you.
Highlighted
Aspiring Pro
Posts: 1,873
Thanks: 63
Fixes: 3
Registered: ‎25-09-2012

Re: Mac issues

Fix

No problem, if you have any issues with doing the wifi split just let me know.

To split the wifi log into the router at http://192.168.1.254/

Go to 'Advanced Settings' 

Enter admin password which is on removable plastic card on the rear of your Hub

continue to advanced settings

Click the wireless tab

Click the 5Ghz tab.

You should then add '-5G' or similar to the end of the current wireless SSID, this will easily identify it on the wireless networks list that your PC detects.

You should make sure that 'Sync with 2.4 GHz' is set to NO.

Then click apply.

Hope this helps Smiley

NE

Ex Plusnet Fibre customer. Sky Ultrafast (G.Fast) Customer using a Sky Hub 4.2. If you wish to say thanks, please click the thumbs up Thumbs_Up
Highlighted
Hooked
Posts: 7
Registered: ‎11-05-2016

Re: Mac issues

I've now done this and still have the same situation. I re-entered the IP address manually as the iMac dropped it again. That still didn't work. What else can I try? 😞
Highlighted
Hooked
Posts: 7
Registered: ‎11-05-2016

Re: Mac issues

Scrap that - I went through the advanced settings again and got it working on third time of asking - don't know why but I'll take it! 🙂
Highlighted
Aspiring Pro
Posts: 1,873
Thanks: 63
Fixes: 3
Registered: ‎25-09-2012

Re: Mac issues

Glad to hear it. 

It can also be beneficial to 'forget' the wireless network and re-join it. 

Hope this helps 

NE Smiley

Ex Plusnet Fibre customer. Sky Ultrafast (G.Fast) Customer using a Sky Hub 4.2. If you wish to say thanks, please click the thumbs up Thumbs_Up
Highlighted
Hooked
Posts: 7
Registered: ‎11-05-2016

Re: Mac issues

Weirdly it has worked for the iMac but the MacBook Air still won't recognise the password. I've tried with manual IP settings as well as default but it still won't connect. Have rebooted twice as well. Tips or suggestions welcomed!
Highlighted
Aspiring Pro
Posts: 1,873
Thanks: 63
Fixes: 3
Registered: ‎25-09-2012

Re: Mac issues

Whilst I've owned a Mac Mini for some time I've not come across such an issue.

I would recommend if not already tried is to go to click on the wifi icon on the top right , open network preferences, click advanced, and delete all the preferred networks (a quick way is to click on one and then do CMD and A at the same time to highlight all) and then click the minus key.  This deletes all the preferred and known networks so you will have to rejoin them.

NE.

Ex Plusnet Fibre customer. Sky Ultrafast (G.Fast) Customer using a Sky Hub 4.2. If you wish to say thanks, please click the thumbs up Thumbs_Up
Newbie
Posts: 1
Registered: ‎20-12-2016

Re: Mac issues

Awesome thank you, worked great! I'm presuming now though that other devices won't switch automatically between 2Ghz and 5Ghz?
Highlighted
Legend
Posts: 17,723
Thanks: 598
Fixes: 168
Registered: ‎05-04-2007

Re: Mac issues

Yep, you'll need to manually choose which to connect to.

If this post resolved your issue please click the 'This fixed my problem' button

Former Plusnet Staff member. Posts after 31st Jan 2020 are not on behalf of Plusnet.
Highlighted
Newbie
Posts: 2
Registered: ‎03-11-2016

Re: Mac issues

I've just developed this issue on my Mac having been on my plusnet router for three months. It changed for no reason. This has worked brilliantly. Thanks for the advice.