cancel
Showing results for 
Search instead for 
Did you mean: 

Laggy web browsing

darrenreid93
Hooked
Posts: 9
Registered: 04-01-2017

Laggy web browsing

I've recently switched from TalkTalk fibre, to Plusnet. Transfer speed wise my connection is fine, however whenever a webpage first opens, it attempts to connect for around 10 seconds just twirling and leaving a white page. As soon as it starts loading its just as instant as with Talktalk. I noticed it as soon as I switched, and unfortunatley hasn't got better. I've tried with my openreach modem, Hub one, and even TalkTalk router across all my devices I normally use. It's as if its trying to access plusnet's cache and failing. It can't be an Openreach issue, as TalkTalk has been fine and it only problematic as soon as I switched. Changing DNS doesn't help. Anyone got any ideas what I can do? It must be a Plusnet backhaul problem, or setting issue on my side. I've tried everything I can think of in terms of the second option, however I would be very open to potential solutions.

1 REPLY
MrSilver
Pro
Posts: 550
Thanks: 88
Fixes: 9
Registered: 05-10-2016

Re: Laggy web browsing

hi, and welcome!

Dont be offended by the question, but how technical are you?

couple of things to try, that may need more explaining if needed!

Load up Chrome, press F12, go to network tab, press ctrl-e

In the main window type in a website address like plus.net

See what comes up on the network, ideally take a screenshot of the output so we can see what is taking a while.

 

Second that is better but harder is to load up Wireshark and record going to a website, that shows then the DNS requests and the website traffic so see whats going wrong. Can give some instructions if you dont know how to do that though,

Third, try running in privacy mode, that stops extensions running in case they are the problem.

 

If it was a plusnet backhaul problem it would be impacting everyone, mine at least is pretty snappy today (and other days) so hopefully we can fix your issue.