cancel
Showing results for 
Search instead for 
Did you mean: 

Just upgraded to highest speed fibre but speeds are worse

bigfootisblurry
Hooked
Posts: 5
Registered: ‎19-06-2020

Just upgraded to highest speed fibre but speeds are worse

As the subject really, I've upgraded from 36mb fibre to 66mb fibre this week but my download speeds have only increased slightly (33mb up to 39mb) and my ping/jitter is considerably worse. Upload speeds have roughly doubled from 8mb to 16mb. This is someway below the 50+mb download I'm guaranteed and was wondering if there's anything else I need to do? Router has been rebooted with no change and the connection quality seems to be getting steadily worse since the change.

5 REPLIES 5
daveplus
Pro
Posts: 615
Thanks: 133
Fixes: 10
Registered: ‎25-08-2010

Re: Just upgraded to highest speed fibre but speeds are worse

@bigfootisblurry 

Hi

First step would be to go to  https://www.broadbandchecker.btwholesale.com/#/ADSL to see what is possible

Dave

bigfootisblurry
Hooked
Posts: 5
Registered: ‎19-06-2020

Re: Just upgraded to highest speed fibre but speeds are worse

Between 80 and 67 down, 19-20 up.

 

 Plusnet self service says theres a fault on the line, very frsutrating, as there wasn't before I upgraded.

RichardB
Aspiring Champion
Posts: 862
Thanks: 280
Fixes: 29
Registered: ‎19-11-2008

Re: Just upgraded to highest speed fibre but speeds are worse

Hi @bigfootisblurry,
The fault was there before the upgrade as your speed was 33 mbps and not 37 to 40 mbps.
The fault is now more apparant as the speed is now significantly below the minimum.
The good news is that PN have identified the issue anxd will be organising an Openreach tech to attend.
Richard
bigfootisblurry
Hooked
Posts: 5
Registered: ‎19-06-2020

Re: Just upgraded to highest speed fibre but speeds are worse

Thank you for the comments. Lets see if an when it gets sorted. Not had the greatest experience with PN so far it has to be said.

bigfootisblurry
Hooked
Posts: 5
Registered: ‎19-06-2020

Re: Just upgraded to highest speed fibre but speeds are worse

Almost a week later and no updates at all other than various automated "passed to various department" statements, themselves not changed since Thursday.

 

Is anyone here actually able to look at my issue?