cancel
Showing results for 
Search instead for 
Did you mean: 

Just switched to Plusnet but broadband not working

Booiep
Newbie
Posts: 1
Registered: ‎31-05-2018

Just switched to Plusnet but broadband not working

Switched to Plusnet the blue light is on the box but it’s not  working and the line is all crackerly. Can anyone help?

1 REPLY
Plusnet Help Team
Plusnet Help Team
Posts: 6,125
Thanks: 592
Fixes: 231
Registered: ‎01-01-2012

Re: Just switched to Plusnet but broadband not working

Sorry to hear your connection isn't working.

It looks like your router is stuck in it's automated setup.

If you follow the steps below you should be able to get online

 

1) Open a browser
2) Enter 192.168.1.254 into the address bar
3) On the router's home screen, select 'Settings'
4) Enter the password. This is the 'Admin Password for Hub Manager' on the removable card on the rear of the router (it can also be found on the base of the router)Within the 'Settings' menu, select the 'Broadband' tab or 'Enter your broadband username and password'
5) On the following page, you must enter the broadband username and password (There is a 'show characters option on this page if you are struggling with entering the password)
6) Click the 'Connect' button. The power light should turn blue to indicate that there is an internet connection.

Let us know if you're still having issues after

If this post resolved your issue please click the 'This fixed my problem' button
 Matthew Wheeler
 Plusnet Help Team