cancel
Showing results for 
Search instead for 
Did you mean: 

Just had my Fibre installed. Slow speeds.

mitchorr
Newbie
Posts: 6
Registered: 15-05-2015

Just had my Fibre installed. Slow speeds.

Hi , I had the engineer visit and install my fibre this morning, when testing he was getting 30+mb down speeds yet I only seem to be getting just over 1mb when testing myself.
Any ideas ?
To add , when i go to the 'Change products' page it says i am still in the process of a product change? Should this not have been updated by now?
Thanks. 
6 REPLIES
Moderator
Moderator
Posts: 25,990
Thanks: 1,239
Fixes: 50
Registered: 14-04-2007

Re: Just had my Fibre installed. Slow speeds.

I'm guessing that Plusnet have not yet received a completion notification from BT.

Customer and Forum Moderator.

mitchorr
Newbie
Posts: 6
Registered: 15-05-2015

Re: Just had my Fibre installed. Slow speeds.

Ahh okay. Any ideas how long this normally takes?
Cheers
mitchorr
Newbie
Posts: 6
Registered: 15-05-2015

Re: Just had my Fibre installed. Slow speeds.

?
Moderator
Moderator
Posts: 25,990
Thanks: 1,239
Fixes: 50
Registered: 14-04-2007

Re: Just had my Fibre installed. Slow speeds.

I'm sorry I can't give a definitive answer but if one of the CRT guys spots this thread he/she could take a look at it.

Customer and Forum Moderator.

mitchorr
Newbie
Posts: 6
Registered: 15-05-2015

Re: Just had my Fibre installed. Slow speeds.

It seems the chat service is unavailable and has been since this morning for me. Quite ridiculous.
Plusnet Help Team
Plusnet Help Team
Posts: 4,776
Thanks: 355
Fixes: 136
Registered: 01-01-2012

Re: Just had my Fibre installed. Slow speeds.

I can see you've got through to our Live chat team who have got this sorted for you.
If this post resolved your issue please click the 'This fixed my problem' button
 Matthew Wheeler
 Plusnet Help Team