cancel
Showing results for 
Search instead for 
Did you mean: 

Hang on OS X with plusnet wifi

philrosenberg
Newbie
Posts: 1
Registered: 15-03-2015

Hang on OS X with plusnet wifi

Hi all
This is a problem and solution. When we had this problem we found no help online. When we phoned plusnet the tech support person we spoke to had never come across this problem but he asked a colleague and he knew the fix. I thought I would post that fix in case it is useful to anyone else.
Basically when our MacBook first tried to connect to our new plusnet router over the wifi it hung and we had to do a hard reset. On reboot it hung again, then next reboot same again. I disabled the wifi from the router using my Windows laptop via the router's gateway web page and we could boot the mac again. Then I turned on the wifi and a few seconds later the Mac hung. We repeated this procedure but with the network menu dropped down and it seemed like the first instance of "Airport: Looking for networks" after the wifi was switched on caused the hang.
The fix was as follows:
1) Turn off the wifi, either via the router gateway or just turn off the router.
2) Turn on your Mac
3) Click the wifi symbol and select Open Network Preferences
4) Make sure AirPort is selected and pres the Advanced... button
5) select the TCP/IP tab
6) Under configure IPv6, select Off.
7) press OK then Apply and close down the Network window, then reboot.
Cool While rebooting you should be able to turn the wifi back on.
9) Hopefully you should now be able to enjoy your wifi :-)
Hope this helps someone. If it is of any interest we are running Mac OS X Snow Leopard and the router was a SagemCom 2704N.
Good luck
Phil
11 REPLIES
robinm
Hooked
Posts: 6
Thanks: 5
Registered: 23-03-2015

Re: Hang on OS X with plusnet wifi

Many thanks for this - I am changing to Plusnet fibre & immediately on powering up their router had this problem on my elderly Mac Mini, running OS X 10.6.8. Same router type and model as yours. Now fixed.  Smiley
A bit strange, though; I would have thought that all new routers would at least support IPv6, even if they don't actually use it.
Hove2
Newbie
Posts: 1
Registered: 06-08-2015

Re: Hang on OS X with plusnet wifi

Very many thanks for this post. I had exactly the same problem with the Sagemcom router and Snow Leopard on an old Macbook, and your IPv6 fix solved it completely.  I had previously tried the PlusNet technical support folk but they did not know about it, and are sending me a new router.  Ah well, nice to have a spare.
AndrewPS
Newbie
Posts: 1
Registered: 09-09-2015

Re: Hang on OS X with plusnet wifi

Thanks: I had the identical problem with my daughter's old machine. Took it to the Apple Genius bar this morning, and (of course) no fault was apparent. So I was very grateful to find this, when I finally realised that the problem had started when we changed to Plusnet, and experimented with turning the router off...
I have one piece of extra experience to share/advice to offer: when I tried to alter theTCP/IP settings, the options were dimmed. I turned off the router, turned off Airport - nothing. But then I quite and relaunched System Preferences and the options were available. And now (so far) everything is working fine.
icklesal
Dabbler
Posts: 12
Registered: 18-09-2015

Re: Hang on OS X with plusnet wifi

Unfortunately I'd love to say this worked for me - but it didn't.

Had my new PN account activated today (20/10/15) after migrating from Madasafish. (Posts are available elsewhere on the forum about MAAF etc)
Despite being sent the new router mentioned in AndrewPS post - it absolutely refused to let me into anything on my iMac, which is still using 10.6.8. It hung, it churned, it crunched, it froze everything on my mac from opening a simple .png image in preview to trying to get into my folders. In fact, if I didn't love my baby so much, I'd have resorted to taking a hammer to it - perhaps the new router, not my Imac!
The only solution for me was to disconnect the whole lot and return to using my old Thomson Gateway Router I was first provided when I joined Madasafish! Only difference being now is that I log into it with PN details
So, sorry to be the bearer of bad news, but this really isn't a solution for all. Sadly...  Cry
I really think somewhere in their what system does it support info, PN may need to make folks using older systems aware of this. As the one size fits all hardware, clearly doesn't work for everyone!
Course, if I do upgrade the OS (eventually) then at least I'll have a spare router.
The daft thing is -  my iphone and ipad connected to the new router no problem — so a bit like me, I am well aware one day I will need to upgrade my iMac OS's. But for now, I will survive being stuck in the past Cheesy
paragoncs
Dabbler
Posts: 10
Registered: 11-03-2011

Re: Hang on OS X with plusnet wifi

As far as I've seen, this problem with the Sagecom only appears when using Mac OS X Snow Leopard 10.6 , the newer Mac OS 10.7 and upwards are ok.
veeb
Newbie
Posts: 1
Registered: 27-11-2015

Re: Hang on OS X with plusnet wifi

Many thanks Phil.....  it worked a treat... with 10.4.11. 
ted356
Newbie
Posts: 1
Registered: 09-12-2015

Re: Hang on OS X with plusnet wifi

I have just had the same problem in trying to use a new Plusnet router with an iMac still on Snow Leopard, that was previously working fine with an old Thomson router.
Switching off automatic ipv6 in Airport>Advanced>TC/IP did NOT clear the fault, but after switching off automatic ipv6 in Ethernet>Advanced>TC/IP as well, everything has been OK. Perhaps this will solve the problem for the poster who said that the original fix didn't work for them.
jtgbso
Newbie
Posts: 1
Registered: 29-12-2015

Re: Hang on OS X with plusnet wifi

Thank you so much for this post which fixed the same problem on Sage router sent to replace faulty Thomson one. Plusnet adviser could only tell me to upgrade my elderly Mac ( on Snow Leopard) to level that Apple site does not advise. This fix seems (touch wood!) to have worked fine and it's very disappointing that PN advisers aren't giving this advice out. I intend replacing my laptop sometime soon, but certainly don't want to be forced into that unnecessarily. Thank you again (and for spelling out how to do it so clearly too)
Chubblers
Newbie
Posts: 6
Registered: 24-01-2016

Re: Hang on OS X with plusnet wifi

Thanks Philrosenberg I was having the same trouble with my Mac, this fix you suggested worked. 
molehill
Newbie
Posts: 1
Registered: 06-02-2016

Re: Hang on OS X with plusnet wifi

  Smiley  Thanks - this fix worked for the wife's MacBook which is about 7/8 years old when we moved from BT (BT Home Hub 2.0 router) to plusnet.
CraigT
Newbie
Posts: 1
Registered: 14-12-2016

Re: Hang on OS X with plusnet wifi

A further thanks from me, my iMac worked fine with Talktalk but hung when connected wired or wifi to Plusnet.

Disabled IPv6 and works fine.

Shame that Plusnet did not have that as a known problem nor fixed their routers not to cause the problem.