cancel
Showing results for 
Search instead for 
Did you mean: 

Great speeds, and terrible speeds?

Bolter2
Newbie
Posts: 2
Registered: a week ago

Great speeds, and terrible speeds?

I upgraded to superfast fibre 2 a few months ago, on my Xbox one, through WiFi, I get amazing speeds of around 67mbps. It's flawless. However, all mobile devices in the house get terrible speeds, pictures struggle to load on Facebook, for example. This is through my android phone, and my wife's iPhone and iPad, and laptop. The only difference is that the Xbox uses the 5ghz frequency, and the mobile devices use 2.4ghz. I'm not expecting 67mbps on my phone, but I should at least be able to load a picture or video. I have contacted customer services several times, we have been through all the standard stuff, changed channels etc etc. But today they told me there isn't much more they can do and it's down to me to either use a signal booster or get a new router. I don't think a signal booster will make a difference, as I can sit next to the router and have excellent signal, just poor speeds. The router is in the same location as my old Plusnet one, and nothing else has changed that I believe would affect it that badly.

Our phones and devices work perfectly on other WiFi such as work, or friends houses. So it's definitely something with ours and starting to wonder if there is a problem with the 2.4ghz channel on this particular router? I don't want to have to spend more money on a new router if this is a fault with the router provided.

Any help is much appreciated, thanks
3 REPLIES 3
Highlighted
Baldrick1
Hero
Posts: 3,595
Thanks: 1,549
Fixes: 99
Registered: ‎30-06-2016

Re: Great speeds, and terrible speeds?

@Bolter2  Welcome to the forum.

Did the standard stuff’ include splitting the 2.4 and 5GHz bands? See https://community.plus.net/t5/My-Router/2-4ghz-and-or-5ghz-best-practice/m-p/1351966#M840

This very often resolves this sort of problem. Note that you will need to go back into your device wireless settings to pick up the new 5GHz SSID.

Bolter2
Newbie
Posts: 2
Registered: a week ago

Re: Great speeds, and terrible speeds?

Hi @Baldrick1, this wasn't part of the standard stuff no. I have just done as instructed and will see if it improves. Thanks alot for the suggestion and fingers crossed!
Plusnet Help Team
Plusnet Help Team
Posts: 509
Thanks: 76
Fixes: 32
Registered: ‎25-02-2019

Re: Great speeds, and terrible speeds?

Hi @Bolter2, sorry to hear you're having connection issues.

 

Let us know if the changes made have done the trick.

If this post resolved your issue please click the 'This fixed my problem' button
 Faris
 Plusnet Help Team