cancel
Showing results for 
Search instead for 
Did you mean: 

Fibre broadband has issues loading websites completely. Connection issues partway through page loads

SwordAl
Newbie
Posts: 4
Registered: 08-08-2016

Fibre broadband has issues loading websites completely. Connection issues partway through page loads

My Unlimited Fibre Extra broadband has been acting up for about week. Symptoms:

  • I do a mybroadbandspeed.co.uk test and get the expected 75 Mbps down, 19 Mbps up but a lot of times when browsing I have to refresh the browser multiple times to get a page to load fully or at all.
  • Android apps have issues loading content when on wifi, but switching to mobile data solves the issues instantly. Even when a page loads properly there is usually a long delay at the start of the initial page loading.
  • Streaming sites sometimes need refreshes to get the stream started, however once the stream has started it is solid and mostly smooth.
  • Chrome often shows Connecting... in the bottom left for a long time before doing anything at all.
  • Windows and Android themselves haven't complained about connection issues when on the network.

I have the standard Plusnet router (Technicolor TG582n FTTC) with Openreach modem and one of the new Openreach wall telephone sockets.

I haven't made any recent changes to router settings, and have restarted the router and Openreach modem multiple times.

The issue is with both wired and wireless Windows 10 PCs and also wifi mobile devices. My main PC is wired and is the one which I've been testing with.

I have tested in multiple desktop browsers (Chrome and Edge) and Android Chrome and the issues persist across all.

Also, no issues exist when connected to a VPN, so it is definitely an issue with Plusnet and not my hardware.

Attached are some screenshots of Edge and Chrome dev console complaining about network issues and failing to load resources. My IP address is in the 51.6.* range, which I notice has had many complaints in the past month.

Can a Plusnet rep help me please? Many thanks.

 

Edit: I've now reported the issue officially but any additional advice here would be great.

4 REPLIES
SpendLessTime
Aspiring Hero
Posts: 2,376
Thanks: 585
Fixes: 53
Registered: 21-09-2009

Re: Fibre broadband has issues loading websites completely. Connection issues partway through page l

@SwordAl

Welcome to the forums.

Some people have found that buying a static IP from Plusnet solves the problem (but not everyone as one or two say the problem came back after a few weeks).

The cost of a static IP is £5 (one off fee) and gets setup within hours.

You would just need to log onto the router and disconnect/reconnect to get the new static IP working for you once it has been setup.

The static IP alters how you are connected through the Plusnet network and that seems to be the solution for most people.

SwordAl
Newbie
Posts: 4
Registered: 08-08-2016

Re: Fibre broadband has issues loading websites completely. Connection issues partway through page l

@SpendLessTime

Thanks for the advice, I think I'll hold off on that until I hear back from support. I don't think I should have to pay extra money to have a decent connection when I'm already paying for their top service tier.

leaharmes
Newbie
Posts: 3
Registered: 09-02-2017

Re: Fibre broadband has issues loading websites completely. Connection issues partway through page l

I also have the same issue. Did the OP find a resolution? Thank you
SpendLessTime
Aspiring Hero
Posts: 2,376
Thanks: 585
Fixes: 53
Registered: 21-09-2009

Re: Fibre broadband has issues loading websites completely. Connection issues partway through page l

@leaharmes

I have no idea (just a customer like you) but this issue was a specific one last year (solved by Plusnet in November by infrastructure changes in the network)  so I doubt you have this very specific issue.

 

Your symptoms maybe similar but not with the same solution.

Perhaps you could start your own thread and list the symptoms, the hardware involved and what you have done to try and solve it.