cancel
Showing results for 
Search instead for 
Did you mean: 

Connection/set up fault

woodzy
Newbie
Posts: 2
Registered: 21-02-2018

Connection/set up fault

Hi guys

My internet speed (i think ) is not too bad for my area, i get about 35-45 down & about 5 upload. The problem i'm having is my ping is very high, about 130+ & that makes a big difference while online gaming. I'm wondering if the issue may be the set up that i have inherited. The master socket comes into the kitchen (which is not ideal) and there is a phone line extension running from the master socket round the back of the kitchen cupboards then through a wall into another type master socket in the living room, about 10m or so & then i have the filter on for phone & hub one. Unfortunately i cant plug the hub one into the master socket in the kitchen to check if that makes a difference as the last time an engineer was at my property he hard wired the extension into the master socket & informed me the socket itself could now not be used. I also know that its not my PC as this is a new custom built gaming PC i had built a couple of months ago, & i've also disconnected the firewall & my anti-virus software to try that. All the correct ports are forwarded/opened to what i need on the hub one as well. If i unplug the hub one for a minute or so the ping drops a little & gaming lag is reduced for a couple of days or so then it starts again & i have to unplug the hub once again, but surely i shouldn't need to be doing that every few days or so.

Any help/input from someone would be greatly appreciated Smiley

Andy       

3 REPLIES
Highlighted
Baldrick1
Seasoned Champion
Posts: 1,427
Thanks: 620
Fixes: 49
Registered: 30-06-2016

Re: Connection/set up fault

Welcome to the forum.

Can you borrow a different router to try? There is a very large range that work without issues on the Plusnet/BT infrastructure - you will find the connection details here:  https://www.plus.net/help/broadband/broadband-connection-settings/?_ga=2.224541082.1837326321.152111...

If you look at this forum 'Router' board you will find more information on members preferred device. 

woodzy
Newbie
Posts: 2
Registered: 21-02-2018

Re: Connection/set up fault

Thanks for the reply Baldrick

Unfortunately, I don't have a access to another router/modem. Though i did ponder if it was worth buying my own one, but then thought why when Plus Net provide one that's supposed to be good enough  

Plusnet Help Team
Plusnet Help Team
Posts: 8,326
Thanks: 2,534
Fixes: 414
Registered: 21-04-2017

Re: Connection/set up fault

Hi Andy.

Sorry to hear you're experiencing latency issues.

Can you try factory resetting the router? It might also be useful if you can run a traceroute to the gaming server you're having issues with and/or pingbox1.thinkbroadband.com?

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team