cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco 887VA to replace both routers but Slow Download/Upload

shayne
Newbie
Posts: 4
Registered: 05-08-2007

Cisco 887VA to replace both routers but Slow Download/Upload

Hi Everyone, I recently joined plusnet and using the BT openreach router and the supplied plusnet router I was able to achieve 52mb down and around 18mb upload. This was consistent across various speed test websites.
I have now replaced both routers with a Cisco 887VA and configured it the best I can however the best speed I can get is about 18mb down and 3-4mb up.
It's like it's an ADSL connection and not fibre! As soon as I plug the old routers in then I get full speed again.
Could somone please look at my config below and please advise,
Thanks
Shayne

Building configuration...
Current configuration : 5374 bytes
!
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login default local
!
aaa session-id common
memory-size iomem 10
!
crypto pki trustpoint TP-self-signed-1584283943
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1584283943
revocation-check none
rsakeypair TP-self-signed-1584283943
!
!
crypto pki certificate chain TP-self-signed-1584283943
certificate self-signed 01
 3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
 31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
 D954924B CCA37141 2FD5A7BF 50DD75
       quit
!
ip dhcp excluded-address 192.168.0.1 192.168.0.10
ip dhcp excluded-address 192.168.0.50 192.168.0.255
!
ip dhcp pool HOME
network 192.168.0.0 255.255.255.0
default-router 192.168.0.2
dns-server 192.168.0.2 192.168.0.203 8.8.8.8
lease 0 8
!
no ip domain lookup
ip domain name yourdomain.com
ip ips config location flash:/IPS retries 1
ip ips notify SDEE
ip ips name sdm_ips_rule
!
ip ips signature-category
 category all
  retired true
 category ios_ips basic
  retired false
!
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid CISCO887VA-K9 sn FG*********
license boot module c880-data level advipservices
!
!
username admin privilege 15 secret 5 $1$IJSC$l********.
!
crypto vpn anyconnect flash:/webvpn/sslclient-win-1.1.4.179-anyconnect.pkg sequence 1
!
crypto vpn csd flash:/webvpn/sdesktop.pkg
!
crypto key pubkey-chain rsa
named-key realm-cisco.pub
 key-string
  30820122 300D0609 2A864886 F70D0101 01050003 82010F00 3082010A 02820101
 quit
!
controller VDSL 0
firmware filename flash:vdsl.bin-35d_d23j
modem ukfeature
!
ip ssh version 2
!
interface Ethernet0
no ip address
!
interface Ethernet0.101
encapsulation dot1Q 101
ip virtual-reassembly in
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
no ip address
duplex full
speed 100
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface Vlan1
ip address 192.168.0.2 255.255.255.0
ip nat inside
ip ips sdm_ips_rule in
ip ips sdm_ips_rule out
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
interface Dialer0
description Infinity
mtu 1508
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname **********@plusdsl.net
ppp chap password 0 ************
ppp pap sent-username ***********@plusdsl.net password 0 **********
ppp ipcp header-compression ack
ppp ipcp dns request
ppp ipcp address accept
no cdp enable
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list 1 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 1 permit 192.168.0.0 0.0.0.255
no cdp run
!
control-plane
!
line con 0
no modem enable
line aux 0
line vty 0 4
privilege level 15
transport input telnet ssh
!
!
end
7 REPLIES
pwatson
Rising Star
Posts: 2,468
Thanks: 8
Fixes: 1
Registered: 26-11-2012

Re: Cisco 887VA to replace both routers but Slow Download/Upload

Is mtu 1508 in the dialler section right?
shayne
Newbie
Posts: 4
Registered: 05-08-2007

Re: Cisco 887VA to replace both routers but Slow Download/Upload

I've tried the MTU as 1452, 1500 and 1508  which are all figures that other users have had in there configs and worked fine. I'm not sure what plusnet recommend for this setting
Changing this makes no difference to the speed so far  Angry
Community Veteran
Posts: 6,366
Thanks: 490
Fixes: 45
Registered: 30-07-2007

Re: Cisco 887VA to replace both routers but Slow Download/Upload

You might find this  https://damn.technology/cisco-887va-vdsl2-throughput infomative
shayne
Newbie
Posts: 4
Registered: 05-08-2007

Re: Cisco 887VA to replace both routers but Slow Download/Upload

My config is pretty much the same as everyone elses with this router, It's got to be something specific relating to plusnet settings like PVC etc. I tried adding the following today on my dialer0 interafce:
atm vc-per-vp 128
no atm ilmi-keepalive
pvc 0/38
  oam-pvc 0
  encapsulation aal5mux ppp dialer
This made it worse and was down to 5mb down / 300k up so these settings are having an effect. Does anyone know what the PVC settings are for VDSL/FIBRE ?
redhedgehog42
Grafter
Posts: 48
Registered: 19-12-2014

Re: Cisco 887VA to replace both routers but Slow Download/Upload

Just a thought, you state you recently joined Plusnet and that your initial speeds with the Openreach Modem and Plusnet Router were much higher th they are now with the Cisco kit. If you have just gone on to FTTC and been changing things a lot with many router/modem restarts is it possible that either you haven't let the line to settle down for its initial 10 days to get a consistant speed or that you have inadvertently triggered DLM.
Maybe I'm barking up the wrong tree but reverting back to the Openreach/Plusnet kit and then leaving things alone for a while might be an idea worth thinking about.
shayne
Newbie
Posts: 4
Registered: 05-08-2007

Re: Cisco 887VA to replace both routers but Slow Download/Upload

I wish it was that simple. As soon as I plug the plusnet router in and the white BT open reach modem I get 55mb down and 20mb up consistently!
Community Veteran
Posts: 1,829
Thanks: 93
Fixes: 5
Registered: 21-01-2013

Re: Cisco 887VA to replace both routers but Slow Download/Upload

Quote
interface Dialer0
description Infinity
mtu 1508

Did you try a MTU of 1492  ?
That's the ususal size for VDSL2 and matches the mss of 1452