cancel
Showing results for 
Search instead for 
Did you mean: 

Can't connect to hosts (PC) in LAN

Highlighted
sergiuterman
Newbie
Posts: 1
Registered: 3 weeks ago

Can't connect to hosts (PC) in LAN

Hi,

I've been trying to spin a small http server to be accessed in LAN. I started it on my MacOS laptop and I tried to access it from a different PCs and a mobile phone. Unfortunately it failed.

I made sure the server is running on 0.0.0.0 network. Tested by accessing the website using the LAN ip 192.168.1.X:8000.

After some digging I turned off the router firewall. I tried to ping other PC host's in LAN and it timesout. Here are the following scenarios:

* MacOS ping -> Windows machine (failed, timeout)

* Windows ping -> MacOS (failed, timeout)

* Phone ping -> MacOS (failed, timeout)

* MacOS ping -> phone (success)

 

So apparently I can't ping/access only laptops in LAN. So I thought it might be related to firewall, however the firewall on my MacOS is disabled.

 

Being stuck I tried setting up port forwarding, although I know it's not the case since I can't access the hosts in LAN.

 

All the pinging was done using IP's . So no, host configs nor DNS issues there. I hit a dead end here.

I'm using the following router: Plusnet Hub One | Software version 4.7.5.1.83.8.259
 
PS: Not being able to do port forwarding on custom ports is somewhat annoying. To get a port, I had to do manual lookup of Diablo II default port(s) and try to run my server on those.