cancel
Showing results for 
Search instead for 
Did you mean: 

Broadband speed is consistently low.

SteveH52
Newbie
Posts: 2
Registered: ‎19-11-2017

Broadband speed is consistently low.

The line speed has been consistently low for 3 weeks now, 15 to 17 mbps, maybe coincidentally since receiving notification that upload speeds would be increased the download speed has halved. Using various speed tests generally available on the internet AND Plusnet's own speed checker, it is less than half that stated on my contract details which says my line speed is 38 mbps and there are no issues. All the recommended checks have been done, the hub is plugged directly into the socket. I know that lines are subject to fluctuation but this is consistent and not what I was led to expect when they started the contract. Getting to talk to someone is nigh on impossible despite the ongoing fluff in the TV advertising. What can I do next other than vote with my feet?

2 REPLIES
Plusnet Help Team
Plusnet Help Team
Posts: 9,221
Thanks: 2,907
Fixes: 461
Registered: ‎21-04-2017

Re: Broadband speed is consistently low.

Apologies for the delayed response.

Your router seems to be in sync at 40mbps still. Are you testing over a wired or wireless connection?

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team
SteveH52
Newbie
Posts: 2
Registered: ‎19-11-2017

Re: Broadband speed is consistently low.

Hi, I tested this morning, a few moments ago and the Broadband speed checker tells me that I have 17.15 mbps download, now how can the method of connection affect my download speed and not the upload speed which remains stable at above 9 mbps? Nothing has changed in my configuration. The wireless connection remains at 10 metres and signal strength shows a full bar rating.The readings I have obtained over the last few of days are as follows:

Which 17.9 and 9.1

U Switch 14.8 and 9.2

Your own checker 5.08 and 9.22

 How can you say it is syncing at 40mbps when I get no-where near this. 

Also, I have replaced the ADSL filter, one you sent and one BT supplied, plus, I have tried via the junction test socket though which the hub is connected directly. 

rgds