cancel
Showing results for 
Search instead for 
Did you mean: 

Broadband keeps dropping out and packet invalid in connection messages.

user2455
Newbie
Posts: 3
Registered: ‎24-03-2021

Broadband keeps dropping out and packet invalid in connection messages.

A second attempt atposting this .... 

The broadband keeps cutting out and we have tried re-setting the router. The log shows loads of dropped packets and tcp errors - does any one have any suggestions of what to do?

A small extractof the invalid connection items in the log.

16:51:51, 24 Mar. IN: BLOCK [9] Packet invalid in connection (Invalid tcp flags for current tcp state: TCP [23.207.186.145]:443-​>[80.189.45.133]:54200 on ppp3)
16:51:50, 24 Mar. OUT: BLOCK [9] Packet invalid in connection (tcp reset attack is suspected: TCP [192.168.1.66]:57105-​>[104.22.57.130]:443 on ppp3)
16:51:35, 24 Mar. IN: BLOCK [9] Packet invalid in connection (Invalid tcp flags for current tcp state: TCP [23.207.186.145]:443-​>[80.189.45.133]:54200 on ppp3)
16:51:33, 24 Mar. ath10: STA 9e:48:8c:1e:33:eb IEEE 802.11: Client disassociated
16:51:30, 24 Mar. (12089.080000) Lease for IP 192.168.1.100 renewed by host iPhone (MAC 9e:48:8c:1e:33:eb). Lease duration: 720 min
16:51:30, 24 Mar. (12089.080000) Device connected: Hostname: iPhone IP: 192.168.1.100 MAC: 9e:48:8c:1e:33:eb Lease time: 720 min. Link rate: 433.3 Mbps
16:51:30, 24 Mar. (12088.990000) Lease requested
16:51:30, 24 Mar. ath10: STA 9e:48:8c:1e:33:eb IEEE 802.11: Client associated
16:51:22, 24 Mar. BLOCKED 1 more packets (because of Packet invalid in connection)
16:51:20, 24 Mar. IN: BLOCK [9] Packet invalid in connection (Invalid tcp flags for current tcp state: TCP [23.207.186.145]:443-​>[80.189.45.133]:54199 on ppp3)
16:51:11, 24 Mar. ath10: STA 9e:48:8c:1e:33:eb IEEE 802.11: Client disassociated
16:51:10, 24 Mar. IN: BLOCK [9] Packet invalid in connection (Invalid tcp flags for current tcp state: TCP [52.113.194.132]:443-​>[80.189.45.133]:64151 on ppp3)
16:51:08, 24 Mar. (12067.000000) Lease requested
16:51:08, 24 Mar. ath10: STA 9e:48:8c:1e:33:eb IEEE 802.11: Client associated
16:51:00, 24 Mar. OUT: BLOCK [9] Packet invalid in connection (Invalid tcp flags for current tcp state: TCP [192.168.1.78]:54183-​>[23.36.211.194]:443 on ppp3)
16:50:45, 24 Mar. OUT: BLOCK [9] Packet invalid in connection (Invalid tcp flags for current tcp state: TCP [192.168.1.78]:54181-​>[23.36.211.247]:443 on ppp3)
16:50:26, 24 Mar. (12025.430000) Admin login successful by 192.168.1.78 on HTTP
16:50:20, 24 Mar. IN: BLOCK [9] Packet invalid in connection (Invalid tcp flags for current tcp state: TCP [23.207.186.145]:443-​>[80.189.45.133]:54179 on ppp3)
16:50:02, 24 Mar. (12001.310000) Device disconnected: Hostname: iPhone IP: 192.168.1.100 MAC: 9e:48:8c:1e:33:eb
16:50:00, 24 Mar. ath10: STA 9e:48:8c:1e:33:eb IEEE 802.11: Client disassociated
16:49:44, 24 Mar. (11983.230000) Lease for IP 192.168.1.100 renewed by host iPhone (MAC 9e:48:8c:1e:33:eb). Lease duration: 720 min
16:49:44, 24 Mar. (11983.230000) Device connected: Hostname: iPhone IP: 192.168.1.100 MAC: 9e:48:8c:1e:33:eb Lease time: 720 min. Link rate: 433.3 Mbps
16:49:44, 24 Mar. (11983.140000) Lease requested
16:49:44, 24 Mar. ath10: STA 9e:48:8c:1e:33:eb IEEE 802.11: Client associated
16:48:35, 24 Mar. IN: BLOCK [9] Packet invalid in connection (Invalid tcp flags for current tcp state: TCP [23.207.186.145]:443-​>[80.189.45.133]:54137 on ppp3)
16:47:51, 24 Mar. IN: BLOCK [9] Packet invalid in connection (Invalid tcp flags for current tcp state: TCP [23.207.186.145]:443-​>[80.189.45.133]:54112 on ppp3)
16:47:42, 24 Mar. OUT: BLOCK [7] ICMP replay (ICMP type 3 code 1 80.189.45.133-​>23.1.106.236

 

 

1. Product name: Plusnet Hub
2. Serial number: +081441+NQ93101891
3. Firmware version: Software version 4.7.5.1.83.8.263 Last updated Unknown
4. Board version: Plusnet Hub One
5. DSL uptime: 0 days, 03:19:19
6. Data rate: 2667 / 13079
7. Maximum data rate: 2670 / 16444
8. Noise margin: 6.2 / 9.4
9. Line attenuation: 39.0 / 29.4
10. Signal attenuation: 38.7 / 23.7
11. Data sent/received: 364.7 MB / 1.6 GB
4 REPLIES 4
ThyMinx
Newbie
Posts: 2
Registered: ‎16-01-2021

Re: Broadband keeps dropping out and packet invalid in connection messages.

let me know when they figure it out, I've been at them for months with this issue, did all the tests in the books. They gave me a new plusnet hub one and that doesn't fix it. They then gave me £35 and told me to get a third party party router. This led to me getting a TP-Link VR400 AC1200 v3 (EU). Supposedly compatible with plusnet according to the sticker on the packaging. I still have the same issue of drop outs. The errors that pop up are PPP0 user requests and DSL training/DSL Down. The BT openreach engineers can't find anything wrong and I believe the reason being is because the issue is plusnet sound out a signal which checks for updates or reassigns an IP address or something like that. BT do the same thing (who actually are the same company as plusnet). TP Link claim to be aware of this issue and released a beta firmware to people in the end of 2020 and upon reaching out to them they released a firmware update to deal with this issue (which some people claim it works) and yet I still encounter the same issue every other day, sometimes every day. it's always in the late evenings when the drop outs occur and they can't test the line in those times.

 

good luck on getting it fixed but at this rate I'm thinking of trying to get out of my contract because it's ridiculous. I need a reliable stable internet connection as I'm trying to become a streamer and I'm trying to target an american audience which means late night/early morning is the biggest time I need to be working yet here I am dropping connection midstream.

Dan_the_Van
Pro
Posts: 502
Thanks: 53
Fixes: 6
Registered: ‎25-06-2007

Re: Broadband keeps dropping out and packet invalid in connection messages.

Hi @user2455 

IN: BLOCK and OUT: BLOCK messages are not your connection issues but the Hub One Firewall reporting its actives and can be ignored as this is expected.
However the log extract does show iPhone (MAC 9e:48:8c:1e:33:eb) repeatedly dropping and reconnecting to the 5Ghz WiFi (ath10) which might be your issue
My first suggestion would be to turn off the 5Ghz WiFi to see if this improves things, the second suggestion would be to remove the sync WiFi networks and give them separate SSID names if you want to keep using 5Ghz

Also take a read of https://community.plus.net/t5/My-Router/Hub-One-5GHz-WiFi-issue/m-p/1696363#M15510

For the event log if you select WAN from the drop down you will see how often the DSL is connecting if there are many (not as a result of a power reset) then some further connection checks will be necessary, report back further if you want further help.

@ThyMinx 

Are you running the latest version of the firmware for you VR400? I'd suggest contacting TP-Link support for your problems.

Dan.

 

user2455
Newbie
Posts: 3
Registered: ‎24-03-2021

Re: Broadband keeps dropping out and packet invalid in connection messages.

Thank you for the response - I have turned off the 5 ghz wireless to see if it improves things. The 2.4 ghz and 5 ghz networks were already un-synced and with separate SSID names.   I have extended the DHCP lease as suggested in the article. 

ThyMinx
Newbie
Posts: 2
Registered: ‎16-01-2021

Re: Broadband keeps dropping out and packet invalid in connection messages.

Hey @Dan_the_Van 

Yeah I've contacted them but the issue started with the plusnet hub one, the same issue occurs with the tp-link so i'm not going to lie the only common factor is ISP (being plusnet) and PPP0 (the error that crops up on plusnet hub one and tp-link). Same issue, different devices. That's why I'm trying to get a fix out of someone from both plusnet and tp-link.