cancel
Showing results for 
Search instead for 
Did you mean: 

BT Home Hub 6A not connecting on Plusnet

FIXED
Highlighted
Newbie
Posts: 3
Fixes: 1
Registered: a month ago

BT Home Hub 6A not connecting on Plusnet

Just been given a BT Home Hub 6A so decided to try it on my fibre Plusnet network. Have followed advice on this forum by changing user name & password to no avail. Any ideas would be welcomed to resolve issue. Thanks
3 REPLIES 3
Highlighted
Hero
Posts: 4,887
Thanks: 2,108
Fixes: 140
Registered: ‎30-06-2016

Re: BT Home Hub 6A not connecting on Plusnet

@Route66 Welcome to the forum. 

There are two things that can stop it connecting.

1. Older firmware versions (which updates when it connects) will not work if you have a special character in your Plusnet password. Ignore Plusnet and just use alpha numeric characters for this.

2. You plug the DSL cable in too early. This must not be connected until you have entered your Plusnet user name and password and it's trying to connect.

Highlighted
Newbie
Posts: 3
Fixes: 1
Registered: a month ago

Re: BT Home Hub 6A not connecting on Plusnet

Thanks for the info Baldrick.

I shall try again later this morning after a good nights sleep, and will let you know of my progress.

Highlighted
Newbie
Posts: 3
Fixes: 1
Registered: a month ago

Re: BT Home Hub 6A not connecting on Plusnet

Fix

Thanks again Baldrick for pointing me in the right direction.

It was the Plusnet password at fault. Once I changed my account log in on the Plusnet web site, then entered my new password in the router all went well.