cancel
Showing results for 
Search instead for 
Did you mean: 

Apple iMac and Macbook show wifi and ethernet by no internet

Highlighted
Dabbler
Posts: 14
Registered: ‎02-03-2020

Re: Apple iMac and Macbook show wifi and ethernet by no internet

I know I can do that from my desk top but I have no internet connection! All my messages to you are via my phone on 4G.
Highlighted
Moderator
Moderator
Posts: 23,474
Thanks: 4,007
Fixes: 1,026
Registered: ‎11-01-2008

Re: Apple iMac and Macbook show wifi and ethernet by no internet

but you could airdrop it if you have an iphone
Customer / Moderator
If it helped click the thumb
If it fixed it click 'This fixed my problem'
Highlighted
Pro
Posts: 291
Thanks: 209
Fixes: 1
Registered: ‎27-12-2019

Re: Apple iMac and Macbook show wifi and ethernet by no internet

I have found that when IPv6 is enabled on the Mac is doesn't always play well. So @CaptainE if you would like to turn this off you can do so using the following.

sudo networksetup -listallnetworkservices
Password:
An asterisk (*) denotes that a network service is disabled.
Ethernet
Љ 2
Љ
MT65xx Preloader 2
MT65xx Preloader
USB ACM
MT65xx Preloader 3
USB Controls
MT65xx Preloader 4
Display Ethernet
LAN-2
iPad USB
Display FireWire
Wi-Fi
Bluetooth PAN
Thunderbolt Bridge
Mook@iMac ~ % 


From the list select the network(s) you want (in my case, Ethernet and WiFi) then use:

sudo networksetup -setv6off Ethernet
sudo networksetup -setv6off WiFi


If you want to re-enable these at any time use

sudo networksetup -setv6automatic Ethernet
sudo networksetup -setv6automatic WiFi


You will need admin rights to do any of this.

Highlighted
Plusnet Help Team
Plusnet Help Team
Posts: 17,232
Thanks: 5,301
Fixes: 900
Registered: ‎21-04-2017

Re: Apple iMac and Macbook show wifi and ethernet by no internet

Thanks for your posts @CaptainE and apologies for the delayed staff response. I'd firstly second dvorak's initial response at splitting the 2.4GHz and 5GHz wireless frequencies as these appear to be merged together into a single network name although I'm unsure if you've historically made the change, tested things and then reverted back.

I'd also second Mook's suggestion at switching IPv6 off as this feature on older Mac's tend to not play well with some routers, although that's most commonly on OS X Snow Leopard or earlier and our Hub Zero routers. An easier way to do this without going into the Terminal would be follow the below steps:

  1. Go to System Preferences from the dock bar at the bottom of your screen
  2. Click on Network
  3. Select Ethernet and click on Advanced
  4. Click on the TCP/IP tab
  5. From the drop-down menu on Configure IPv6, change this to Off
  6. Click on the OK button and acknowledge any prompts you get to save the changes
  7. Repeat the above steps selecting Wi-Fi at step 3 rather than Ethernet

For good measure, I've tested your line and the tests are showing everything's OK with the line itself.

Let us know how you get on. Smiley

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team