cancel
Showing results for 
Search instead for 
Did you mean: 

Am I missing something obvious?

Zoidberg21
Newbie
Posts: 1
Registered: 07-12-2015

Am I missing something obvious?

I've had Plusnet Fibre Broadband since March this year and it ran great with no hassle whatsoever up till now.
It seems that due to a mix up between BT Openreach and Plusnet the upgrade paperwork was never closed off so they cancelled the order and sadly my fibre service was disabled over a week ago.
In the meantime Plusnet have got me set up for ADSL operation again until I can be given the fibre broadband that I'm still paying for.
I seem to be getting download speeds of around 13Mbps and uploads of 0.8Mbps but do not seem to have anything like a decent internet browsing capability.
I can load up google search instantaneously but thereafter I can hardly load up anything at all.
Very common internet sites that I used frequently such as Amazon never seem to load up anymore and I just can't figure out why.
It doesn't seem to matter whether I surf wirelessly on an iPad, android tablet or even a PC that is hardwired to the router (all of which worked great before).
Curiously, you tube works perfectly and my email is working fine but sadly internet browsing is a dead loss.
Can anyone please tell me what the problem is likely to be because I'm kinda stuck?
Update :-
This evening I've now tried a few different DNS server addresses but this did not help. The only thing that enabled me to load up basic sites like amazon uk was to set up an online proxy server.
I decided to try an old Thomson V585 router instead of my new plusnet one with the little pink feet and guess what everything works now!
I'm baffled why but there you go... 
1 REPLY
Plusnet Help Team
Plusnet Help Team
Posts: 12,982
Thanks: 141
Fixes: 46
Registered: 27-04-2007

Re: Am I missing something obvious?

It sounds like trying a different router would be wise as the next step, especially as you've tried alternate DNS and that some services like streaming seem to work fine.
If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team