cancel
Showing results for 
Search instead for 
Did you mean: 

2 weeks, broadband still slow

Highlighted
Newbie
Posts: 4
Thanks: 1
Registered: ‎25-09-2020

2 weeks, broadband still slow

I have signed up to fibre broadband, looking to get a speed of 30mb/s on average. Currently getting around 6mb/s. I have waited the 10 day recommended period for the broadband speed to settle. I have checked the broadband speed using the methods recommended by Plusnet, all show a slow speed.

 

I have also tried using an ethernet cable and connecting it to my laptop, whilst turning off all other devices using the wifi, to see whether there would be any effect. Thus far, nothing has worked.

 

Any sugesstions?

3 REPLIES 3
Highlighted
Moderator
Moderator
Posts: 24,383
Thanks: 4,337
Fixes: 1,114
Registered: ‎11-01-2008

Re: 2 weeks, broadband still slow


Moderators Note


This topic has been moved from ADSL Broadband to Fibre

Customer / Moderator
If it helped click the thumb
If it fixed it click 'This fixed my problem'
Highlighted
Aspiring Pro
Posts: 209
Thanks: 29
Fixes: 4
Registered: ‎28-09-2020

Re: 2 weeks, broadband still slow

Is your router plugged into the master telephone socket? Try using the test socket: https://community.plus.net/t5/Library/Testing-From-The-Master-Socket/ba-p/1322242

Check your speed after and if there’s no change to where you’d expect the speed, it could be worth reporting a fault at faults.plus.net

This will create a fault ticket and get you into the queue for Plusnet to investigate further.

Highlighted
Hooked
Posts: 5
Thanks: 1
Registered: ‎16-10-2020

Re: 2 weeks, broadband still slow

I have had continuing problems like yours throughout this year. Previously I reliably got 28 Mbits down, but it has been all over the shop throughout the year so far. I have now had five engineer visits and each time it improves a bit only to drop back again. At present it is sitting at just under 20 Mbits which is pretty good compared to what it has fallen to on occasion (as low as 4 Mbits) but still a bit disappointing.

The last engineer replaced the master socket and that put it up from about 12 Mbits to its current speed, but I think the problem is that sending broadband across copper connections is inherently problematic. All it takes is a slightly high-impedance joint between your master socket and the cabinet for the speed to drop off, and finding out which joint is causing the problem takes a lot of time for the OR engineer and in my experience they don't spend the time needed. They just fiddle about a bit, reset the line and it gets better for a while.

The answer really if you want or need high speed and reliable internet is FTTP, and FTTC is always going to be a problem. Until we all have FTTP we will struggle to reliably get decent broadband when any copper is involved, IMHO.