cancel
Showing results for 
Search instead for 
Did you mean: 

htaccess problem ?

mouseblack
Dabbler
Posts: 17
Thanks: 1
Registered: ‎17-03-2008

htaccess problem ?

until earlier yesterday my www.mydomain.co.uk was working in that an htaccess file was redirecting the domain name to a folder on my ccgi space.
Or at least the last I knew I had an htaccess file!
Earlier yesterday I upgraded to WordPress 3.1 and immediately everything broke.
I started getting a 500 error - I seemed to have solved that. It seemed that there was no htaccess file in the root directory but then I realised that Filezilla had somehow turned off the 'force showing hidden files'. Because there didn't appear to an htaccess file I uploaded one probably overwriting an existing one.
Now I'm getting a a 403 error.
I can navigate to ccgi.username.co.uk/folder but curiously in the location bar displays www.mydomain.co.uk/~username/folder
Here's my htaccess:
RewriteEngine on
RewriteBase /
RewriteCond %{HTTP_HOST} ^www\.534\.co\.uk$ [nc]
RewriteCond %{REQUEST_URI} !^/~username/534/
RewriteRule (.*) /534/$1
Any ideas?
Thanks
Paul
5 REPLIES 5
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,370
Fixes: 75
Registered: ‎06-04-2007

Re: htaccess problem ?

That .htaccess file content looks OK to redirect to a folder. Are the permissions on that file 0640 so that Apache can read it?
Getting a 403 error suggests file permissions haven't been set correctly. After you updated WordPress did you reset file and directory permissions again (eg using Gabe's script)?
David
mouseblack
Dabbler
Posts: 17
Thanks: 1
Registered: ‎17-03-2008

Re: htaccess problem ?

thanks for that spraxyt.
File permissions on the root htaccess is 640
Haven't used Gabe's script but my permissions on the WordPress install are such that when I navigate to www.mydomain.co.uk/~username/folder/ the website works even with the root htaccess enabled
But navigating to www.mydomain.co.uk results in the access forbidden 403 error.
Sad
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,370
Fixes: 75
Registered: ‎06-04-2007

Re: htaccess problem ?

Does it work if you add a / on the end of the domain name, ie www.mydomain.co.uk/ to avoid the trailing slash problem?
David
mouseblack
Dabbler
Posts: 17
Thanks: 1
Registered: ‎17-03-2008

Re: htaccess problem ?

hi spraxyt,
adding a / doesn't work.
mydomain.co.uk (i.e. without www) with and without the / also don't work
mouseblack
Dabbler
Posts: 17
Thanks: 1
Registered: ‎17-03-2008

Re: htaccess problem ?

bloody typo !
it's working now
thanks