cancel
Showing results for 
Search instead for 
Did you mean: 

ccgi webspace problems

clikkaboy
Newbie
Posts: 2
Registered: ‎25-03-2008

ccgi webspace problems

I'm trying to get a Textpattern CMS site working on my webspace http://ccgi.weebleville.plus.com/erme
The first issue is that I can't get the pictures to display, they just come up with red crosses.  They are in a folder called images within the above site, but won't even display if you paste the absolute path into a browser?  However, they do work if I remove the .htaccess file (which is meant to be there).
The other issue is that Textpattern is telling me to turn register globals off, which I did in the .htaccess file, but to no avail.  The helpdesk said that it is a server die setting and they need to do it?
I've used Textpattern for a while with three other hosting provides and never had an issue until I tried to I'd my ccgi webspace.
Thanks for the help in advance!
2 REPLIES 2
Peter_Vaughan
Community Veteran
Posts: 14,469
Registered: ‎30-07-2007

Re: ccgi webspace problems

PlusNets CCGI webspace has been made very secure meaning a lot of things will not work 'out of the box' as a result.
You can't change register_globals in .htaccess along with a lot of other server side php parameters due to the security and also due to the fact the PlusNet run PHP in cgi mode meaning .htaccess is ignored when running a php file.
Posting what you have in .htaccess would help.
PlusNet use *nix based hosting meaning paths are case sensitive ulike a lot of other hosting which uses WIndows and is not case sensitive. So make sure you always use lower case for file and directory names.
clikkaboy
Newbie
Posts: 2
Registered: ‎25-03-2008

Re: ccgi webspace problems

Thanks Peter - here's the htaccess contents.
.htaccess file contents:
------------------------
#DirectoryIndex index.php index.html
#Options +FollowSymLinks
#Options -Indexes
<IfModule mod_rewrite.c>
RewriteEngine On
#RewriteBase /relative/web/path/
RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^(.+) - [PT,L]
RewriteRule ^(.*) index.php
</IfModule>
#php_value register_globals 0