cancel
Showing results for 
Search instead for 
Did you mean: 

ccgi down

yellowduck
Newbie
Posts: 6
Registered: ‎16-03-2010

Re: ccgi down

Yes, .htaccess problem. Can someone with more experience comment on the merits/issues of
DirectoryIndex index.php
<FilesMatch "\.(php|inc)$">
Order allow,deny
deny from all
</FilesMatch>
<FilesMatch "(index.php|dl.php|ut.php|lt.php|download.php)$">
Order allow,deny
allow from all
</FilesMatch>
In particular, why it would have worked previously, but now fails.
Commented everything out, and access granted.
Gabe
Community Veteran
Posts: 767
Registered: ‎29-10-2008

Re: ccgi down

Quote from: yellowduck

DirectoryIndex index.php

Is no longer allowed or necessary.
Gabe
yellowduck
Newbie
Posts: 6
Registered: ‎16-03-2010

Re: ccgi down

are there any change to the php mail() function?  My list is not sending messages. In general, is there anything in the changes that affects the sending of emails using php?
thanks.
cpcnw
Rising Star
Posts: 66
Thanks: 6
Fixes: 1
Registered: ‎10-08-2007

Re: ccgi down

My form mail seems to have stopped working - wouldtn have noticed this other than I made minor ammendments this morning?
Is this due to recent situ with cgi servers?
bobpullen
Community Gaffer
Community Gaffer
Posts: 15,016
Thanks: 2,658
Fixes: 170
Registered: ‎04-04-2007

Re: ccgi down

Quote from: Tony
Seems to be running incredibly slowly and sometimes completing (sometimes giving up) on anything with included files (e.g. PHP common subroutine file).
Getting variables with $_POST does not pick up the variables sent with a form:
<form name="form1" method="post" action="<?=$PHP_SELF?>">
Worked before for 5 years.
Any ideas welcome...

We're looking at a problem with POST variables Tony following the post here (ref: 300211).
@cpcnw @yellowduck we're looking into the php mail() issues now (ref: 300230)...

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

Gabe
Community Veteran
Posts: 767
Registered: ‎29-10-2008

Re: ccgi down

Quote from: Bob
We're looking at a problem with POST variables Tony

Try turning register_globals = Off using the php.ini file I sent you.
Edit: sorry, that's addressed to Tony. I also posted one somewhere round here.
Gabe
Ben_Brown
Grafter
Posts: 2,839
Registered: ‎13-06-2007

Re: ccgi down

It's not a problem with $_POST per se, but with $_SERVER['PHP_SELF']. With the way the current system works it comes out as /~username/script rather than /script. For security we redirect any direct requests in that format to the correct address, if we didn't do this it would provide a very easy way for people to use XSS type attacks on the platform. As this is a redirect, rather than an internal rewrite, it doesn't preserve the POST data.
We're looking in to fixing it, in the mean time if you want to just get it working try using $_SERVER['SCRIPT_URL'] instead.
pcr
Dabbler
Posts: 10
Registered: ‎16-03-2010

Re: ccgi down

Hello,
I have just uploaded an installation of Joomla-prepared website to our CGI webspace. When I try to run/see it, browser returns
Error message:
Premature end of script headers: index.php

I create & upload the php_test.php which consists of 3 lines
<?php
phpinfo();
?>

Same thing. I have tried setting permissions to both files to near-any combination, but nothing solves the problem.
I tried to read through suggestions here, but to be honest, I understand next to nothing about this. Quite simply, what exactly do I need to do (I only have FTP access and downloaded Joomla installation) to make the PHP scripts run, if not even phpinfo() won't return the parameters? Plus.net tech support insists there is nothing they can do, and that everything I need is right here. I need to put up a Joomla version of our website ASAP.
Thanks in advance.
geraldholdswort
Grafter
Posts: 26
Registered: ‎09-10-2008

Re: ccgi down

I know that this is a busy time for you guys, and this may have already been answered - but I can't find an answer.
Basically, I can't get onto my ccgi space using any of my domain names. I get:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@plus.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
If I change permissions on the destination folder, I get Access Denied (or something similar). I haven't changed anything since before the server went down, so still have a .htaccess file to redirect the domain to the right folder. If I enter http://ccgi.username.free-online.co.uk/folder this works fine.
Cheers,
Gerald.
goober999
Newbie
Posts: 1
Registered: ‎16-03-2010

Re: ccgi down

Quote from: pcr
Hello,
I have just uploaded an installation of Joomla-prepared website to our CGI webspace. When I try to run/see it, browser returns
Error message:
Premature end of script headers: index.php

I create & upload the php_test.php which consists of 3 lines
<?php
phpinfo();
?>

Same thing. I have tried setting permissions to both files to near-any combination, but nothing solves the problem.
I tried to read through suggestions here, but to be honest, I understand next to nothing about this. Quite simply, what exactly do I need to do (I only have FTP access and downloaded Joomla installation) to make the PHP scripts run, if not even phpinfo() won't return the parameters? Plus.net tech support insists there is nothing they can do, and that everything I need is right here. I need to put up a Joomla version of our website ASAP.
Thanks in advance.

Hello,
I post this as a result of being referred to this forum from PlusNet's customer support department.
I am in exactly the same position as pcr, I have uploaded my Joomla! directories to the ccgi webspace and upon visiting my website, I receive the Error message posted above as many of you have. I also don't entirely follow some of the posts on here so I'm hoping perhaps a few of you tech guys can come up with a solution to this fairly quickly as I've not had a website for 6 days now!
with anticipation...
yellowduck
Newbie
Posts: 6
Registered: ‎16-03-2010

Re: ccgi down

I had similar. It is most likely a setting in your .htaccess file for the sites you are trying to access. In my case, I simply had to remove the line DirectoryIndex index.php.
Tony_W
Grafter
Posts: 745
Registered: ‎11-08-2007

Re: ccgi down

POST variables worked following Gabe's suggestion to include the register_globals = Off in a php.ini file.
Almost there now, just on last section trying to find out why a section of my PHP code no longer puts partial output on to the browser screen. That was why I thought PHP was executing incredibly slowly and timing out.
Thanks for all of the help guys - especially Gabe !!!
Tony
pcr
Dabbler
Posts: 10
Registered: ‎16-03-2010

Re: ccgi down

Quote from: yellowduck
I had similar. It is most likely a setting in your .htaccess file for the sites you are trying to access. In my case, I simply had to remove the line DirectoryIndex index.php.

I haven't even got the DirectoryIndex line in my .htaccess. Having looked a bit further what Gabe wrote on page 2, I tried to make the following changes
Commented out the line
RewriteRule ^(.*)$ index.php [F,L]

Changed
RewriteCond %{REQUEST_URI} !^/index.php

to
RewriteCond %{REQUEST_URI} !^/~<username>/index.php

and
RewriteRule (.*) /index.php

to
RewriteRule (.*) /~<username>/index.php

and uncommented
RewriteRule ^(.+[^/])$ $1/ [R,L]

No changes whatsoever.
Tony_W
Grafter
Posts: 745
Registered: ‎11-08-2007

Re: ccgi down

Can someone please confirm that the PHP server buffering arrangements are different in the new server?
flush() has no effect. The output (now) only appears when the PHP code has finished executing.
Tony
Gabe
Community Veteran
Posts: 767
Registered: ‎29-10-2008

Re: ccgi down

Quote from: Tony
POST variables worked following Gabe's suggestion to include the register_globals = Off in a php.ini file.

But Ben's is the more correct solution. You were using $PHP_SELF rather than $_SERVER['PHP_SELF'] and turning register_globals off kills $PHP_SELF, leaving your form with action="". That's an old trick to get a form to post to itself but not good html, so the substitution is better.
Gabe