cancel
Showing results for 
Search instead for 
Did you mean: 

Wordpress - rich text editor not showing in admin

mssavvy
Grafter
Posts: 34
Thanks: 3
Registered: ‎28-08-2010

Wordpress - rich text editor not showing in admin

Hi, I've had this problem before and can't remember how it was solved.  Installed wordpress on ccgi using the guide in this forum and the file permissions script.  However when I try and create a page/post, there is no rich text editor.  Is this a further file permission problem?  Many thanks in advance...
5 REPLIES 5
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Wordpress - rich text editor not showing in admin

If you display your admin profile is "Disable the visual editor when writing" checked?
David
mssavvy
Grafter
Posts: 34
Thanks: 3
Registered: ‎28-08-2010

Re: Wordpress - rich text editor not showing in admin

Hi
No it's not checked - I've already looked here!
Any other suggestions?  I know I've sorted this before on another site here but can't remember what I did...
Thanks
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Wordpress - rich text editor not showing in admin

Googling suggests this was a regular problem with WordPress releases around version 2.8.x. For instance here. However didn't spot any recent mentions. Are you using the current 3.1.3 version?
You could try *disabling* the visual editor and save the change. Log out and clear the browser cache, Then login and enable the editor again.
Corrupted files in the wp-admin or wp-includes folders appear to be another possibility. When you installed the package were all text files uploaded as ASCII? You could try an automatic re-install (run the permissions script again before returning to the dashboard if you try that).
David
mssavvy
Grafter
Posts: 34
Thanks: 3
Registered: ‎28-08-2010

Re: Wordpress - rich text editor not showing in admin

Hi
I am using the latest version of wordpress.  I've tried disabling, logging out and clearing cache - still not working.  All text files were uploaded as ASC11.  I'd rather not re-install if possible.  I'm sure it was something easy last time but can't find the old post - or maybe I used a live chat?  Will re-install if that is the case but anyone else had this problem???
Thanks
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Wordpress - rich text editor not showing in admin

Are the permissions on all files of types other than .php, .pl and .cgi (in particular .js (JavaScript) and image files) set to 0640? And directories at least 0710 (wp-content/upload and its subdirectories 0750)?
David