cancel
Showing results for 
Search instead for 
Did you mean: 

Wordpress help needed

locost
Newbie
Posts: 7
Registered: ‎05-11-2010

Wordpress help needed

I have installed wordpress and set folders to 710 php files to 700 etc however when I run install I get the following error
Warning: require_once(/share/storage/04/ya/yaptondesigns/wordpress/wp-includes/cache.php) [function.require-once]: failed to open stream: Permission denied in /share/storage/04/ya/yaptondesigns/wordpress/wp-includes/load.php on line 361
Fatal error: require_once() [function.require]: Failed opening required '/share/storage/04/ya/yaptondesigns/wordpress/wp-includes/cache.php' (include_path='.:/usr/share/php:/usr/share/pear') in /share/storage/04/ya/yaptondesigns/wordpress/wp-includes/load.php on line 361
Can someone tell me what I need to do to sort this out?
12 REPLIES 12
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Wordpress help needed

Those permissions work for me. However have you (literally) set permissions on *every* file to 700 as you said? Only executable files should have that permission; files that have to be read by the Apache server need permissions 640,
Also the permissions on the uploads folder within wp-content need to be 750 to ensure uploaded images can be seen - but installation needs to be completed before that matters.
David
locost
Newbie
Posts: 7
Registered: ‎05-11-2010

Re: Wordpress help needed

Al permissions have been set as per the following
All Folders (directories) should be set to 710
All Script files (.php) should be set to 700
All Static files (.htm .html .css .txt .png .jpg .gif .js) should be set to 640 (note javascript (.js) is treated as a text file by the server)
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Wordpress help needed

Those are correct.  Smiley
Do all your files and directories have group set to cgiusers?
David
locost
Newbie
Posts: 7
Registered: ‎05-11-2010

Re: Wordpress help needed

Do all your files and directories have group set to cgiusers?
Excuse my ignornace but I am new to this as far as I know yes but how do I check?
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Wordpress help needed

Login to the ccgi server using your usual FTP program. That should list files and directories. On the right hand side normally there are two columns showing the file/directory owner (which should be your username) followed by the group (which should be cgiusers),
David
locost
Newbie
Posts: 7
Registered: ‎05-11-2010

Re: Wordpress help needed

Thanks spraxyt have checked the files and  the file/directory owner (my username) followed by the group (cgiusers),
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Wordpress help needed

Sorry, I've run out of ideas.
Has installation of any packages such as this one been successful in your ccgi webspace?
David
locost
Newbie
Posts: 7
Registered: ‎05-11-2010

Re: Wordpress help needed

This is the first time I have tried to use the CGI I did have trouble logging on to it initially. The problem was eventually solved by plusnet resetting my password. Once the password was sorted I loaded wordpress and everything seemed fine till I tried to install it, hence my post

spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Wordpress help needed

The best way forward with this might be to start again from scratch. Delete all the WordPress files and directories from ccgi then upload them again. Make sure your FTP program is set to transfer type "auto" (or similar) so that text files are uploaded as ASCII, binary files as binary.
Then run the setperms.cgi program posted here to set file and directory permissions appropriately. (Did you use that last time?)
After that try the install script again.
David
locost
Newbie
Posts: 7
Registered: ‎05-11-2010

Re: Wordpress help needed

I deleted everything and reinstalled but still had the same problem so I deleted everything again and this time downloaded a fresh copy of wordPress everything now works fine  Thanks for your help spraxyt Cheesy
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Wordpress help needed

Glad to hear you got this working, and thanks for the feedback on what you had to do.
Don't forget that the directory /wordpress/wp-content/uploads needs permissions set to 750 (rather than 710). It's possible that this directory won't exist until something (eg an image) is uploaded, but if so I suggest creating it using your FTP program so that it is ready for uploads.
David
locost
Newbie
Posts: 7
Registered: ‎05-11-2010

Re: Wordpress help needed

Thanks spraxyt thats deffinetly worth a check before I start pulling my hair out again.