cancel
Showing results for 
Search instead for 
Did you mean: 

Wordpress frames causes trouble with the web address

ScottLangham
Newbie
Posts: 2
Registered: 31-08-2008

Wordpress frames causes trouble with the web address

Hi,
I've created a wordpress blog, and hosted it in my ccgi space. However, I've got a domain name that PlusNet host for me, and want users to be able to type this domain to see my blog. PlustNet only allows me to show static content for the domain I've got. In their help, they recommend the solution of creating an index.html containing frames, one of which points to my ccgi space where I've got wordpress installed.
1. The problem is though, that when you look at my site (www.scottlangham.co.uk), you don't see the right addresses in the address bar, for example, if somebody navigates to a particular post, I would like them so see www.scottlangham.co.uk\22-aug-2008 in the address bar so that they can link to that individual post, but instead the address always stays as www.scottlangham.co.uk.
2. Also, if they click on the RSS link that wordpress generates, that gives the user an address of:
  http://ccgi.scottlangham.plus.com/blog
But, I would like them to get:
http://www.scottlangham.co.uk/blog instead.
3. And thirdly, I view the page using mozilla firefox, and if there's RSS content, it displays an icon in the browsers address bar from which I can get the RSS address, but as the content is nested within a frame from the page you're viewing, mozilla doesn't pick this up and doesn't display the icon. I think I can fix the third problem by adding some more stuff into the index.html that contains the frames, but I can't work out how to solve the first two problems.
Any help would be much appreciated.
  -Scott
3 REPLIES
Prod_Man
Grafter
Posts: 286
Registered: 04-08-2007

Re: Wordpress frames causes trouble with the web address

Hello there,
That's the worst advice I've ever heard....
Only makes everything more messy and doesn't solve a thing.
Tip for all users who want a Domain Name in the Future.
Hold your horses until you have the Domain Name Records setup otherwise you're only wasting time pre-installing with CMS's.
Most of which save some Database Entries with the Base URL that you installed with...
Fix:
1. First http://mysql.plus.net/ -> Login with your MySQL Details.
Then, start hunting though all the Tables and Entries which relate to "ccgi.scottlangham.plus.com" and replace them with "www.scottlangham.co.uk"...
Tip for free - learn some SQL things such as:
.. WHERE `col` LIKE '%findhere%'...
2. Backup your Database as SQL.
Delete the Database entirely (DROP DATABASE).
Install from fresh - on your new Domain.
Fix your SQL file replacing all entries of "ccgi.scottlangham.plus.com" with "www.scottlangham.co.uk" with a text editor.
Re-enter the modified SQL file.
Should then work.
Hope that helps!
Jim,
Plusnet Staff
Plusnet Staff
Posts: 17,641
Thanks: 535
Fixes: 159
Registered: 05-04-2007

Re: Wordpress frames causes trouble with the web address

As Jim says, the frames way of doing it isn't the best. I've had a quick look over your account and I can see you are doing it via a cname record as per http://usertools.plus.net/tutorials/id/14
Unfortunately it looks as though you missed the trailing '.' off the record, I've updated that for you but it's going to take some time for DNS to update again.
If this post resolved your issue please click the 'This fixed my problem' button
 Chris Parr
 Plusnet Staff
ScottLangham
Newbie
Posts: 2
Registered: 31-08-2008

Re: Wordpress frames causes trouble with the web address

Thank-you very much for your help gents.
Yes, I discovered the tutorial http://usertools.plus.net/tutorials/id/14 and am hoping it might help. I asked PlusNet to change my ccgi services to basic. I'm interested to know what this does for me and how this behaves differently compared to whatever the default setting was.