cancel
Showing results for 
Search instead for 
Did you mean: 

Weird wordpress static hompage/permalink error.

tonycollinet
Community Veteran
Posts: 1,135
Thanks: 5
Registered: ‎14-08-2007

Weird wordpress static hompage/permalink error.

EDIT - OK, I have made the site work correctly, by setting (in the wordpress site settings) the site URL to http://ccgi.collinet.plus.com/~collinet/wordpress (instead of http://ccgi.collinet.plus.com/wordpress). But now of course I get the ~username in all URL's which is just ugly. Any idea how I can get rid of this? Thanks.
(Summary)
With site address in settings set to http://ccgi.collinet.plus.com/~collinet/wordpress everything works, but urls are ugly
With site address in settings set to http://ccgi.collinet.plus.com/wordpress I get the problem with the home page described below - but all URL's omit the ~collinet.
********************
I have just transferred a Church website into wordpress. I have just about managed to get permalinks working to get rid of the /~collinet in the URL. All works fine except for the menu entry to the static homepage.
If I Hover over the "Home" Menu button,  http://ccgi.collinet.plus.com/wordpress/ appears in the browser link preview (bottom left of window in Chrome). This is correct.
However, if I click the Home menu button, it goes to http://ccgi.collinet.plus.com/~collinet/wordpress/ - which is wrong and I get a page not found error.
If I click in the Site Name in the header bar, it goes to the correct homepage.
All other page menu entries work correctly
If I change the page used for the home page in wordpress settings, the page named Home now works correctly, and whichever page is set to be the static home page shows the same error.
Anyone any ideas what is going on? (First link above will take you to the site if you want to see for yourself)
EDIT:
- OK, I'm pretty certain it has nothing to do with permalinks (which as far as I can tell, only affects the end of the URL). However, when trying to sort out permalinks, I uploaded the wordpress standard .htaccess file - which is:
Quote
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /wordpress/
RewriteRule ^index\.php$ -
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /wordpress/index.php
</IfModule>
# END WordPress
3 REPLIES 3
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,370
Fixes: 75
Registered: ‎06-04-2007

Re: Weird wordpress static hompage/permalink error.

I suggest trying something like the rewrite rules shown in this post.
That post gives background to the origin of ~username in the URL. mod_rewrite is active so there is no need to test for that in the .htaccess file; RewriteEngine On is, of course, needed. I'm uncertain whether RewriteBase should be set to / or /wordpress/.
David
David
taras
Grafter
Posts: 226
Registered: ‎22-08-2008

Re: Weird wordpress static hompage/permalink error.

tonycollinet
Community Veteran
Posts: 1,135
Thanks: 5
Registered: ‎14-08-2007

Re: Weird wordpress static hompage/permalink error.

Thanks all - will look again later.