cancel
Showing results for 
Search instead for 
Did you mean: 

Webspace permanently broken. Plusnet never respond

dcomputers
Newbie
Posts: 9
Registered: ‎21-09-2012

Webspace permanently broken. Plusnet never respond

Look, here's how it is. PlusNet have given me a decade of good service on my broadband, yet of late (since their UK push/advertising campaign) their service and hosting, and especially their technical support has been non-existant.
I have a site hosted on my CGI space. www.clanimperium.co.uk
About 90% of the time it doesn't work, instead of getting the home page, you get an index page with a single folder (clanimperium) despite the fact that the whole site is not withing a folder.
When the homepage does work, navigating to the dokuWiki located at http://www.clanimperium.co.uk/wiki results in a URL rewrite to http://www.clanimperium.co.uk/~dcomputers/wiki which, while it works, is undersirable as it exposes my user name.
When I send a ticket to PlusNet, they ignore it. The level of service is farcical and not what I'd expect for a business grade account.
Has anyone got any idea why PlusNet is failing even on the most basic of service provision, and could someone with a clue go and tell them how to do their job?
16 REPLIES 16
bobpullen
Community Gaffer
Community Gaffer
Posts: 14,877
Thanks: 2,476
Fixes: 168
Registered: ‎04-04-2007

Re: Webspace permanently broken. Plusnet never respond

Hi there,
I'm really sorry that neither of your open tickets have been picked up. Not sure what's happened there but I'm pretty sure we'll not have intentionally been ignoring them. I'll give the Business Support Team a nudge ...
Quote from: dcomputers
I have a site hosted on my CGI space. www.clanimperium.co.uk
About 90% of the time it doesn't work, instead of getting the home page, you get an index page with a single folder (clanimperium) despite the fact that the whole site is not withing a folder.

That's a problem with your additional domain records. They're set up correctly but somebody neglected to flick a switch here and remove the default records. This has been done now so allowing for DNS propagation the problem should be sorted within 24-48 hours.
Quote from: dcomputers
When the homepage does work, navigating to the dokuWiki located at http://www.clanimperium.co.uk/wiki results in a URL rewrite to http://www.clanimperium.co.uk/~dcomputers/wiki which, while it works, is undersirable as it exposes my user name.

That's a nuance of the CGI platform and isn't specific to the wiki software you have installed. It would happen with the majority of CGI dependent software like Wordpress, Joomla etc. I think you've been pointed in this direction before, but your best resource of information for this was authored by Gabe on these forums and can be found here.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

dcomputers
Newbie
Posts: 9
Registered: ‎21-09-2012

Re: Webspace permanently broken. Plusnet never respond

Thanks for the help and speedy response, Bob.
I've seen the forum post you refer to. The only thing in it that appears relevent is the .htaccess file presence, but having checked, I was unable to find any .htaccess files in the folders in my webspace.
Gabe
Community Veteran
Posts: 767
Registered: ‎29-10-2008

Re: Webspace permanently broken. Plusnet never respond

See also this thread, and the one linked at the end of it - different packages, but a similar problem.
Gabe
dcomputers
Newbie
Posts: 9
Registered: ‎21-09-2012

Re: Webspace permanently broken. Plusnet never respond

I'm just not confident enough with this sort of thing to know what I'm doing.
http://www.clanimperium.co.uk/wiki is being redirected to http://www.clanimperium/~dcomputers/wiki
What do I need to do to resolve this, and how ill it affect subfolders?
Also why can't PlusNet enact a global fix? It's retarded and certainly doesn't happen on any other host that i've ever used.
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Webspace permanently broken. Plusnet never respond

If you add a / so that your initial URL reads .../wiki/ does it still redirect to a URL containing /~username ?
David
dcomputers
Newbie
Posts: 9
Registered: ‎21-09-2012

Re: Webspace permanently broken. Plusnet never respond

I'd love to tell you, but the entire site is currently broken pending the bods at PlusNet flicking a switch, or sacrificing a virgin, or whatever other random things they've said they're doing currently.
Gabe
Community Veteran
Posts: 767
Registered: ‎29-10-2008

Re: Webspace permanently broken. Plusnet never respond

(Hi David - crossed in the post - the trailing slash fixes the initial call, but the "start" link still has the username in it, so I guess it's also in the settings file. But have you seen the homepage? Oh boy!  Grin Roll_eyes Lips_are_sealed  )
@dcomputers
To see .htaccess files, you may need to set your ftp client to show hidden files. Check the home folder and /wiki.
If there are none, then go to reply 11 in that thread. Copy the first 4 lines of code into a txt editor (not the last three) and save as htaccess.txt (just plain text). Upload the file to you home folder and change the file name to .htaccess (remembering the leading dot). That should fix the trailing slash problem and avoid the rewrite. But it looks like the username also got into your settings at installation and probably needs removing.
The problem is partly caused by a global fix to allow legacy code to work with suexec, when the platform was updated in a hurry. The fix should perhaps have been temporary.
Gabe
dcomputers
Newbie
Posts: 9
Registered: ‎21-09-2012

Re: Webspace permanently broken. Plusnet never respond

OK, have created, uploaded, and renamed said .htaccess file. Will know more about if it's worked when whatever it is the magic pixies are doing is finished, since I can't even access the homepage at the moment, much less the wiki
Oldjim
Community Veteran
Posts: 38,460
Thanks: 1,035
Fixes: 62
Registered: ‎15-06-2007

Re: Webspace permanently broken. Plusnet never respond

works fine - the address is now showing as  http://www.clanimperium.co.uk/wiki/doku.php
Strat
Moderator
Moderator
Posts: 30,320
Thanks: 3,302
Fixes: 504
Registered: ‎14-04-2007

Re: Webspace permanently broken. Plusnet never respond

I get a 404 on that URL.

Customer and Forum Moderator. Windows 10 Firefox 87.0 (64-bit)

Gabe
Community Veteran
Posts: 767
Registered: ‎29-10-2008

Re: Webspace permanently broken. Plusnet never respond

Try clearing your cache and reloading. I can see it.
Growltiger?
The username is still in the links, so the next thing to do would be to check your docuwiki settings.
Gabe
dcomputers
Newbie
Posts: 9
Registered: ‎21-09-2012

Re: Webspace permanently broken. Plusnet never respond

I've cleared my browser cache and am still getting a crazy index page for http://www.clanimperium.co.uk and a URL not found for http://www.clanimperium.co.uk/wiki
This tends to agree with reports which, when I could access it, others could not.
Strat
Moderator
Moderator
Posts: 30,320
Thanks: 3,302
Fixes: 504
Registered: ‎14-04-2007

Re: Webspace permanently broken. Plusnet never respond

Cleared cache and same here.

Customer and Forum Moderator. Windows 10 Firefox 87.0 (64-bit)

Gabe
Community Veteran
Posts: 767
Registered: ‎29-10-2008

Re: Webspace permanently broken. Plusnet never respond

Still propagating then. You can see the effect at ccgi.dcomputers.plus.com/wiki
Gabe