cancel
Showing results for 
Search instead for 
Did you mean: 

Safeguard won't turn on "Sorry we have a problem and currently can't save your changes"

stevem26
Newbie
Posts: 3
Registered: ‎08-04-2016

Safeguard won't turn on "Sorry we have a problem and currently can't save your changes"

When I try to turn on Safeguard and tap Save I get "Sorry we have a problem and currently can't save your changes, please try again later".

I have waited weeks and tried again, but get the same.

7 REPLIES 7
Anotherone
Community Veteran
Posts: 19,107
Thanks: 455
Fixes: 21
Registered: ‎31-08-2007

Re: Safeguard won't turn on "Sorry we have a problem and currently can't save your changes&quot

I vaguely recollect others having a problem with this. I believe @bobpullen was looking at some of the issues. Hopefully he'll come and look at this for you. 

bobpullen
Community Gaffer
Community Gaffer
Posts: 14,877
Thanks: 2,478
Fixes: 168
Registered: ‎04-04-2007

Re: Safeguard won't turn on "Sorry we have a problem and currently can't save your changes&quot


@stevem26 wrote:

When I try to turn on Safeguard and tap Save I get "Sorry we have a problem and currently can't save your changes, please try again later".

Did you manage to sort this? I've just checked and Safeguard seems to be enabled for your account.


Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

stevem26
Newbie
Posts: 3
Registered: ‎08-04-2016

Re: Safeguard won't turn on "Sorry we have a problem and currently can't save your changes&

Unlike last night, it does now say it is on.  However, it isn't working.  I can still visit questionable sites (which is fun, but against the point) including those in the explicit block list.

I observe that every time I make a change, I get the error message "Sorry we have a problem and currently can't save your changes" in red at the bottom.

Further, I notice that the Change History has no records of any changes I have made or attempted since 21st Jan.

Out of interest - how do you know what is my account?  IP address?

Thanks

bobpullen
Community Gaffer
Community Gaffer
Posts: 14,877
Thanks: 2,478
Fixes: 168
Registered: ‎04-04-2007

Re: Safeguard won't turn on "Sorry we have a problem and currently can't save your changes&


@stevem26 wrote:

Out of interest - how do you know what is my account?  IP address?


Yeah.

I'll see if I can find out what's going on with the Safeguard thing. I see what you mean by the errors when you change something.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

PN_user
Newbie
Posts: 2
Registered: ‎28-07-2016

Re: Safeguard won't turn on "Sorry we have a problem and currently can't save your changes&

Hi,

Has anyone found a fix for this? I have recently joined PlusNet and on day one activated the Safeguard filter, all working fine. Then about a week later I noticed it wasn't filtering at all, checked back in the Member Centre and Safeguard was switched off even though I hadn't done this and did not receive an email confirming changes (or it appearing on the tracking history). So I switched it back on but got "Sorry we have a problem and currently can't save your changes, please try again later". This was a week ago and bizarrely while it says Safeguard filters are on in the member centre (all the defaults) it is not filtering anything! I have restarted router, waited hours etc. Any subsequent changes I try to make to it I get "Sorry we have a problem and currently can't save your changes, please try again later" and it does not change.

 

Thought about using OpenDNS as some have suggested but have now found out all the DNS settings on the new hub are locked down! Can someone help please as this Safeguard is not safe at all...

stevem26
Newbie
Posts: 3
Registered: ‎08-04-2016

Re: Safeguard won't turn on "Sorry we have a problem and currently can't save your changes&

Unfortunately I've nothing solid for you.  About thirty days after I posted - this problem "just went away for me".  My filter was turned on and working - so I never fiddled with it again!

 

It did seem to take a while to respond.  Try turning it on, and leave it for a week or more then see if it's working.

 

And yes, I also wanted to use OpenDNS but as you say, the supplied BT router doesn't allow you to mess with the DNS settings, which is nuts I was sure all routers would allow this.  There are ways of hacking it but it's not easy.

 

 

If you get desperate and can afford it, consider getting your own router from Maplins or such - then you can use OpenDNS (which I much preferred to Plusnet's family filter).

 

Good luck!

PN_user
Newbie
Posts: 2
Registered: ‎28-07-2016

Re: Safeguard won't turn on "Sorry we have a problem and currently can't save your changes&

Two months on and safeguard still not working. Logged call with PS and even wrote letter but I'm afraid PS support has been atrocious - they put my call on hold for a week then take it off then put it back on hold..with no workaround or suggestions. Has anyone got any bright ideas on how to get this working?