cancel
Showing results for 
Search instead for 
Did you mean: 

Router leaking first part of account login credentials to any site visited.

FIXED
Grafter
Posts: 36
Thanks: 8
Registered: ‎04-04-2015

Router leaking first part of account login credentials to any site visited.

If you visit any of the many sites that show what information normal internet browsing reveals about you (eg https://browserleaks.com ) from your plusnet hub one router connection you'll see some thing like:

My IP Address
IP address xx.xx.xx.xx
Hostname xxxxxxx.plus.com
IP Address Location
Country United Kingdom (GB)
ISP British Telecommunications PLC
ASN 6871
Timezone Europe/London
Local Time Sat, 29 Feb 2020 10:24:17 +0000
Latitude/Longitude 51.4964,-0.1224

I've put in the xx's to anonymise it.

My concern is with the Hostname. In the case of plusnet the xxx bit is by default actually the broadband Username, and is the first half of the login credentials for your plusnet account. 

To my mind this is undesirable from a privacy or a security standpoint.

Anyone know of a way to change this behaviour?

(What I had expected to to see here was something like the individual machine hostname - in my case aspire7736 for this particular computer).

Thanks

Dave

 

7 REPLIES 7
Highlighted
Pro
Posts: 310
Thanks: 232
Fixes: 1
Registered: ‎27-12-2019

Re: Router leaking first part of account login credentials to any site visited.

@mag Make a request to Support to have your rDNS changed to your IP address, this action will remove that information.

Highlighted
Community Gaffer
Community Gaffer
Posts: 14,347
Thanks: 1,940
Fixes: 142
Registered: ‎04-04-2007

Re: Router leaking first part of account login credentials to any site visited.

What he said ^
BTW, this is nothing to do with the router. The sites you're visiting are just doing a reverse DNS lookup on your IP address.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

Highlighted
Community Gaffer
Community Gaffer
Posts: 5,170
Thanks: 1,432
Fixes: 252
Registered: ‎25-03-2015

Re: Router leaking first part of account login credentials to any site visited.

Fix

Hi @mag,

 

I've raised a ticket on your account regarding this Here.

 

If you could reply to the ticket confirming that you'd like your rDNS updating as mentioned above in this thread, I'll be happy to get that updated for you.

 

I hope this helps.

If this post resolved your issue please click the 'This fixed my problem' button
 Harry Beesley
 Plusnet Infrastructure Operations Professional
Highlighted
Grafter
Posts: 36
Thanks: 8
Registered: ‎04-04-2015

Re: Router leaking first part of account login credentials to any site visited.

Thanks to all who responded - I've replied to the ticket raised.

Thanks also for the very proactive response - much appreciated.

Dave

Highlighted
Community Gaffer
Community Gaffer
Posts: 5,170
Thanks: 1,432
Fixes: 252
Registered: ‎25-03-2015

Re: Router leaking first part of account login credentials to any site visited.

No problem @mag 

 

That should take effect within the next 24 hours. I'm in the office tomorrow, so I'll try to remember to check that for you, but feel free to drop me a PM if you notice it hasn't updated tomorrow afternoon.

If this post resolved your issue please click the 'This fixed my problem' button
 Harry Beesley
 Plusnet Infrastructure Operations Professional
Highlighted
Community Gaffer
Community Gaffer
Posts: 5,170
Thanks: 1,432
Fixes: 252
Registered: ‎25-03-2015

Re: Router leaking first part of account login credentials to any site visited.

I've checked your rDNS and it looks like this is now returning <Your IP>.plus.com as expected Thumbs_Up

If this post resolved your issue please click the 'This fixed my problem' button
 Harry Beesley
 Plusnet Infrastructure Operations Professional
Highlighted
Grafter
Posts: 36
Thanks: 8
Registered: ‎04-04-2015

Re: Router leaking first part of account login credentials to any site visited.

Thanks - all looking good now.