cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with receiving incoming calls on Andrews & Arnold VoIP

FIXED
bromleyboy21
Hooked
Posts: 8
Thanks: 3
Registered: ‎20-01-2024

Problem with receiving incoming calls on Andrews & Arnold VoIP

Hi,

 

My in-laws decided to upgrade to PlusNet fibre last autumn but wanted to keep the landline number. After doing some research on this forum we decided to sign up with Andrews & Arnold for VoIP calls. The number ported over fine and I set it up to forward calls onto a mobile until I was next at theirs.

 

Further research suggested that a Cisco SPA122 was a good ATA box to purchase which I was able to set up and get working when visiting at Christmas.

 

Out going calls work fine but incoming calls are very inconsistent, some make it through to the home phone but a good number go straight to the mobile forwarding which it set up to divert after 9 seconds.

 

The Andrews and Arnold support team are very responsive by email and have suggested a few settings I should check/change but none have made things anymore reliable.

 

The latest suggestion was to make the Cisco box have a static IP address (which it already has) and turn off UPnP on the router - which I've done.

 

I then asked if changing to a different ATA box would help but the response was: "I don't think another ATA will make any difference here we're seeing the device rejecting those calls so it appears that either the configuration is right on the device or your underlying broadband isn't correctly directing the incoming calls to the ATA."

 

So can anyone suggest any other settings I can look to change on either the router or SPA122?

 

Many thanks

 

Ed

18 REPLIES 18
MisterW
Superuser
Superuser
Posts: 14,742
Thanks: 5,518
Fixes: 394
Registered: ‎30-07-2007

Re: Problem with receiving incoming calls on Andrews & Arnold VoIP

which it set up to divert after 9 seconds

@bromleyboy21 that's a bit short. Try setting it to at least 20 secs. There can be quite a few seconds delay in a voip phone being in a position i.e. ringing, to accept a call. AFAIK the timer will start as soon as the A & A system 'sees' the incoming call. So with a timer set at 9 secs , you may well only get one or two 'rings' on the actual phone before its diverted to mobile.

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

bromleyboy21
Hooked
Posts: 8
Thanks: 3
Registered: ‎20-01-2024

Re: Problem with receiving incoming calls on Andrews & Arnold VoIP

Many thanks for the suggestion, I'll make that change now and see how things go.

rflitcroft
Dabbler
Posts: 20
Thanks: 17
Registered: ‎10-01-2024

Re: Problem with receiving incoming calls on Andrews & Arnold VoIP

Is your ATA behind your router's NAT firewall?

If so then you need to either:
1) configure your ATA to send SIP keep-alive messages every 30 seconds or so, so that the connection between the ATA and the kit at A&A is kept active; or
2) Alternatively, you can enable port forwarding from WAN->LAN such that your VOIP traffic is forwarded to your ATA. If you do this, ensure that you only forward traffic from A&A's servers. Not all routers seem to have this source-IP filter, but without it your ATA is exposed to the world and it will be attacked or used, possibly expensively.

I have much the same setup, but a different ATA. Initially using option (1) I was able to receive incoming calls only with a fresh registration. After a few minutes, no incoming call made it through. The problem was not configuring the keep-alives properly.

Now I have relegated my plusnet Hub 2 to lowly access-point duties and have a more functional main router in place, I have moved to option (2) which so far is more reliable.

bromleyboy21
Hooked
Posts: 8
Thanks: 3
Registered: ‎20-01-2024

Re: Problem with receiving incoming calls on Andrews & Arnold VoIP

Thanks for your reply which confirms my thinking regarding the problem being experienced and why it's intermittent.

Regarding your first point - Andrews & Arnold recommended that I changed this setting on the Cisco ATA box: "Registration Period down to 600 seconds instead of 3600." So should I change the 600 to 30 seconds?

For the second point does the Plusnet Hub2 allow this port forwarding? And if so I assume I'd need to ask A&A for the server details?

Many thanks to people's suggestions to get this fixed.

MisterW
Superuser
Superuser
Posts: 14,742
Thanks: 5,518
Fixes: 394
Registered: ‎30-07-2007

Re: Problem with receiving incoming calls on Andrews & Arnold VoIP

For the second point does the Plusnet Hub2 allow this port forwarding? And if so I assume I'd need to ask A&A for the server details?

@bromleyboy21 The Hub 2 does not support IP filters on port forwarding.

On the first point check that the 'NAT keep alive intrvl' is set at 15 secs as decsribed here https://www.cisco.com/c/en/us/support/docs/smb/unified-communications/cisco-small-business-voice-gat... in the Nat Support parameters.

I have a family member using the Hub 2 with an A & A account and it works just fine (albeit they use a Gigaset N300IP) . Providing the NAT keep alive is used it should be fine.

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

rflitcroft
Dabbler
Posts: 20
Thanks: 17
Registered: ‎10-01-2024

Re: Problem with receiving incoming calls on Andrews & Arnold VoIP

I achieved a stable service using NAT and a Hub2 with re-registration every 300 seconds, and keep-alives every 30 seconds.
Did not set a STUN server on the ATA.
SIP ALG was disabled on the router.
rflitcroft
Dabbler
Posts: 20
Thanks: 17
Registered: ‎10-01-2024

Re: Problem with receiving incoming calls on Andrews & Arnold VoIP


Andrews & Arnold recommended that I changed this setting on the Cisco ATA box: "Registration Period down to 600 seconds instead of 3600." So should I change the 600 to 30 seconds

Don't confuse the registration period with keep-alive frequency - they are separate. Try between 300 - 600 seconds for a registration period, with keep-alive's between 15 -30 seconds. That should get you stability.

MisterW
Superuser
Superuser
Posts: 14,742
Thanks: 5,518
Fixes: 394
Registered: ‎30-07-2007

Re: Problem with receiving incoming calls on Andrews & Arnold VoIP

@bromleyboy21 just found a later document here https://www.cisco.com/c/en/us/support/docs/smb/unified-communications/cisco-small-business-voice-gat... which seems to show the keepalive settings in a different place

 

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

bromleyboy21
Hooked
Posts: 8
Thanks: 3
Registered: ‎20-01-2024

Re: Problem with receiving incoming calls on Andrews & Arnold VoIP

Thanks so much guys, I'll report back in due course how I get on

HPsauce
Pro
Posts: 7,004
Thanks: 149
Fixes: 2
Registered: ‎02-02-2008

Re: Problem with receiving incoming calls on Andrews & Arnold VoIP

Interesting, I've recently started using A&A with an N300IP and Hub One. I have never looked at those parameters as it works fine; they're in the "Advanced" section as I've just found out.

On checking my Registration refresh is 180 seconds and the NAT refresh is 20 seconds.

bromleyboy21
Hooked
Posts: 8
Thanks: 3
Registered: ‎20-01-2024

Re: Problem with receiving incoming calls on Andrews & Arnold VoIP

Thanks for finding this extra info for me.

Can I just confirm that I'm ignoring the SAS Enable and saying yes to NAT mapping and yes to NAT keep alive?

Screenshot_1.jpg

Many thanks

Ed

MisterW
Superuser
Superuser
Posts: 14,742
Thanks: 5,518
Fixes: 394
Registered: ‎30-07-2007

Re: Problem with receiving incoming calls on Andrews & Arnold VoIP

@bromleyboy21 yes , I believe you should ignore the SAS enable.

TBH the voip hardware Ive seen previously only has one option which is usually NAT keep alive. Im not entirely sure what the NAT mapping enable does in your case.

I THINK that you should try with both NAT mapping enabled and NAT keep alive enabled. If that doesnt seem to work then try with just the NAT keep alive enabled.

You can leave the Keep alive msg as $NOTIFY and Keep alive dest as $PROXY (I think!)

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

rflitcroft
Dabbler
Posts: 20
Thanks: 17
Registered: ‎10-01-2024

Re: Problem with receiving incoming calls on Andrews & Arnold VoIP


@MisterW wrote:

I THINK that you should try with both NAT mapping enabled and NAT keep alive enabled. If that doesnt seem to work then try with just the NAT keep alive enabled.


According to this tortuous thread: https://community.cisco.com/t5/voice-systems-and-accessories-small-business/nat-mapping/td-p/3896301, the NAT Mapping Enabled = yes) causes the WAN IP to be discovered by some mechanism (e.g. STUN).
"Exact behavior depends on the configuration of other NAT-related options and/or data discovered during STUN (if enabled)."

bromleyboy21
Hooked
Posts: 8
Thanks: 3
Registered: ‎20-01-2024

Re: Problem with receiving incoming calls on Andrews & Arnold VoIP

I'm learning a lot of things today! What is STUN and is it good or bad?!

Do I want to try turning on NAT mapping or not?

Thanks all