cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with Wordpress blog path

Highlighted
Grafter
Posts: 43
Thanks: 3
Registered: ‎28-12-2007

Problem with Wordpress blog path

I have installed a second Wordpress blog that was developed offline with AMPPS to my webspace using Duplicator. This is in my /public/blog2 folder. (Thanks for help form Spracyt and Bob Pullen on another thread)

 

The path that Duplicator gave me is:

 

/services/webpages/util/c/c/cgi.MyUserName.plus com/public/blog2

 

The address it gave me for the blog is:

 

http://ccgi.MyUserName.plus.com//blog2 (the second double slash is not a typo)

 

The site works OK for visitors, but behind the scenes things are not right. For example:

 

If I try to save changes to settings I get the ‘page not found’ screen and this in the address bar:

http://blog2/wp-admin/options.php?settings-updated=true

 

If I type in 'ccgi.MyUserName.plus.com//' before ‘blog2/ ...’ and hit enter the changes are saved as expected.

 

The .htaccess file (generated by Duplicator) has only this in it:

 

# BEGIN WordPress

<IfModule mod_rewrite.c>

RewriteEngine On

RewriteBase //blog2/

RewriteRule ^index\.php$ - [L]

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule . //blog2/index.php [L]

</IfModule>

 

# END WordPress

 

I have had another blog running on my webspace for years in /public/blog with the address:

ccgi.MyUserName.plus.com/blog and there is no problem with this. There is nothing in the .htaccess file for that blog, and I have tried running the new blog with a copy of his, but no improvement.

 

I also find that if I try using some Wordpress administrative functions, such as opening the Wordpress image library, I just get the busy sign indefinitely with this in the address bar:

 

http://ccgi.MyUserName.plus.com//blog2/wp-admin/upload.php

 

The permissions for 'upload.php' are 644 (same as the first blog I installed which works fine) and changing this to 710 makes no difference. The permissions for the folders above this level are also the same as the other blog (755).

 

Lastly, I can only get the login link on the front page to work if I right click it and load it in a new tab. At some stage I got an warning message about frame, but I can't reproduce this. Then whenever I log in to Wordpress I get a message saying the server is insecure. Thereafter the login dialogue box pops up every couple of minutes (‘Your session has expired”) but if I dismiss it I can continue.

 

Sorry to be so lengthy, but it seems better to put it all down now rather than anyone who is prepared to help having to ask questions. It also seems possible that at least some of the problems have a common cause.

10 REPLIES 10
Highlighted
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Problem with Wordpress blog path

Having a double slash is wrong though often navigation still works because the server behaves the same as if it was a single slash. However it looks like in at least one instance here the double slash might have led to confusion with a fully qualified URL with the http: scheme omitted.

For starters I suggest replacing the double slashes in /public/blog2/.htaccess with single slashes so it reads

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /blog2/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /blog2/index.php [L]
</IfModule>

# END WordPres

Next log into the WordPress Dashboard and visit Settings -> General. Make sure the WordPress Address (URL) and Site Address (URL) both say

http://ccgi.MyUserName.plus.com/blog2

Save any changes you make.

File (and .htaccess) permissions of 644 and folder permissions of 755 should be OK.

In the following path is the occurrence of "cgi" rather than "ccgi" a typo?

The path that Duplicator gave me is:

/services/webpages/util/c/c/cgi.MyUserName.plus com/public/blog2

I would expect tp see "ccgi" there.

After making these changes do you still get the security and session expired warnings? Has the Media Library access problem gone away?

David
Highlighted
Grafter
Posts: 43
Thanks: 3
Registered: ‎28-12-2007

Re: Problem with Wordpress blog path

Well that has certainly made a difference!

 

Settings are now saving  without my having to complete paths

The security warnings have disappeared

The login screen isn’t popping up the whole time

The search box on the plug ins page is now working, which it wasn't before

The whole site is loading noticeably faster

 

It’s even solved an aggravation that I hadn’t mentioned: getting the dread ‘Cheating are we?’ message if I tried to save settings from the theme’s visual editor.

 

And apologies for the typo (cgi for ccgi) in the path.

 

The only very minor probs that remain are that I still have to right-click on ‘Site Admin’ and choose ‘Open in new tab’ to get into the dashboard and some, but not all, the images stored in wp-content are showing up on the media library page. The others have empty thumbnail marquees, but if I click on them the appropriate file name and meta appears in the RHS panel. Both are very minor aggravations as I assume that I can re-import the missing images.

 

Maybe as I go on configuring the site, and using more dashboard facilities, I’ll come across other glitches, but at the moment life is certainly a lot sweeter.

 

So very many thanks for your help again David.

Highlighted
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Problem with Wordpress blog path

I'm glad to hear my suggestions fixed most of the problems. Smiley

With regard to admin login, if you hover the pointer over the login link does your browser status line show the following fully qualified URL?

http://ccgi.MyUserName.plus.com/blog2/wp-login.php

Follow up question to that -  if you visit your blog2 home page

http://ccgi.MyUserName.plus.com/blog2

then type /wp-login.php after blog2 in the address bar (so the URL is like my earlier code), and press enter does this  display the login page?

For my WordPress blogs my answers are "yes" and "yes".

The problem with the Media Library thumbnails suggests the files have been corrupted; eg new line characters might have been added into the binary code because a PC <> server transfer has been done in ASCII (text) mode rather than binary. Is it easy to try re-importing the images?

David
Highlighted
Grafter
Posts: 43
Thanks: 3
Registered: ‎28-12-2007

Re: Problem with Wordpress blog path

Sorry about the delay, but I’m actually off on holiday on Monday and there’s been a mad scramble to create some content on the blog and pressure test it while this thread is still live and rescue is a possibility.

 

Question 1: I blush to admit that I’d missed the useful little box in the bottom LHS of the window. This is what it says when I hover over the Site Admin link:

 http://ccgi.MyUserName.plus.com/blog2/wp-admin

 

Which explains a lot, but I’m afraid that I have no idea how to get that link to point to … /blog2/ /wp-login.php instead.

 

Question 2: This does indeed get me to the login screen:

http://ccgi.MyUserName.plus.com/blog2/wp-login.php

 

Although editing the .htaccess file as you suggested before has solved most of he problems, there is one that has occurred since doing so.

 

If I click the theme customise (visual editor) link a blank screen. If I hover over it I get this:

 

http://ccgi.newbery1.plus.com/blog2/wp-admin/customize.php?url=http://ccgi.newbery1.plus.com/blog2/

 

If I right click and choose Open Link in New Tab it opens OK, but if I then make changes and click on Save, the changes are not saved. There is no problem if I make the changes from the main Wordpresss dashboard instead of the theme visual editor. If I hover over the Save button in the visual editor, a path flashes up at the bottom LHS of the screen but vanishes before I can read it.

 

These are very minor aggravations, but I am curious about what has caused them and particularly how one can get one’s head under the bonnet and fix them.

 

As you suggest, it will be easy enough to re-import the missing images in the image library.

 

If by any chance you are wondering what all the fuss is about, the blog can be found here:

 

www.protectllanbedr.org

Highlighted
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Problem with Wordpress blog path

@TonyN

Those links were very useful. I think the navigation problems you are having are most likely associated with confusion between the domain name for the site and the username-based addresses under which it is stored in the file system.

When a visitor clicks on article links the address shown in the address bar should change to that of the clicked link whereas it currently continues to show the address of the domain home page. This suggests to me it could be running in a frame - you mentioned transiently seeing a frame error message earlier in this topic.

Sorting this out could bring the site down for a while, best avoided while you are away. Should we leave it until you are back?

David
Highlighted
Grafter
Posts: 43
Thanks: 3
Registered: ‎28-12-2007

Re: Problem with Wordpress blog path

 

 

Only just got on to this after holiday and a lot of catching up but that really helps David.

 

You have correctly surmised that a frame is involved, but although I know what a frame is in some contexts to do with IT, I haven’t a clue in this case.

 

The domain is hosted at Free Parking and I have set domain masking to conceal the real URL of the page. Apparently this causes a frame to be used (screen shot attached). So maybe this is the problem? I've used URL masking because the blog is a bit controversial in the local community and I act as admin anonymously. I know that anyone with sharp eyes can spot my username coming up at the bottom LH of the screen if they hover over a link, but I would prefer it not to appear in the address bar if that is possible.

 

The screen print also shows that I still have the URL for forwarding set with the extra double forward slash that was an issue earlier in this thread. I haven’t changed anything pending your being kind enough to have a look as destroying evidence probably wouldn’t help.

 

There is something new that may or may not help point to a solution, if there is one. If you go to http://www.protectllanbedr.org you will find a LINKS widget in the RH sidebar with three links listed. The top two have the same problem as I have described above — they only open if I right click and choose ‘Open in New Tab’. The bottom one works perfectly. I've checked and rechecked the links and they work fine when run from other places (say a link in a Word doc) but if I embed them in a post on the blog I'm back to the same problem. All the other links, for comments, pages etc, work fine except ‘Log In’ which does not.

 

The blog is quite busy at the moment, but as this is now affecting visitors rather than just me, it's probably best to fix it if you have time to lend a hand, even if that means taking the site down to do it.

Highlighted
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Problem with Wordpress blog path

@TonyN Thanks for the information. From a brief search there's lots about adding iframes into WordPress pages (eg to run a YouTube video) but I didn't spot anything about doing the reverse. I'll come back again when I've done a bit more research. Thanks for leaving "the evidence" in place for the moment. Smiley

David
Highlighted
Grafter
Posts: 43
Thanks: 3
Registered: ‎28-12-2007

Re: Problem with Wordpress blog path

Look forward to it David, Things are ticking along quite well on the site even with the link problems at the moment. One of my problems is that I haven't been able to find a search string that takes me to a site where there is a basic explanation of what a frame is in this context and what it does.

Highlighted
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Problem with Wordpress blog path

Tony, the tutorial at https://www.tutorialspoint.com/html/html_frames.htm provides a basic introduction to frames. What you have is like their first example but only two stacked frames. Your top frame is 100% screen height, and the second (bottom) frame is what's left - which is nothing. That might have been put there to cope with known browser oddities. Their examples show an HTML5 document type but that standard doesn't include frames; however browsers often extend the standard as long as they can make sense of the request. (For information clicking any of their "menu example" links doesn't work in FF for me.)

Thanks for posting the URL masking dialog image. In that dialog I suggest you change the URL at the top to remove one of the double slashes before blog2. After doing that I expect functionality not to change, the only difference being a single slash (correctly) shows in the page source of the masked blog page.

Turning next to why clicking two of the widget links hangs with white pages but the third one works. I think that could be because the first two use cookies but the third one doesn't. When run in a frame I think cookies are treated as third-party because they don't go with the site URL in the address bar. Most browsers block third-party cookies by default and I'm not going to suggest changing that.I think that will be why the login link also hangs on a white screen - it will use cookies.

Right-clicking the links and opening them in a new tab displays them outside the frame; the cookies then become first-party and work. For the links widget are there any customisation settings allowing you to set links to "open in a new tab"? That would make the links work for site visitors. However I don't think you can customise the login link in the same way - does that affect just you or visitors too for posting comments?

While I remember, in an earlier reply I think you mentioned the "login" link said "Site Admin". If it says that it means you are already logged in (as administrator), it just says "Log in" when you are not. Site Admin would have "Log out" below it?

I have more thoughts on hiding the underlying site links. However I'll leave that for another post after you've taken a look at this one.There's no need to retain existing settings if you want to make changes.

David
Highlighted
Superuser
Superuser
Posts: 3,872
Thanks: 2,319
Fixes: 14
Registered: ‎10-04-2007

Re: Problem with Wordpress blog path

I took a look at this problem this afternoon and whilst not having a full solution I can build on some of David's suggestions.

When I click on the failing links, I get a blank screen (Firefox 53.0.3). Selecting code inspector on the page  I can see [ Attached Image ] - Note the double '//' in the URL. On that page checking the 'Console' tab you get

"Load denied by X-Frame-Options: https://www.facebook.com/Protect-Llanbedr-1362898753802517 does not permit framing."
Llanbedyr1.jpg
So the Site you are trying to display the page from has set the X-Frame option to DENY to inhibit most browsers from displaying the linked item in a 'Frame' or 'Iframe'.

See X-Frame

Going back to the URL displayed in the attached image, if I edit out the second '/' then the browser displays the original page. This is what I'd expect along with the Console Error as above.

David's suggestion to change the URL in the Masking dialog should fix part of the problem and make the site a bit cleaner and less obstructive.  And the suggestion to force the page to open in a new tab should eliminate the problem.

HTH

 

Maurice