cancel
Showing results for 
Search instead for 
Did you mean: 

Printers drop off network every day

FIXED
goldnet
Hooked
Posts: 8
Fixes: 2
Registered: ‎17-08-2018

Printers drop off network every day

Hi all

Recently moved house and signed up with PlusNet SuperFast Fibre. So far service seems good (77mb connection). Have a small problem with the (HubOne) router disconnecting my two printers each day. When I go to prnt, the printers report offline and I have have to turn them off then back on to get a new connection.

This happens when on wifi (very slow printing) and a LAN cabled connection. I have also set the IP addresses to persistent but this makes no difference.

Never experienced this on other routers with other providers.

It's a bit of a pain as when cycling an inkjet printer you waste ink....! As I work from home on a number of devices, running around the house trying to reactivate a printer is a bit of a pain!

Any experiences or solutions gratefully received!

11 REPLIES 11
Townman
Superuser
Superuser
Posts: 16,972
Thanks: 7,063
Fixes: 67
Registered: ‎22-08-2007

Re: Printers drop off network every day

I’ve seen this with WiFi connected printers where channel selection is set to automatic. The router switches channel but a printer in power save does not. Setting the WiFi to use 1, 6 or 11 eliminates that issue.
goldnet
Hooked
Posts: 8
Fixes: 2
Registered: ‎17-08-2018

Re: Printers drop off network every day

Yes I saw this when searching prior to posting.  Both my printers are cable connected direct to the router though... Wi-fi printing was too slow to be realistic!

Baldrick1
Seasoned Hero
Posts: 6,178
Thanks: 2,722
Fixes: 182
Registered: ‎30-06-2016

Re: Printers drop off network every day

Could it be caused by the router IP address lease time being set to 24 hours? I don't use a Hub One but there should be a setting somewhere in the advanced settings where it can be changed. It might be worth a try extending it to see whether it makes any difference.

Alex
Community Veteran
Posts: 5,025
Thanks: 755
Fixes: 12
Registered: ‎05-04-2007

Re: Printers drop off network every day

Possible - I only have one network printer and I have it set to a static internal IP.

Reason is when I first got a network printer, it was on DHCP, the IP changed and I couldn't print. Had to reinstall the drivers, and said to myself "I am not having network printers on DHCP again" Roll_eyes 

Depending on your models of printers, you need to set it at each device and make sure your subnet mask is correct, and when you have set devices make sure the router DHCP range is outside of what you set. For example I would assign the printers a .3 or .4 IP and make sure DHCP is set to a .20 and above.

I've heard of IP conflicts which are bad news - and a bit of a joke for the network people on here, I guess it is a bit like creating a loopback on a network switch? Smiley

Baldrick1
Seasoned Hero
Posts: 6,178
Thanks: 2,722
Fixes: 182
Registered: ‎30-06-2016

Re: Printers drop off network every day

Fair enough but what I'm suggesting will take a moment to implement and indicate whether this is the problem with the least effort. This is the control I have under Advanced Settings\My Network\IPv4 Configuration 

DHCP Lease.png

Furthermore under Advanced Settings\My Network\My Devices if I select a device such as a printer I also see this option:

DVHP fixed.png

So I assume that there's no need to manually set a fixed IP address if one is required. This is on a BT Business Smarthub 6, I have no idea if the Hub One has these facilities.

 

 

 

 

 

 

 

 

 

Townman
Superuser
Superuser
Posts: 16,972
Thanks: 7,063
Fixes: 67
Registered: ‎22-08-2007

Re: Printers drop off network every day

The right solution here is to set the printer to DHCP and assign a static IP in the router configuration.

There’s also some possibility that PC to printer connection is being done over IPv6 so hard coding an IPv4 address might not deliver the fix you hope for. Try pinging the printer by name and see how the address resolves.
Alex
Community Veteran
Posts: 5,025
Thanks: 755
Fixes: 12
Registered: ‎05-04-2007

Re: Printers drop off network every day

Your printers are listed, so presumably the router will know the MAC address and device name?

Wouldn't the "Aways Use This IP Address" option if you turn it on, do what you want? I assume that setting applies to internal IP's.

My suggestion was the a bit of a more difficult way, changing that setting could be easier.

 

goldnet
Hooked
Posts: 8
Fixes: 2
Registered: ‎17-08-2018

Re: Printers drop off network every day

Thanks all for suggestions. As I said, I did set the printers to use a fixed IP on the hub as per the screenshots but will check if it’s by any chance using an IP6 address in case that’s affecting whether or not the IP is properly fixed. Will report back...

VinceMarsters
Grafter
Posts: 43
Thanks: 10
Fixes: 1
Registered: ‎20-07-2018

Re: Printers drop off network every day

I've got a printer that does this too - regardless of the router I use unfortunately. Sometimes it will stay connected for weeks and other times it will drop off after a few hours in standby. After years of this I just accept it now as a quirk of the printer - and suspect it may be due to either Google Cloud Print or Samsung Print but use both so not going to switch it off just to find out.

goldnet
Hooked
Posts: 8
Fixes: 2
Registered: ‎17-08-2018

Re: Printers drop off network every day

Fix

OK, I have a regular IP4 address for each printer - 192.168.1.72 and 71

Just pinged each from a command window and they each answer so it seems my persistent port is not set.

No need to define a DHCP range and manually assign outside the range.

goldnet
Hooked
Posts: 8
Fixes: 2
Registered: ‎17-08-2018

Re: Printers drop off network every day

Correction - the persistent ports are NOW set (damn that autocorrect!) - all OK


@goldnet wrote:

OK, I have a regular IP4 address for each printer - 192.168.1.72 and 71

Just pinged each from a command window and they each answer so it seems my persistent port is not set.

No need to define a DHCP range and manually assign outside the range.