cancel
Showing results for 
Search instead for 
Did you mean: 

Packages that won't work on the CCGI servers

Community Veteran
Posts: 26,722
Thanks: 936
Fixes: 10
Registered: ‎10-04-2007

Packages that won't work on the CCGI servers

We are starting to see some new versions of packages that will not run on Plusnet's CCGI servers because they do not have php5.
From the php website:
Quote
PHP 4 end of life announcement
[13-Jul-2007]Today it is exactly three years ago since PHP 5 has been released. In those three years it has seen many improvements over PHP 4. PHP 5 is fast, stable & production-ready and as PHP 6 is on the way, PHP 4 will be discontinued.
The PHP development team hereby announces that support for PHP 4 will continue until the end of this year only. After 2007-12-31 there will be no more releases of PHP 4.4. We will continue to make critical security fixes available on a case-by-case basis until 2008-08-08. Please use the rest of this year to make your application suitable to run on PHP 5.

For nearly a year PUG have been asking when Plusnet will support php5 on the CCGI servers. Today a PUG member has posted (snipped a bit):
Quote
PUG did try pushing this item at the recent meeting with PlusNet.  No formal response, but lots of reasons why not.
It's becoming a positive disincentive to use the Web hosting function on such a dated platform which will soon be obsolete and unsupported.
We'll keep on pushing.

So far I've seen the following packages that will not run on the CCGI servers because of the lack of PHP5:
MediaWiki 1.11
Drupal 7
From the phpMyAdmin website
Quote
The phpMyAdmin project is a member of the GoPHP5 initiative. Starting February 5, 2008, we will accept PHP 5.2 features into our codebase and our new feature releases will no longer provide support for older PHP versions.

From the PEAR website
Quote
After being the leader and most used PHP applications and libraries for many years with over 30 Million downloads, the PEAR Project is happy to announce that the next version of PEAR, named PEAR2, is going to aim at being only available for PHP5.2 and newer versions of PHP.
PEAR2 is currently not released but under development with a new installer (Pyrus) coming along the way. Using the benefits of the PHP Archiver (PHAR) and the features that PHP5.2 offers, we can now produce better applications than ever using the PHP language.
Thanks to all our users and especially our dedicated developers for making this possible. Without them, we would not be able to achieve and reach a goal that has been important to us for the few past years, moving to PHP5.

Mantis: Dropping Support for PHP 4
We have been thinking about the right time to drop support for PHP 4.x.x for a while now. The main drive is that in order for Mantis to use new PHP 5 features, we will have to drop PHP 4 support. We are thinking that it makes sense for 1.1.x to be the last Mantis release that supports PHP 4.x.x and starting with Mantis 1.2.0 have PHP 5 as the minimum requirement.
Is anyone aware of versions other packages that require php5?
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
14 REPLIES
glyndev
Grafter
Posts: 620
Registered: ‎31-07-2007

Re: Packages that won't work on the CCGI servers

I can't remember the names of the packages but I have downloaded several over the last 12 months where the latest 3 or 4 releases or even the first release require PHP5 and are not compatible with PHP4.
In their stubourness  +net are forcing people to move elswhere and burying their heads in the sand about it.
Or is it a strategic ploy to try to get people to move to their new hosting service.
Community Veteran
Posts: 26,722
Thanks: 936
Fixes: 10
Registered: ‎10-04-2007

Re: Packages that won't work on the CCGI servers

Another one (from this post)
MediaWiki
Quote
MediaWiki 1.11 requires PHP 5 (5.1 recommended). PHP 4 is no longer supported.

Anyone know of any more?
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
MikeWhitehead
Grafter
Posts: 748
Registered: ‎19-08-2007

Re: Packages that won't work on the CCGI servers

The GoPHP5 site gives a list of all the projects that have either moved to PHP5, accepting PHP5 code into their current codebase, or will be utilising PHP5 in their upcoming release(s).
I really don't see the big problem with upgrading to PHP5, or at least allowing for PHP5 by default with legacy support.
Community Veteran
Posts: 26,722
Thanks: 936
Fixes: 10
Registered: ‎10-04-2007

Re: Packages that won't work on the CCGI servers

Nor can most other people!
Have a read of the links in my signature - PUG have been pushing it apparently and not getting answers.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
MikeWhitehead
Grafter
Posts: 748
Registered: ‎19-08-2007

Re: Packages that won't work on the CCGI servers

Yep, I voted on that item quite a while back, but it seems to be to no avail. There has been plenty talk about an upgrade, so the majority of users should understand that there would be a change. Personally, I have webspace elsewhere so I wouldn't be using my PlusNet webspace, but I feel the pain of others who are resigned to using outdated/vulnerable code due to the lack of an upgrade. If user-written code breaks on an upgrade, then that user will just need to code better (I've not looked into the transition greatly, it doesn't look too bad. More to do with better coding practices which can only be a good thing) And to ensure you don't use depreciated code prior to a live update, u could just use the E_STRICT error level.
Community Veteran
Posts: 4,729
Registered: ‎04-04-2007

Re: Packages that won't work on the CCGI servers

The bad news;
So far only about 0.02% of PlusNet customers have voted on PUGIT indicating that this is an issue form them. Hardy good justification for a business case to update the CGI servers.
The good news;
In February PlusNet started setting up a "Future of CGI Working Group" with the PlusNet UserGroup, I can not comment of their progress so far, as due to time constraints I was unable to volunteer. But it does show that PlusNet are ready to start writing the specifications for the next generation of CGI servers.
Chilly
pierre_pierre
Grafter
Posts: 19,757
Registered: ‎30-07-2007

Re: Packages that won't work on the CCGI servers

Yes and what percentage of the Total Plusnet users see this Forum or the Pug Forum, I for one am not a Pug member Cry
Community Veteran
Posts: 4,729
Registered: ‎04-04-2007

Re: Packages that won't work on the CCGI servers

Highlighted
oliverb
Grafter
Posts: 606
Registered: ‎02-08-2007

Re: Packages that won't work on the CCGI servers

Well it'd be dishonest of me to register as I don't code PHP but hey: its discontinued, right?
Community Veteran
Posts: 14,469
Registered: ‎30-07-2007

Re: Packages that won't work on the CCGI servers

Only PHP version 4 which is replaced by PHP version 5 hence why the CCGI servers need to support PHP 5.
oliverb
Grafter
Posts: 606
Registered: ‎02-08-2007

Re: Packages that won't work on the CCGI servers

BTW I see you meant register for the PUG, I thought that was going to be some kind of poll.
Community Veteran
Posts: 26,722
Thanks: 936
Fixes: 10
Registered: ‎10-04-2007

Re: Packages that won't work on the CCGI servers

Once you have registered you can vote for PUGIT 290
The last response from Plusnet to this item was on 29 Aug 07 08:43 by Bob Pullen:
Quote
The current servers will not be upgraded to PHP5. However when CGI gets rebuilt at some point then it will be there as standard. This is not currently on the development roadmap so no firm dates for implementation can be offered.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
Community Veteran
Posts: 26,722
Thanks: 936
Fixes: 10
Registered: ‎10-04-2007

Re: Packages that won't work on the CCGI servers

Zen Cart
On August 12, 2007, Zen Cart team announced that the future versions of the software, starting with 1.4.0 will require PHP 5.2 as a minimum.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
Community Veteran
Posts: 26,722
Thanks: 936
Fixes: 10
Registered: ‎10-04-2007

Re: Packages that won't work on the CCGI servers

PhpGedView
Your web server needs to be running PHP version 4.4 or greater to generate dynamic HTML pages and use all of PhpGedView 4.1.x functions.
Current version on ccgi is Version 4.3.10
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)