cancel
Showing results for 
Search instead for 
Did you mean: 

[PAYH] Problem accessing cgi files

BestPump
Grafter
Posts: 42
Registered: ‎19-09-2007

[PAYH] Problem accessing cgi files

Hi All,
I've just created my database and set up FTP for the new platform.
I have uploaded my shopping cart software into the cgi-bin folder but when I try to access it via the browser, it's as if there are no files there.
My platform web address is http://bestpump.plushost.co.uk/ and I assume that the cgi-bin should be accessed via http://ccgi.bestpump.plushost.co.uk/ but there's nothing there.
Please can anyone help?
Thanks,
Jeff
7 REPLIES
Community Veteran
Posts: 767
Registered: ‎29-10-2008

Re: [PAYH] Problem accessing cgi files

Quote from: BestPump
http://ccgi.bestpump.plushost.co.uk/ but there's nothing there.

Should be www.bestpump.plushost.co.uk/cgi-bin/
Gabe
BestPump
Grafter
Posts: 42
Registered: ‎19-09-2007

Re: [PAYH] Problem accessing cgi files

Should this show up then?
http://www.bestpump.plushost.co.uk/cgi-bin/index.html
It's just an HTML doc with <h1>Hello</h1> but I get a 500 internal server error message.
Anything I upload refuses to display. Permissions are set to 755.
On the other hand, the default file here: http://www.bestpump.plushost.co.uk/cgi-bin/test/test.cgi displays OK!
What's going on?
Jeff
Community Veteran
Posts: 767
Registered: ‎29-10-2008

Re: [PAYH] Problem accessing cgi files

The cgi-bin is set up to interpret only a limited range of extension types, e.g. .cgi, .pl, and doesn't know what to do with .html. Your .html files need to go in the httpdocs folder. If your site uses .php files, they also go in httpdocs.
Gabe
BestPump
Grafter
Posts: 42
Registered: ‎19-09-2007

Re: [PAYH] Problem accessing cgi files

Thanks for your help, Gabe. Now I'm getting somewhere!
I've moved the files from cgi-bin to httpdocs and now the files are showing up.
My new problem seems to be permissions based. When I run my shopping cart installer, it runs through a checklist successfully until the last item which is "The installation directory must be enabled for writing:". I've set all permissions to 775 and tried 755 but it still fails.
Addition: I've set the httpdocs folder and the sub-folder containing the installer to 775 permissions but it still fails.
Can anyone help?
Regards,
Jeff
Community Veteran
Posts: 767
Registered: ‎29-10-2008

Re: [PAYH] Problem accessing cgi files

Try 777.
Gabe
BestPump
Grafter
Posts: 42
Registered: ‎19-09-2007

Re: [PAYH] Problem accessing cgi files

Another step forward and then another fall!
Any idea if I can turn PHP safe mode off?
I'm getting this error now:
"Unable to extract files
Error while opening {file.php} in write binary mode"

Jeff
Community Veteran
Posts: 767
Registered: ‎29-10-2008

Re: [PAYH] Problem accessing cgi files

Sadly, no. We're stuck with safe mode until Plus decide to upgrade PAYH to Plesk 9 (or go for an unsupported fix).
I've had no reply to my requests that Plus keep the ccgi platform running until they upgrade PAYH.
Gabe