cancel
Showing results for 
Search instead for 
Did you mean: 

New CGI Webspace - websites vanished

UncleZen
Rising Star
Posts: 111
Thanks: 16
Fixes: 2
Registered: ‎15-08-2008

New CGI Webspace - websites vanished

Thanks PlusNet.
Im working on stuff for a project and its all gone.
Where are my websites?
The URL's no longer work. I do not have permission to access the folder(s) / 403 forbidden.
Ive just jumped through hoops to get the FTP connected and I see a /public folder with sub-folders that look like my stuff might reside there, but when I go there I get permission denied.
Username: unclezen.
Go figure. I'm well annoyed this evening. Angry
11 REPLIES 11
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: New CGI Webspace - websites vanished

I think this topic, added since your post, explains what's happened and what Plusnet are doing to fix the problem.
David
David
UncleZen
Rising Star
Posts: 111
Thanks: 16
Fixes: 2
Registered: ‎15-08-2008

Re: New CGI Webspace - websites vanished

Thanks, I await a solution.
@plusnet how about some decent project management and sufficient testing?
UncleZen
Rising Star
Posts: 111
Thanks: 16
Fixes: 2
Registered: ‎15-08-2008

Re: New CGI Webspace - websites vanished

It would be nice if a progress update was posted alongside the "Problems with CGI site migration 4th/5th March? - READ ME FIRST" topic.
bobpullen
Community Gaffer
Community Gaffer
Posts: 14,877
Thanks: 2,478
Fixes: 168
Registered: ‎04-04-2007

Re: New CGI Webspace - websites vanished

Your problem should be fixed, let me know if you're still having difficulties. This was an unforeseen error and there's been months of testing. Sorry to have inconvenienced you Sad

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

UncleZen
Rising Star
Posts: 111
Thanks: 16
Fixes: 2
Registered: ‎15-08-2008

Re: New CGI Webspace - websites vanished

Thanks for the update.
All my sites except one are present.
There was a site in a /dev/scgb-new-php folder thats now gone, but I can easily reinstate it so dont worry.
All the files look like they are there (apart for those above) but the sites dont work as the paths are wrong.
UncleZen
Rising Star
Posts: 111
Thanks: 16
Fixes: 2
Registered: ‎15-08-2008

Re: New CGI Webspace - websites vanished

An update on paths.
The only site Ive checked so far (I have several test sites) doesnt work as it tries to load data from a data file.
On the old hosting I would verify that the file exists , using php file_exists and give the full path to the file, that would be something like this on the old hosting:
/files/home1/my_username/whatever/path/to/file/filename.dat
On the new hosting, based on the home directory value shown in the Disk Usage > Setup/Environment screen, I'm using:
/services/webpages/c/c/ccgi.my_username.plus.com/whatever/path/to/file/filename.dat
and the file is not found, but the file is present and can be loaded directly into the browser from the address bar.
Have I misunderstood paths?
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: New CGI Webspace - websites vanished

Quote from: UncleZen
On the new hosting, based on the home directory value shown in the Disk Usage > Setup/Environment screen, I'm using
/services/webpages/c/c/ccgi.my_username.plus.com/public/whatever/path/to/file/filename.dat
and the file is not found, but the file is present and can be loaded directly into the browser from the address bar.

You need to add /public where I've marked in red in the quote.
David
UncleZen
Rising Star
Posts: 111
Thanks: 16
Fixes: 2
Registered: ‎15-08-2008

Re: New CGI Webspace - websites vanished

Thanks, I'll try that out later when I get home.
UncleZen
Rising Star
Posts: 111
Thanks: 16
Fixes: 2
Registered: ‎15-08-2008

Re: New CGI Webspace - websites vanished

Tried it out and yes, its working thanks for the tip.
However I have noticed that the one site I have looked at is weeks out of date, I cant tell exaclt how old it only that for me to be absolutley sure its upto date I'll have to re-load all the files from my local copy.
I have loads of work to do to bring these sites back up to date.
@plusnet Sureley a "recent" backup was used before you restored and migrated the data?
bobpullen
Community Gaffer
Community Gaffer
Posts: 14,877
Thanks: 2,478
Fixes: 168
Registered: ‎04-04-2007

Re: New CGI Webspace - websites vanished

Quote from: UncleZen
However I have noticed that the one site I have looked at is weeks out of date, I cant tell exaclt how old it only that for me to be absolutley sure its upto date I'll have to re-load all the files from my local copy.

We can import a more recent copy for you if you like? Failing that, the old database is still accessible from a Plusnet IP using our phpMyAdmin interface.
Quote from: UncleZen
@plusnet Sureley a "recent" backup was used before you restored and migrated the data?

Yes, that was the intention. Unforeseen delays during the provisioning of this latest batch of accounts has led to some of the data being significantly out of date though. Apologies for the inconvenience. Lack of foresight on our part.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

UncleZen
Rising Star
Posts: 111
Thanks: 16
Fixes: 2
Registered: ‎15-08-2008

Re: New CGI Webspace - websites vanished

Thanks Bob,
Ive re-uploaded all the out-of date stuff now.