cancel
Showing results for 
Search instead for 
Did you mean: 

Installing Wordpress

pjay
Dabbler
Posts: 14
Registered: ‎30-07-2007

Installing Wordpress

Hi,
I'm completely new to Wordpress and I've tried to follow the Plusnet Installation guide, but with no success.
I have two domains hosted at Plusnet. The one I want to install Wordpress on is in a subfolder 'xyz', pointed to by www.xyz.co.uk. I'd like to have a Wordpress blog at www.xyz.co.uk.
I have enabled CGI and MySQL, downloaded Wordpress, and edited 'wp.config' to include the username, hostname, password for my database. Do you leave in the ' ' marks? i.e. is this correct: define('DB_HOST', 'rumpus');
I have uploaded the Wordpress folder (renamed 'wp') to the 'xyz' folder on the server using Cyberduck on my Mac.
I believe that the next step is to run 'install.php', which I have tried to do by typing http://www.xyz.co.uk/wp/wp-admin/install.php into the address bar of my web browser. When I do so, Safari just downloads 'install.php'.
Can anyone help, please?
Many Thanks,
Pete
6 REPLIES 6
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Installing Wordpress

Yes, the single quotes on configuration lines must be retained, define('DB_HOST', 'rumpus'); is correct.
Did you also create and add unique key and salt codes to the wp-config.php file?
Macs use different line endings from Windows PCs and from Linux (server); FTP programs usually translate between these on files uploaded in ASCII mode from PCs, but I don't know if Cyberduck does that and if it copes with Macs. Did you upload the files as ASCII or binary? And the WordPress files are a mixed bunch in any case (which AUTO mode transfers usually cope with). The problem you have with install.php being listed suggests it is being treated as a text file with line endings not recognised.
Have you set the uploaded directory and file permissions correctly? See the CGI platform PHP upgrade FAQ support library document.
David
David
pjay
Dabbler
Posts: 14
Registered: ‎30-07-2007

Re: Installing Wordpress

Hi,
I hadn't set the salt codes, but have done now.
Cyberduck is set to 'auto' upload settings, with Unix line endings. It says that php and cgi files are uploaded in ASCII in this mode.
I have set the file permissions of the Wordpress folder and its contents to 710, and now I am getting a '403 forbidden' error when I try to run install.php
Any ideas?
Thanks,
Pete
pjay
Dabbler
Posts: 14
Registered: ‎30-07-2007

Re: Installing Wordpress

I have been uploading to twww.<username>.plus.com/htdocs/, when I think I should have been uploading to ccgi.<username>.plus.com/htdocs/
Having done this, I have successfully installed Wordpress. The only problem is that my blog is now at http://ccgi.<username>.plus.com/wp/
I would like it to be at http://www.xyx.co.uk/
Does anyone know how to achieve this, please?
Thanks,
Pete
pjay
Dabbler
Posts: 14
Registered: ‎30-07-2007

Re: Installing Wordpress

Looking at this thread, I have realised that the main free webspace and the CGI space are on different servers:
http://community.plus.net/forum/index.php?topic=83425.16
Is there an easy way (using the Plusnet control panel?) to make my domain xyz.co.uk (which is hosted by Plusnet) point to my blog in the CGI space so that the URL in the browser stays as xyz.co.uk
I have tried using a .htaccess file to re-direct, but the URL changes to ccgi.<username>.plus.com/wp when I type xyz.co.uk
Hope this makes sense.
Pete
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Installing Wordpress

Does the information in this thread help? That covers an update related to the current ccgi platform.
David
pjay
Dabbler
Posts: 14
Registered: ‎30-07-2007

Re: Installing Wordpress

Thanks, some interesting info there. Looks very complicated though.