cancel
Showing results for 
Search instead for 
Did you mean: 

Install phpbb3

spiritus
Newbie
Posts: 3
Registered: 07-12-2007

Install phpbb3

I am also have problems installing phpbb3 on the CGI server after upload and following the install and trying to navigate to:
http://ccgi.username.plus.com/~username/phpBB3/install/index.php or http://ccgi.username.plus.com/phpBB3/install/index.php
I keep getting error 500
###############################################################
Server error!
The server encountered an internal error and was unable to complete your request.
Error message:
Premature end of script headers: index.php
If you think this is a server error, please contact the webmaster.
Error 500
ccgi.username.plus.com
Wed Jul 6 20:44:03 2011
Apache
###############################################################
I can navigate to another folder and view phpbb3/docs/index.html ok.
I think it has something to do with permissions or the .htaccess file but as the CGI was updated recently is there some kind of Mod or Permissions specific to allow this to work.
Cheers Dan
2 REPLIES
spiritus
Newbie
Posts: 3
Registered: 07-12-2007

Re: Install phpbb3

I have figured this one out and I got this working it was the permissions. Cant believe how permission specific this has to be. Now running the Install.
Cheers
Dan  Grin
Superuser
Superuser
Posts: 9,514
Thanks: 868
Fixes: 53
Registered: 06-04-2007

Re: Install phpbb3

Saw your update as I was about to post, but thought I'd post anyway.
Yes, the problem is most likely related to a problem with .htaccess files or to file and directory permissions.
It is worth reading the CGI Platform PHP Upgrade FAQ which accompanied that upgrade in March 2010. Item 8 covers likely causes of server 500 errors.
One thing you must do is ignore information on file and directory permissions given in the phpbb3 install guide, the ones given in item 6 of the FAQ should work.
The easiest way to set executable file and directory permissions to those required is to upload and run the script hot-linked in item 6 of the FAQ which is here.
Did you upload all files containing text as ASCII format, and images as binary? An FTP program transfer setting of 'auto' would probably get that right.
David
David