cancel
Showing results for 
Search instead for 
Did you mean: 

Instaling Wordpress

dnalsmar
Newbie
Posts: 2
Registered: ‎13-02-2011

Instaling Wordpress

I am new to this and taking advice from a video on U tube and your help files. I thought I had uploaded Wordpress using foxzilla to my plusnet webspace but when I go www.ramsland.plus.com it takes me to a plus net page and says I have nothing loaded.
I was expecting to get a create configuration file screen. Now I do not know what to do! Can any one help. On Foxzilla the files and directories look the same on my c drive as on the right hand side. I copied the Wordpress folder into the htdocs - is that correct?
Any help would be appreciated.
4 REPLIES 4
Peter_Vaughan
Community Veteran
Posts: 14,469
Registered: ‎30-07-2007

Re: Instaling Wordpress

You have uploaded to your homepages webspace... this will not run PHP. PLusntet have two webspaces on some accounts, homepages for running basic HTML based websites and ccgi for running php/cgi based websites.
If your account has it, you need to activate your ccgi webspace and MySQL database. You should see icons to do this under Website Setting on your Member Centre page. If you don't have those icons then your package does not support ccgi/MySQL and you won't be able to install and run Wordpress.
dnalsmar
Newbie
Posts: 2
Registered: ‎13-02-2011

Re: Instaling Wordpress

I have now uploaded Wordpress via the cgi server and gone to  ccgi.ramsland.plus.com / the message reads:
Access forbidden!
You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.
How do I set up an index , I read the bits on the cgi help screen which gives the following information:
"Directory listing is switched off so unless you are directly referencing a specific file, you'll need an index file in place to see your site.
The server will look for index files in the following order:
index.html, index.html.var, index.htm, index.shtml, index.cgi, index.pl, index.php"
I am not clear what is required - suggestions welcome.
I have put  Wordpress in the main directory , not the cgu bin - is that correct?
Mattz0r
Rising Star
Posts: 620
Fixes: 1
Registered: ‎21-07-2010

Re: Instaling Wordpress

Hello there,
You may need to fix some of the file persmission, as per the FAQ found @ http://community.plus.net/library/settings/cgi-platform-php-upgrade-faq/
Here is the extract which is relavent to yourself.
6) What file permissions should I use on the new platform?
We recommend you set permissions on your files as follows. Thanks to 'Gabe' on the community forums for his helpful post regarding this topic here.
    * Folders: We recommend setting your folder permissions to 710 (drwx--x---). If you need to use more relaxed permissions then we suggest setting things no higher than 750 (drwxr-x---). Some packages, like Wordpress, may encourage you to set folder permissions to 777, but we advise against this. If 710 is insufficient, try 750 but no higher.
    * Scripts: We recommend setting script permissions to 700 (-rwx------) and no higher.
    * Static web content: e.g. Apache files like .htaccess and .htpassword and other static web content like html, css and javascript files should be left at the default value of 640 (-rw-r-----).
    * Other files: Files which are only read from and written to by scripts, but not served to browsers can be set to 600 (-rw-------). This includes log files, ini files and certificate files.

Hope this helps,
Regards,
Matt
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Instaling Wordpress

Quote from: dnalsmar
You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.
How do I set up an index?

It's an index document that is being looked for, not an index. An index document is a specific web page definition file. Since you didn't ask for a specific page in your URL …
Quote from: dnalsmar
The server will look for index files in the following order:
index.html, index.html.var, index.htm, index.shtml, index.cgi, index.pl, index.php

… one of those is what's needed.
Quote from: dnalsmar
I have put  Wordpress in the main directory , not the cgu bin - is that correct?

Either will do, but keeping it outside cgi-bin is more convenient. Have you uploaded all your WordPress files so some of them are in the top level '/', or do they start in /wordpress (which is more usual)?
David