cancel
Showing results for 
Search instead for 
Did you mean: 

Instal webtrees

appleshaw
Grafter
Posts: 32
Registered: ‎03-07-2008

Instal webtrees

As Plus has upgraded and MySQL now has PDO drivers I have tried to instal webtrees, which is a development of phpgedview. However having loaded the files and started the configuration I get the very unhelpful message
'Error message:
Premature end of script headers: index.php '
I have since used another ISP site which reports details of why the installation has failed. To do this I part loaded sections and at one point it suggested the PDO drivers had not loaded.
Any clues as to how to find out what is missing?
6 REPLIES
Superuser
Superuser
Posts: 9,925
Thanks: 1,265
Fixes: 71
Registered: ‎06-04-2007

Re: Instal webtrees

Does section 9 of the CGI Platform PHP Upgrade FAQ give any clues?
David
Superuser
Superuser
Posts: 9,925
Thanks: 1,265
Fixes: 71
Registered: ‎06-04-2007

Re: Instal webtrees

The webtrees system requirements list http://wiki.webtrees.net/System_requirements says MySQL 5.0.13 or later is needed. Unfortunately Plusnet's version is 4.1.11.
Prospects for getting that upgraded any time soon do not appear to be bright. Sad
David
appleshaw
Grafter
Posts: 32
Registered: ‎03-07-2008

Re: Instal webtrees

Set folders to 710 and the initial php files to 700 and have now got into setup.
I thought that I had seen that the MySQL had also been upgraded - otherwise I am wasting my time. The links from phpMyAdmin refer to v.5 OK that does not mean a lot.
Now have to sort out from phpgedview the data needed for Db names - i know humbug but may have to download data & start again
Superuser
Superuser
Posts: 9,925
Thanks: 1,265
Fixes: 71
Registered: ‎06-04-2007

Re: Instal webtrees

The user interface to MySQL is v5 but MySQL itself is 4.1.11. phpMyAdmin shows that top left of its homepage. Having got this far it is worth seeing if webtrees actually checks.
The server login data is the same as you must be using to login to phpMyAdmin and the database name will be shown at the top of phpMyAdmin's navigation panel - likely to be your username_pn assuming you are a Plusnet vISP customer.
Otherwise the information should be in the phpgedview configuration file which would normally be in its top level folder.
David
appleshaw
Grafter
Posts: 32
Registered: ‎03-07-2008

Re: Instal webtrees

Have come back to see if there is any change here. webtrees needs MySQL 5.0.13 and the installation does check for this.
The front page of Plus MySQL shows
Server version: 4.1.11-Debian_4sarge7-log
MySQL client version: 5.0.51a
That client version seems to be what is needed. Is there any way to access it?
Superuser
Superuser
Posts: 9,925
Thanks: 1,265
Fixes: 71
Registered: ‎06-04-2007

Re: Instal webtrees

The 'client version' refers to the API that clients link to. Unfortunately the database the API passes SQL commands to is still MySQL 4.1.11 so only SQL 4.1.11 commands will work.
Since you've confirmed webtrees checks for version 5.0.13 unfortunately it's nogo. Sad
David