cancel
Showing results for 
Search instead for 
Did you mean: 

Extraneous characters in 'advance notice of direct debit' email

Peterworks
Rising Star
Posts: 69
Thanks: 8
Fixes: 1
Registered: ‎17-02-2008

Extraneous characters in 'advance notice of direct debit' email

Within the last two months I have been getting the above where the pounds sign is being replaced with a black diamond with a white question mark in it.

I know Yahoo mail have been having problems because of misconfiguring '8bitmime' on their SMTP system.

Is PlusNet having the same problem ? I could find no mention of the character set being use when viewing the message source.

I have UTF8 set for display in Thunderbird which should be able to translate just about anything (apparently).

Anyone else getting this problem ?

7 REPLIES 7
Browni
Aspiring Hero
Posts: 2,547
Thanks: 963
Fixes: 51
Registered: ‎02-03-2016

Re: Extraneous characters in 'advance notice of direct debit' email

I see the same if I view the email in webmail on Chrome, Pale Moon & Edge but the email renders correctly in Outlook 2016.

Ex-Plusnetter now living life in the G,fast lane!
spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Extraneous characters in 'advance notice of direct debit' email

UTF-8 will dispaly characters correctly only if all the octets present are valid UTF-8 ones. This excludes the range A0-FF. The Plusnet £ sign is probably in that range. Does it display correctly if you view the message with Western encoding?

David
Peterworks
Rising Star
Posts: 69
Thanks: 8
Fixes: 1
Registered: ‎17-02-2008

Re: Extraneous characters in 'advance notice of direct debit' email

Hi David,

Have tried Western (ISO-8859-1) and Western (Windows-1252) but no change.

 

spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Extraneous characters in 'advance notice of direct debit' email

My default outgoing is UTF-8 and incoming Western (iso-8859-1) and works OK for me. Incoming UTF-8 is detected and displayed as such.

Have you tried selecting a message in the list then clicking View->Text Encoding and selecting Western?

David
Peterworks
Rising Star
Posts: 69
Thanks: 8
Fixes: 1
Registered: ‎17-02-2008

Re: Extraneous characters in 'advance notice of direct debit' email

Thanks spraxyt - changing text encoding to Western worked.

Will follow your suggestion and set incoming as Western (ISO-8859-1) and see how it goes.

 

spraxyt
Superuser
Superuser
Posts: 10,063
Thanks: 1,369
Fixes: 75
Registered: ‎06-04-2007

Re: Extraneous characters in 'advance notice of direct debit' email

I don't recall setting those defaults when I installed Thunderbird on this relatively new PC so I assume they are the set-up values. I think it is plain text messages where the default will be used, and Western (ISO-8859-1) is probably appropriate for us. HTML emails might use UTF-8 but they will say so and that is respected.

David
Peterworks
Rising Star
Posts: 69
Thanks: 8
Fixes: 1
Registered: ‎17-02-2008

Re: Extraneous characters in 'advance notice of direct debit' email

I cannot remember the set-up values on initial installation. I 'played' with text encoding to help a friend who is on Yahoo (using IMAP in Thunderbird). They (Yahoo) have a problem with their SMTP as detailed here: https://forums.yahoo.net/t5/Sending/Yahoo-SMTP-server-advertising-8bit-capability-incorrectly-and/td...

I then made enquiries on another forum I am on because I was getting the same problem with email alerts from them. The administrator changed outgoing encoding to UTF-8 and all was okay. That is why I raised it here.

As stated above I will see how it goes using your set up in post 5.