cancel
Showing results for 
Search instead for 
Did you mean: 

Database gone on my phpMyAdmin?

Community Veteran
Posts: 2
Registered: 30-07-2007

Database gone on my phpMyAdmin?

Not sure what's happened  here.  When I log into phpMyAdmin my database seems to have gone.  It's still there as my website works but I can't see  it in phpMyAdmin. It was there before as I was populating tales via SQL imports.  Any idea what I may have messed up? I've uninstalling and re-installing phpMyAdmin.  Thanks.
7 REPLIES
Superuser
Superuser
Posts: 9,045
Thanks: 498
Fixes: 43
Registered: 06-04-2007

Re: Database gone on my phpMyAdmin?

I doubt this is something you've messed up. I have the same problem and from personal contact I know of two other customers who are also affected. I suspect it might result from something two nights ago when my databases 'disappeared' around 00:30. An application running at that time halted while trying to access the database.
The databases were 'back' when I checked next day, and that application continued from where it was up to when I restarted it.
However it wasn't until this afternoon that I checked phpMyAdmin and discovered the access problem.
David
David
DavidEvans
Newbie
Posts: 2
Registered: 02-08-2007

Re: Database gone on my phpMyAdmin?

My database has "gone" too, both from PHPMyAdmin and from Website.
How long should I wait before making a fuss, and to whom?
Another David
Superuser
Superuser
Posts: 9,045
Thanks: 498
Fixes: 43
Registered: 06-04-2007

Re: Database gone on my phpMyAdmin?

As I have done, I suggest raising a support ticket under Plusnet Hosting (CGI) https://www.plus.net/wizard/?p=wizard&page=23097&wizard_id=38 reporting the problem. Despite the system mentioning 39 hours average response time I hope these will be picked up on Monday.
David
David
reavells
Newbie
Posts: 6
Registered: 20-06-2014

Re: Database gone on my phpMyAdmin?

I also have this issue and have also raised a support ticket (have seen various other odd issues occur since Friday.... PHP mail() function stopped working for a while.... various random files had permissions changed from 644 to 000).
If you know the DB name and 1 table name in it then you can try this in phpMyAdmin:
1) Click the "SQL" tab.
2) Execute a query like "select * from <db_name>.<table_name>"
3) Click the "Show All" link on the paging row
4) The DB name then appears along the top of the page next to the server name, and clicking on it shows you all the tables.
Might be useful in the meantime until the issue is properly addressed.
Community Gaffer
Community Gaffer
Posts: 12,959
Thanks: 749
Fixes: 69
Registered: 04-04-2007

Re: Database gone on my phpMyAdmin?

I've raised everyone's issues with Hostopia, I'll report back once I've received a response...

Bob Pullen
Plusnet Products Team
If I've been helpful then please give thanks ⤵

Community Gaffer
Community Gaffer
Posts: 12,959
Thanks: 749
Fixes: 69
Registered: 04-04-2007

Re: Database gone on my phpMyAdmin?

I've received word that the phpMyAdmin issues should be resolved. You may need to delete your phpMyAdmin install directory from /private and reinstall the application.
@me@butterflies, I've done this with your account and I'm now able to see database content when logged in. I've used your default Plusnet username and your Hosting Control Panel password if you want to give it a go?

Bob Pullen
Plusnet Products Team
If I've been helpful then please give thanks ⤵

Superuser
Superuser
Posts: 9,045
Thanks: 498
Fixes: 43
Registered: 06-04-2007

Re: Database gone on my phpMyAdmin?

phpMyAdmin access to my database tables works again now. Initially, whilst the tables were listed some of them showed as corrupted and 'select' access was refused. The relevant applications also showed errors. Using Cntrl-F5 made no difference.
However after a few minutes applications started working again and both phpMyAdmin and Adminer showed no errors. Smiley
David