cancel
Showing results for 
Search instead for 
Did you mean: 

CGI webspace issues producing rubbish text on forum pages.

12stringbassist
Grafter
Posts: 26
Thanks: 2
Fixes: 1
Registered: ‎11-05-2016

CGI webspace issues producing rubbish text on forum pages.

I've been talking at some length about issues on my forum at http://ccgi.crazeeworld.plus.com/slade/index.php - hosted by plusnet.

I am getting strings of rubbish text (see bottom of my post), so i started a support request topic at PHPBB, to see if PHPBB was broken. The experts there say there is an issue with how coding is handled on the PN server.
The topic is at https://www.phpbb.com/community/viewtopic.php?f=661&t=2584866

The conclusion from what is happening is "There is also some clue in the fact "this is only happening when the PHP htmlspecialchars() API is being called", since that is the only function ever cited in these warnings. As though maybe something is setup on that server to "protect" or otherwise intercept when this particular PHP function is called; but for some reason whatever it intended to do is going bad."

I'm not trying to lay any blame here - just pointing out an issue and hoping it can be resolved.
I've been with Plus Net for about 10 years or so and stay because of the forum hosting being essential.

Any advice will be most gratefully received.

I see other people on here are having some issues over the last week or so with CGI and thought I'd best come to you to see what is known about the state of the CGI server.

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 86: htmlspecialchars(): charset `bb/user $user Object of the current user * @param string $default A timezone to select * @param boolean $truncate Shall we truncate the options text * * @return array Returns an array containing the options for the time selector. */' not supported, assuming utf-8
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 151: htmlspecialchars(): charset `bb/user $user Object of the current user * @param string $default A timezone to select * @param boolean $truncate Shall we truncate the options text * * @return array Returns an array containing the options for the time selector. */' not supported, assuming utf-8
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 152: htmlspecialchars(): charset `bb/user $user Object of the current user * @param string $default A timezone to select * @param boolean $truncate Shall we truncate the options text * * @return array Returns an array containing the options for the time selector. */' not supported, assuming utf-8
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/user.php on line 329: htmlspecialchars(): charset `bb/user $user Object of the current user * @param string $default A timezone to select * @param boolean $truncate Shall we truncate the options text * * @return array Returns an array containing the options for the time selector. */' not supported, assuming utf-8
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4130: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3009)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4130: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3009)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4130: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3009)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4130: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3009)

 

Tags (3)
10 REPLIES 10
12stringbassist
Grafter
Posts: 26
Thanks: 2
Fixes: 1
Registered: ‎11-05-2016

Re: CGI webspace issues producing rubbish text on forum pages.

I can see I'm going to have to spend my Friday on the phone, as I can't raise a ticket online anymore to get this resolved.

12stringbassist
Grafter
Posts: 26
Thanks: 2
Fixes: 1
Registered: ‎11-05-2016

Re: CGI webspace issues producing rubbish text on forum pages.

Support Ticket raised on phone.

12stringbassist
Grafter
Posts: 26
Thanks: 2
Fixes: 1
Registered: ‎11-05-2016

Re: CGI webspace issues producing rubbish text on forum pages.

No updates on anything from Plusnet to my ticket.
Does anyone from support read this forum?

This is really causing me some hideous issues.

BigDaz
Rising Star
Posts: 64
Thanks: 2
Fixes: 1
Registered: ‎15-08-2007

Re: CGI webspace issues producing rubbish text on forum pages.

Just going to add I'm in exactly the same boat. Started getting PHP warning errors with 3.3.2 and so upgraded to 3.3.3 to try and fix it. I'm getting exactly the same warnings and problems on mine. 

BigDaz
Rising Star
Posts: 64
Thanks: 2
Fixes: 1
Registered: ‎15-08-2007

Re: CGI webspace issues producing rubbish text on forum pages.

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 86: htmlspecialchars(): charset `Finale_2020//CalienteLigaMXFinale_2020.png","riseagain":"https:////abs.twimg.com//hashflags//ISL_2020_GOA//ISL_2020_GOA.png","magicishere":"https:////abs.twimg.com//hashflags//DisneyParks_MickeyEars_Flight4_Update//DisneyParks_MickeyEars_Flight4_Update.png","vivasnosqueremos":"https:////abs.twimg.com//hashflags//StopViolenceAgainstWomen_2020//StopViolenceAgainstWomen_2020.png","neutralidaddelared":"https:���' not supported, assuming utf-8

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 151: htmlspecialchars(): charset `Finale_2020//CalienteLigaMXFinale_2020.png","riseagain":"https:////abs.twimg.com//hashflags//ISL_2020_GOA//ISL_2020_GOA.png","magicishere":"https:////abs.twimg.com//hashflags//DisneyParks_MickeyEars_Flight4_Update//DisneyParks_MickeyEars_Flight4_Update.png","vivasnosqueremos":"https:////abs.twimg.com//hashflags//StopViolenceAgainstWomen_2020//StopViolenceAgainstWomen_2020.png","neutralidaddelared":"https:���' not supported, assuming utf-8

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 152: htmlspecialchars(): charset `Finale_2020//CalienteLigaMXFinale_2020.png","riseagain":"https:////abs.twimg.com//hashflags//ISL_2020_GOA//ISL_2020_GOA.png","magicishere":"https:////abs.twimg.com//hashflags//DisneyParks_MickeyEars_Flight4_Update//DisneyParks_MickeyEars_Flight4_Update.png","vivasnosqueremos":"https:////abs.twimg.com//hashflags//StopViolenceAgainstWomen_2020//StopViolenceAgainstWomen_2020.png","neutralidaddelared":"https:���' not supported, assuming utf-8

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 1587: htmlspecialchars(): charset `Finale_2020//CalienteLigaMXFinale_2020.png","riseagain":"https:////abs.twimg.com//hashflags//ISL_2020_GOA//ISL_2020_GOA.png","magicishere":"https:////abs.twimg.com//hashflags//DisneyParks_MickeyEars_Flight4_Update//DisneyParks_MickeyEars_Flight4_Update.png","vivasnosqueremos":"https:////abs.twimg.com//hashflags//StopViolenceAgainstWomen_2020//StopViolenceAgainstWomen_2020.png","neutralidaddelared":"https:���' not supported, assuming utf-8

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/user.php on line 329: htmlspecialchars(): charset `Finale_2020//CalienteLigaMXFinale_2020.png","riseagain":"https:////abs.twimg.com//hashflags//ISL_2020_GOA//ISL_2020_GOA.png","magicishere":"https:////abs.twimg.com//hashflags//DisneyParks_MickeyEars_Flight4_Update//DisneyParks_MickeyEars_Flight4_Update.png","vivasnosqueremos":"https:////abs.twimg.com//hashflags//StopViolenceAgainstWomen_2020//StopViolenceAgainstWomen_2020.png","neutralidaddelared":"https:���' not supported, assuming utf-8

[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 1795: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3009)

 

Just got this now which quotes some odd things, not sure what it indicates. 

12stringbassist
Grafter
Posts: 26
Thanks: 2
Fixes: 1
Registered: ‎11-05-2016

Re: CGI webspace issues producing rubbish text on forum pages.

PlusNet passed their servers over to Euroservers a while ago. This explains why their telephone support has no clue at all what I am talking about when I mention CGI web space.. or even just web space.

One of their support people said that they don't provide webspace anymore.

They do. We can access it via our logins, though myPHPadmin had disappeared.
It really is NOT good enough.

I did get someone with a clue on Friday, but he passed me on to the black hole that is the network team.


I'm going to ring every couple of days until someone sorts this.

I think I can get TV interest in the drop in Plusnet's service as my forum serves the band Slade.

12stringbassist
Grafter
Posts: 26
Thanks: 2
Fixes: 1
Registered: ‎11-05-2016

Re: CGI webspace issues producing rubbish text on forum pages.

@BigDaz 

I managed to speak to someone who actually did a server refresh today for me while I was on the phone.
A huge change from being told it's nothing to do with PlusNet now.

Lots of refreshing browsers and clearing internet history and forum cookies meant I got into my forum using my 3rd admin backup account. Reset admin and admin2  passwords.

It is less glitchy now (still some broken code appearing) and removing the URL from the home link in the forum ACP means I don't get kicked out by clicking home, as it doesn't show anymore. That is something to do with the session ID.

There's a forum cookie setting in the  forum ACP where you need to set.
General > Cookie settings - The server location is http://ccgi.crazeeworld.plus.com, so I had to set the top value to .crazeeworld.plus.com - that leading dot is REALLY  important.

Plus Net - Please don't censor out that bold text in the line above - it is the point of the post.

BigDaz
Rising Star
Posts: 64
Thanks: 2
Fixes: 1
Registered: ‎15-08-2007

Re: CGI webspace issues producing rubbish text on forum pages.

I'll give it a try. Thank you.

12stringbassist
Grafter
Posts: 26
Thanks: 2
Fixes: 1
Registered: ‎11-05-2016

Re: CGI webspace issues producing rubbish text on forum pages.

@BigDaz 

Hopefully the server refresh did you some good.
I found that a private browser session on my phone worked fine to access the forum.

This morning, I woke up to a flood of emails and texts and messages, saying the forum had disappeared altogether.
No access via FTP, browser or phone.
The file structure appears when i log in at https://hosting.plus.net/portal/
Baffling.


I've spoken to support again this morning and none of the agents are actually trained to deal with a service that PN don't advertise any longer. I DO fully understand that. We are using a legacy area that they don't advertise now as being available and they hadn't disabled it.

Fortunately, I took a full backup of the database and forum files yesterday via FTP.
I may have to resort to migrating it elsewhere.
Guidance on how to do that is here:
https://www.phpbb.com/support/docs/en/3.1/kb/article/transferring-your-board-to-a-new-host-or-domain...

12stringbassist
Grafter
Posts: 26
Thanks: 2
Fixes: 1
Registered: ‎11-05-2016

Re: CGI webspace issues producing rubbish text on forum pages.

I'm not prone to conspiracy theories usually, but after I talked to someone who actually managed to do a server refresh, the forum disappeared completely from view and from FTP.

Yet i can see the files in my CGI web space file manager on the plusnet portal.
WHY has the ability to reach them via FTP and to view on the net been removed?

I am looking into alternative hosting on Monday.
I'll look for a new ISP then, too.