cancel
Showing results for 
Search instead for 
Did you mean: 

A significant problem with the new ccgi migration

drpatterson
Newbie
Posts: 3
Registered: 05-03-2014

A significant problem with the new ccgi migration

Following the  e-mail to say my new ccgi site was ready I checked the site.
I logged in via the portal at https://hosting.plus.net/portal/
File manager pro shows a public directory with an img subdirectory and none of my original ccgi files.
FTP to 91.136.8.9 with username substituted in ccgi.username.plus.com shows:
public directory with original ccgi root files. (Why are the root files not showing up in the portal file manager pro?)
img subdirectory (Plusnet originated)
All my subdirectories from the original ccgi
However, I cannot open these directories! Error 550 Permission denied.
I suspect that I will also not be able to delete them.
This needs an urgent solution.
David
6 REPLIES
virnuls
Dabbler
Posts: 11
Registered: 05-07-2010

Re: A significant problem with the new ccgi migration

Yes - I'm getting a similar thing.  File Manager Pro is only showing the img folder (containing the PlusNet logo) and a folder that I uploaded this morning using FileZilla.
Using an FTP connection with FileZilla shows many more files and folders (although there is at least one folder missing), and I can add new ones, but I can't overwrite existing files.  I suspect it's a permissions thing, but it won't let me change the permissions.
The files are there because the pages are accessible via http://ccgi.virnuls.plus.com/ (and that's a copy of the site from about three weeks ago, so I know that it's not the PlusNet-hosted version, which is still accessible using my domain name).
Who do we contact to get this sorted out?  Do we go through PlusNet, or straight to Hostopia?
Superuser
Superuser
Posts: 9,515
Thanks: 868
Fixes: 53
Registered: 06-04-2007

Re: A significant problem with the new ccgi migration

I suggest raising a Hosting (CGI) ticket on your account to get this sorted out. We contact Plusnet for support, not Hostopia.
David
Community Gaffer
Community Gaffer
Posts: 13,231
Thanks: 966
Fixes: 81
Registered: 04-04-2007

Re: A significant problem with the new ccgi migration

Hi guys, I'll get these raised. Apologies for the inconvenience.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

drpatterson
Newbie
Posts: 3
Registered: 05-03-2014

Re: A significant problem with the new ccgi migration

As of today I can now see the contents of the public folder in an ftp package.
However, none of my scripts are working!
Most of my website is therefore useless.
all cgi-bin/<any scriptname> requests are being directed to the CGI-BIN folder in public
A text dump of the script file is returned. NOTHING ELSE!
I have tried placing a hello world script in the /cgi-bin folder
This cannot be accessed as the plusnet path directive looks in /public/CGI-BIN
I am somewhat exasperated!
What can be done to get perl and php scripting operational?
Is there an option to use the original ccgi site as this was 100 % functional?
David
Superuser
Superuser
Posts: 9,515
Thanks: 868
Fixes: 53
Registered: 06-04-2007

Re: A significant problem with the new ccgi migration

To stop CGI scripts under /public being listed instead of run add the directive

AddHandler cgi-script .cgi .pl

to a .htaccess in the /public folder (ie /public/.htaccess)
Hostopia should have added that for you during the migration. The /public/CGI-BIN folder *should* be a link to /public/cgi-bin so content should be in the latter. Does your FTP program show /public/CGI-BIN is a real folder? CGI files need to be chmod 700 to avoid access errors.
David
drpatterson
Newbie
Posts: 3
Registered: 05-03-2014

Re: A significant problem with the new ccgi migration

Everything is now working as far as I can tell.
Further testing will no doubt identify some issue.
My thanks to support.
I have not needed to place the addhandler command in .htaccess
.htaccess is visible by default to my ftp package. (Not normal practice)
I had to lookup the new ccgi directory file path and edit a password filepath in .htaccess
David