cancel
Showing results for 
Search instead for 
Did you mean: 

port translation?? NAT or IP filter??

N/A

port translation?? NAT or IP filter??

Hi all,

My work have barred all outbound SSH traffic. I was hoping someone could explain how I could connect to my Solwise ea110 public facing IP address on ports 443 (https) and have it pass the connection through to port 22 on an internal box. Not sure if this is a NAT or IP filter task.

Help appreciated,

Ed
3 REPLIES
N/A

port translation?? NAT or IP filter??

Ok, I've tried:

web interface > services > NAT > nat rule entry add

Rule ID: 21
Rule Flavor: RDR
IF Name: ppp-0
Protocol: TCP
Local Address From: 172.16.1.2
Local Address To: 172.16.1.2
Global Address From: <plusnet assigned ip>
Global Address To: <plusnet assigned ip>
Destination Port From: 443
Destination Port To: 443
Local Port: 22

Found the documentation here:
http://www.solwiseforum.co.uk/downloads/files/110quicksetup-versolwise.pdf


Unfortunately, It doesn't work Sad

the ssh failure:

# ssh -v -l root <plusnet assigned ip> -p 443
OpenSSH_3.6p1, SSH protocols 1.5/2.0, OpenSSL 0x0090603f
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Rhosts Authentication disabled, originating port will not be trusted.
debug1: Connecting to <plusnet assigned ip> [<plusnet assigned ip>] port 443.
debug1: connect to address <plusnet assigned ip> port 443: Connection timed out
ssh: connect to host <plusnet assigned ip> port 443: Connection timed out
l#


Anyone got any ideas on how to get this working?
N/A

port translation?? NAT or IP filter??

Obviously your company restricted access for a reason. It sounds like you are using your companies network, check your company's IT policy/rules, otherwise you could find yourself out of a job!!!
N/A

port translation?? NAT or IP filter??

Quote
Ok, I've tried:

web interface > services > NAT > nat rule entry add

Rule ID: 21
Rule Flavor: RDR
IF Name: ppp-0
Protocol: TCP
Local Address From: 172.16.1.2
Local Address To: 172.16.1.2
Global Address From: <plusnet assigned ip>
Global Address To: <plusnet assigned ip>
Destination Port From: 443
Destination Port To: 443
Local Port: 22

Anyone got any ideas on how to get this working?


i did this as well - the only difference is that i left both global addresses at 0.0.0.0 (all)