cancel
Showing results for 
Search instead for 
Did you mean: 

SMTP Server Problem

N/A

SMTP Server Problem

Dear all,

I am using PHP NUKE and I'm trying to get an SMTP server to send mail via "relay.plus.net" to port 25.

However, the SMTP server shows that it cannot connect and just remains hanging - trying to connect.

PHP.ini appears to be written properly.

Grateful for any suggestions (polite)

Andrew

[Moderator's note (by Chris P.): Title changed from all capitals, as this is akin to shouting on the internet]
4 REPLIES
N/A

SMTP Server Problem

Is this php-nuke site hosted on PlusNet's CGI space? If not, you won't be able to use the PlusNet relay as it won't accept connections from non-PlusNet IPs.

I'm not completely sure, but it could be that if it is hosted on your PlusNet CGI space, port 25 is blocked by the server's firewall, which would have an effect similar to that which you described. Hopefully someone who knows more about these things can confirm or deny this.
N/A

SMTP Server Problem

Thanks for the reply.

The site (which I think is a bit of a red herring) is situated on my static ip address (212.159.23.26/public).

To push the mail out from the nuke site it appears to need an SMTP server. I have loaded a server, given it the SMTP address (relay.plus.net) and the port 25.

However the connection fails. As you suggest it may be that port 25 is blocked - any way round this?

regards

Andrew
N/A

SMTP Server Problem

If this site is hosted on your local machine then PlusNet won't be blocking any ports - except for 135 and 445 (I'm almost certain those are correct) which are blocked to prevent the spread of certain viruses/worms.

So you have setup a local SMTP server, which then sends emails to relay.plus.net? Or you have just put relay.plus.net into phpNuke's configuration? I think the easiest would be the latter - just using relay.plus.net. The only thing I can think of which could be causing a problem is a local firewall blocking port 25? If you use a router this could possibly be setup to block port 25 by default aswell.
Plusnet Staff
Plusnet Staff
Posts: 12,169
Thanks: 18
Fixes: 1
Registered: 04-04-2007

SMTP Server Problem

Hi,

Port 445 is only blocked on the network borders, 135 is blocked on both the Redbacks and the firewalls.
I used phpNuke a while back and the easiest way to set it up was just to set relay.plus.net as the outgoing server as Chris says. I can't remember if it has the option to enter and SMTP username and password (I might be thinking of phpBB) if it does make sure they are blank or the option is turned off.