cancel
Showing results for 
Search instead for 
Did you mean: 

Open Ports

N/A

Open Ports

Using a Solwise SAR110 ADSL Router. I have noticed when I run shields up I always get the following ports open, 21, 23, 80. As you can imagine these are all very important and don’t use them but I cannot shut them down. I use Norton or Zone alarm but these ports always remain open. How can I shut them.
3 REPLIES
N/A

Open Ports

Are you using a router?

If so, then it will be the router answering the calls.

Consult the manaual for securing these ports on the router.

If you are using a PCI or USB modem, then the problem relates to software on your computer. TO shut these down, to will need to find the application using that port.

If using Windows XP, you can do this by opening a console window (Start -> Run -> "cmd" -> OK) and typing "netstat -o -a" and hitting return.

Look for entried marked as "LISTENING" in the state column, and have ":<port>" in the Local Address column (where <port> is the ports that are showing as open).

The last column is labeled PID. This coresponds to the program that is using that port. You can, look this up using CTRL+ALT+DEL, going to the "Processes" tab, and looking for that number in the PID coumn.

NOTE: You may have to enable the pid column. On the manu bar, select View -> Select columns. Tick PID and OK.
csogilvie
Grafter
Posts: 5,852
Registered: 04-04-2007

Open Ports

The SAR 110 ADSL router has these ports open for its web interface, telnet interface and FTP interface, which is why you see those ports open when you run Shields Up. To rectify this, you should do as Philip (acarr) says, and consult the manual.
Mark_Dowd
Grafter
Posts: 102
Registered: 08-08-2007

Open Ports

I have just configured this on my SAR110, but consulting the manual doesn't tell the half of it :!:

First, you need to decide what you want to do. This box may look like something costing £4.99 from the market, but it is devilishly sophisticated, therefore detailed configuration is not for the faint hearted.

If you try this, caveat emptor.

This configuration assumes that the device responding to Shields Up is the SAR110, rather than the device "behind" it.

If you just want to block all "public" attempts at connecting to the SAR110, but allow all other traffic in both directions, i.e. you have a separate (hard or soft) firewall, do the following:
- Go to Services, IP Filter
- Set Security Level to Low and all Default Actions to Enable.
- Press the Submit button
- Delete all rules using the Dustbin Icon :shock:
- Click Add and set the following entries
-> Rule ID = 1
-> Action = Deny
-> Direction = Incoming
-> Interface = Public
-> Security Level = Low
-> Dest IP Address = Self
-> Protocol = Any

Press Submit, et viola...one bullet-proof but see-through ADSL Router.

Next it is a good idea to block NetBEUI completely, as it takes up valuable session space (limited number, not sure how many).
- Select Service, Blocked Protocols
- Check NetBEUI (and any others you don't fancy) and press Submit

Don't forger to commit and reboot

Finally, if it all goes pear shaped, you can reload the default configuration using the serial interface cable supplied. It has saved my bacon any number of times.

Enjoy...