cancel
Showing results for 
Search instead for 
Did you mean: 

Nokia E Series/N Series Settings

Community Gaffer
Community Gaffer
Posts: 12,857
Thanks: 675
Fixes: 65
Registered: 04-04-2007

Nokia E Series/N Series Settings

Hi all,

Thought I'd start a new thread and sticky it seeing as this question has been asked on multiple occasions over recent months.

Following the work conducted on the VOIP platform as announced here it is now possible to use Broadband phone with the Nokia N series and E series handsets.

The following explains how I configured my N95 to use the service. Other models may differ slightly but never-the-less the settings should be similar.


Handset Configuration

  • Navigate to Tools > Settings > Connection > SIP Settings

  • Select Options > New SIP Profile > Use Default Profile

  • Enter your Broadband Phone settings as follows. I have used screenshots from sipgate's support pages and then included text after each screenshot to show what I replaced the options with.



    Profile name: PlusTalk
    Service Profile: IETF
    Default Access Point: Your wirless access point or GPRS/UMTS Carrier
    Public user name: sip:<Your SIP ID>@sip.plus.net
    Use compression: No
    Registration: User preference but I chose 'Always On'
    Use Security: No

  • Go into the submenu called 'Proxy Server':



    Proxy server address: sip:sip.plus.net
    Realm: sip.plus.net
    User name: <Your SIP ID>
    Password: <Your main account password>
    Allow loose routing: Yes
    Transport type: UDP
    Port: 5060

  • Return to the previous menu and go into the subfolder called 'Registrar Server':



    Registrar server address: sip:sip.plus.net
    Realm: sip.plus.net
    User name: <Your SIP ID>
    Password: <Your main account password>
    Transport type: UDP
    Port: 5060

Testing your device's functionality

To confirm the functionality of the configuration, there are two easy methods:

  • Call the echo test number
    Using the Internet calling facility, dial 7000 from your handset.

  • Make a call to your 0845 number
    Using a land-line or another mobile device, try making a call to your Broadband Phone 0845 number.

We'll try and get this turned into a formal support article for the Help & Support section of the website.

Kind Rgds,

Bob Pullen
Plusnet Products Team
If I've been helpful then please give thanks ⤵

28 REPLIES
N/A

Nokia E Series/N Series Settings

Unfortunately I cannot get this to work with my E60 Sad
Community Gaffer
Community Gaffer
Posts: 12,857
Thanks: 675
Fixes: 65
Registered: 04-04-2007

Nokia E Series/N Series Settings

Hmmm, very odd.

Now I'm at home I can't get it to work either. It won't register again Sad

I'm using the same settings as I did at work yesterday, the only difference being that I'm connecting via a Zyxel 662HW as opposed to a BT 1801HG?!?

Will carry on investigating.

Rgds,

Bob Pullen
Plusnet Products Team
If I've been helpful then please give thanks ⤵

N/A

Nokia E Series/N Series Settings

Hi Bob, just tried on my N95 with my BT/2wire 1800 gateway, not registering here either Sad
Community Gaffer
Community Gaffer
Posts: 12,857
Thanks: 675
Fixes: 65
Registered: 04-04-2007

Nokia E Series/N Series Settings

That's odd because I've just tried again now I'm back in the office and I can register fine via the 1800HG.

Kind Rgds,

Bob Pullen
Plusnet Products Team
If I've been helpful then please give thanks ⤵

N/A

Nokia E Series/N Series Settings

I can get Truphone to work fine on the N95 without any problems, but just wondering if you have any ports open in the 1800HG firewall to help Plustalk work?
Community Gaffer
Community Gaffer
Posts: 12,857
Thanks: 675
Fixes: 65
Registered: 04-04-2007

Nokia E Series/N Series Settings

I didn't specifically forward any of the ports on the 1800. All settings are the default ones that are assigned after a factory reset.

Rgds,

Bob Pullen
Plusnet Products Team
If I've been helpful then please give thanks ⤵

N/A

Nokia E Series/N Series Settings

Quote
That's odd because I've just tried again now I'm back in the office and I can register fine via the 1800HG.
quote]

So this beggars the question, is it something particular to the router (doubtful) or just the fact your trying to run it from the office? I very much suspect the latter but what would be that difference precisely?
Zaphod
Dabbler
Posts: 21
Registered: 14-08-2007

Nokia E Series/N Series Settings

So, we can fairly safely say that this appears to be a firewall issue within PlusNet. Your connection works from within PlusNet but doesn't from outside.

That said, this implies that there is a difference between the behaviour of X-lite and a Nokia phone.

I wonder does every packet involved in logging in via a Nokia phone go over UDP port 5060? Could it be that the login on a Nokia phone is sent over TCP/IP or via a different port?

I get no response when I try to ping sip.plus.net
N/A

Nokia E Series/N Series Settings

Yeah but then if ya try to tracert to sip.plus.net you get no resolve, so not sure what that would prove (Or is that just me?). But certainly everything points to a networking/routing difference (not sure which might be the more correct term), as obviously something is complicating matters from outside Plusnet's own network. Wonder if the E61 manual can shed any light? I'll have a look.
arlehaven
Grafter
Posts: 67
Registered: 10-06-2007

Nokia E Series/N Series Settings

Cheesy Hi Bob, firstly may I say thanks for the instructions and screenshots above.

Mark (Kelly)Big Bro, mentioned to me that you had posted details re setting up the Nokia N95 so here I am, I took a wee look and guess what.... Connected no problem using the settings you gave.

I am using the BT1800HG, I am using the standard settings and have not had to open any ports.

I noticed two things whilst setting mine up and following your instructions; firstly Username - I used my sip ID number rather than my plusnet username.

(the first time I tried to register it failed when using the actual user name) however this may have been caused by my second point. Having created new sip settings I noticed that the original sip account was still in the phone. I made the Plus Talk settings the default account and deleted the original settings.... 2 seconds later I was connected.

I hope this helps in some way.
Community Gaffer
Community Gaffer
Posts: 12,857
Thanks: 675
Fixes: 65
Registered: 04-04-2007

Nokia E Series/N Series Settings

Quote
So, we can fairly safely say that this appears to be a firewall issue within PlusNet. Your connection works from within PlusNet but doesn't from outside.

You misunderstand.

When I'm at work I'm connecting via a Max DSL enabled test line on a standalone BT circuit using a plusnet username and password. I'm not connecting via the internal network.

Quote
That said, this implies that there is a difference between the behaviour of X-lite and a Nokia phone.

I'm using the Nokia at home and at work. That suggests the router as the differentiator. It's the 1800HG at work and a Zyxel 662HW at home. Both routers are on standalone Plusnet ADSL lines using the same login credentials. At work I can get Plustalk working on an ATA, in X-Lite and on my Nokia via the 1800HG. At home it I can get connected via all but the Nokia using the Zyxel 662HW. Sipgate connects to all 3 at both locations.

Quote
I wonder does every packet involved in logging in via a Nokia phone go over UDP port 5060? Could it be that the login on a Nokia phone is sent over TCP/IP or via a different port?

The Nokia allows you to choose TCP/IP, UDP or Auto. Either Auto or UDP should work (and does when I'm connected using the 1800HG)

Quote
I get no response when I try to ping sip.plus.net

You wont because it doesn't accept ICMP packets.

Kind Rgds,

Bob Pullen
Plusnet Products Team
If I've been helpful then please give thanks ⤵

Community Gaffer
Community Gaffer
Posts: 12,857
Thanks: 675
Fixes: 65
Registered: 04-04-2007

Nokia E Series/N Series Settings

Quote
Cheesy Hi Bob, firstly may I say thanks for the instructions and screenshots above.

Mark (Kelly)Big Bro, mentioned to me that you had posted details re setting up the Nokia N95 so here I am, I took a wee look and guess what.... Connected no problem using the settings you gave.

w00t! Finally, somebody else connects to prove I'm not going crazy Cheesy

Quote
I am using the BT1800HG, I am using the standard settings and have not had to open any ports.

I noticed two things whilst setting mine up and following your instructions; firstly Username - I used my sip ID number rather than my PlusNet username.

That's what I put in my instructions isn't it?

Quote
Having created new sip settings I noticed that the original sip account was still in the phone. I made the Plus Talk settings the default account and deleted the original settings.... 2 seconds later I was connected.

I have two accounts set up and it doesn't cause a problem. It's worth paying attention to the 'Registration' option though. If it's set to 'When needed' it's likely that you'll have to manually connect using the 'Internet tel.' Applet in the Tools menu.

Kind Rgds,

Bob Pullen
Plusnet Products Team
If I've been helpful then please give thanks ⤵

ScoUK
Grafter
Posts: 61
Registered: 04-08-2007

Nokia E Series/N Series Settings

Hope we can get to the bottom of this one.

For interest, I'm using a Nokia N95 and Netgear DG834GT Router. And doesn't work for me. "Connection Failed" error on phone.
arlehaven
Grafter
Posts: 67
Registered: 10-06-2007

Nokia E Series/N Series Settings

Hello Scouk,

As I previously stated Bobs instructions are excellent with regards the settings. I was a happy bear when mine registered straight away. At first I thought that was all I had to do, so I tried to make a call but it didn't work.

This morning I took another look at the settings in the phone.

Menu/tools/settings/connection.

Having sucessfully set up the sip settings yesterday I then looked at the settings for the Internet telephone listed below sip settings in the list.

Here I renamed the setting to Plustalk and ensured that the Internet telephone was using the Plustalk sip settings.

I have made several calls this morning sucessfully and phoned myself to confirm it was receiving calls which it did.

Both the soft phone on the computer and the Nokia N95 rang out.

Again as previously stated, I have not had to touch any firewall settings in the router, I am also running Zone alarm pro and havn't changed anything there.

In short recheck your sip settings, use the sip ID number rather than your username, in Bobs instructions, only use the full id ie sip id number + @sip.plus.net where told.

I hope this helps a bit.
Good luck. Smiley