cancel
Showing results for 
Search instead for 
Did you mean: 

FTP problems with cgi.*.plus.com

N/A

FTP problems with cgi.*.plus.com

Anyone having problems connecting to the cgi server for uploading scripts? I've been using WS 95 FTP and just downloaded CuteFTP aswell to check it wasn't my software playing up.

All I can do is able to connect to it, passed authentication, and then attempts to get a dir listing but it hangs at that point. I've had this problem before, but I can't remember what the solution was (if there was any). :roll:

Cheers. :-)
2 REPLIES
phillight
Grafter
Posts: 95
Registered: 30-07-2007

FTP problems with cgi.*.plus.com

Same problem here using SmartFTP:


Resolving host name cgi.plus.net...
Connecting to (cgi.plus.net) -> IP: 212.159.3.3 PORT: 21
Connected to (cgi.plus.net) -> Time = 0ms
Socket connected waiting for login sequence.
220 ProFTPD 1.2.9 Server (ProFTPD) [cgi05.plus.net]
USER kaysgardens
331 Password required for kaysgardens.
PASS (hidden)
230 User kaysgardens logged in.
SYST
215 UNIX Type: L8
FEAT
211-Features:
MDTM
REST STREAM
SIZE
211 End
PWD
257 "/" is current directory.
TYPE A
200 Type set to A
PASV
227 Entering Passive Mode (212,159,3,3,19,59)
Opening data connection IP: 212,159,3,3,19,59 PORT: 4923.

*****
Make cup of tea here
*****

A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
PORT 192,168,0,2,5,158
200 PORT command successful
Opening data connection IP: 192.168.0.2 PORT: 1438.
LIST -aL
150 Opening ASCII mode data connection for file list
3033 bytes received successfully. (2.96 KB/s) (00:00:01).
226 Transfer complete.


It's been like this for a few hours.

Edit: Try changing your connection to active rather than PASV - SmartFTP seems to do this automatically when the PASV command times out.

Phil
N/A

FTP problems with cgi.*.plus.com

Neither modes work - it gives me the same "hang" after when a list command is issued in passive or goes into a loop in active. Last time this happened I was just told to use CuteFTP (well this is a paste from CuteFTP).

Quote

STATUS:> Connecting to cgi.kylesterry.plus.com (ip = 212.159.3.3)
STATUS:> Socket connected. Waiting for welcome message...
220 ProFTPD 1.2.9 Server (ProFTPD) [cgi05.plus.net]
STATUS:> Connected. Authenticating...
COMMAND:> USER kylesterry
331 Password required for kylesterry.
COMMAND:> PASS (hidden)
230 User kylesterry logged in.
STATUS:> Login successful
COMMAND:> TYPE I
200 Type set to I
COMMAND:> REST 100
350 Restarting at 100. Send STORE or RETRIEVE to initiate transfer
STATUS:> This site can resume broken downloads
COMMAND:> REST 0
350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer
COMMAND:> pwd
257 "/" is current directory.
COMMAND:> TYPE A
200 Type set to A
STATUS:> Retrieving directory listing...
COMMAND:> PORT 81,174,158,36,19,70
200 PORT command successful
COMMAND:> LIST
425 Unable to build data connection: Operation timed out
ERROR:> File error
COMMAND:> pwd
257 "/" is current directory.
COMMAND:> REST 0
350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer
COMMAND:> TYPE A
200 Type set to A
COMMAND:> pwd
257 "/" is current directory.

....loop.... forced a change to higer directory than my own to see if it can give me a permission error or something....
Quote

COMMAND:> TYPE A
200 Type set to A
STATUS:> Retrieving directory listing...
COMMAND:> PORT 81,174,158,36,19,78
200 PORT command successful
COMMAND:> LIST
421 No Transfer Timeout (300 seconds): closing control connection.
ERROR:> Can't initiate data transfer
COMMAND:> TYPE A