cancel
Showing results for 
Search instead for 
Did you mean: 

Edonkey problem

N/A

Edonkey problem

Can anybody give me the definitive settings/setup to access Edonkey using Voyager 2100 Router and Norton Firewall !!!

Just sits trying to Connect !

With previous ISP just installed it and away it went first time - why is it not the case with PlusNet ?

Many thanks (in anticipation !)
2 REPLIES
N/A

Edonkey problem

It should work out of the box but you would have a low ID if its not working Norton is probally stoping it. You must tell Norton to give it access. I encloe some details for setting the ports and windows firewall(which could be stopping it).

It should connect ok without any port forwarding but you do need to forward the ports if you want a hi ID


WindowsXP with SP2 (or higher) installed:

When you start eMule the first time Windows will ask you if it should permit connections for eMule. Just click on "Unblock" and you are all set.
Please note that you can only select "Unblock" when you are logged in as administrator on Windows which also means that eMule's "Run as unprivilged User" feature must be disabled (which it is by default).

WindowsXP with SP1 (or lower) installed:

Start eMule and go to the connection settings. Choose your ports you want to use and then click on the button "Open these ports on internal WinXP firewall". If everything works well, eMule should be able to open those ports. It is recommended to do a porttest by clicking on the button "Test ports" to verify that all eMule ports are reachable.
If eMule failed to open the port automatically you can either open them manually or disable the firewall. Here is a step-by-step guide how to open those ports manually:
1. Open eMule
2. Click Preferences > Connection
3. Write down the client port value (default 4662)
4. Also note the UDP port value (default 4672)
5. Close eMule and your internet connection
6. In On Windows XP click Start, and then click My Network Places.
7. Go to Network Tasks, click View Network Connections. (Alternatively, you can right-click My Network Places and click Properties.)
8. Right-click the connection you use for the Internet and choose Properties
9. Click the Advanced tab, and then click Settings.
If the Settings button is unavailable, ICF is not enabled on this connection and you do not need to open any ports (they are all already open).
10. Click Add to open a new port.
11. Type a name in the Description box, for example, "eMule : TCP Incoming".
12. Type 127.0.0.1 in the Name or IP address of the computer hosting this service on your network box. You can specify the IP address of an internal computer; however, in most cases, you use 127.0.0.1
13. Type the client port you wrote down in step #3 in the External port and Internal port boxes.
14. Choose TCP, and then click OK.
15. Click Add to open a new port again.
16. This time choose a name like "eMule : UDP Incoming"
17. see #12
18. Now External port and Internal port is the value you noted in step #4.
19. Choose UDP, and click OK.
If you change your client port later, you need to reconfigure the rule above on your firewall.

(this nice ICF how to was adopted from -nRoK-. Thanks)

For additional information, click the article numbers below to view the articles in the Microsoft Knowledge Base:

Q308127 How to Manually Open Ports in Internet Connection Firewall in Windows XP
Q283673 How to Enable or Disable the Personal Firewall Feature in Windows XP
Q307554 Programs Require Manual Port Configurations with Internet Connection Firewall


Without proper configuration you will have a low ID when using a router. A router works like a shield to the network behind it, masquerading the IP addresses of the computers in the LAN. When another client tries to establish a connection to your eMule it only sees the IP of the router but not the actual IP of the computer eMule is running on. To prevent this all ports in the list that have the incoming direction – port 4662, 4711 TCP and port 4672 UDP – have to be forwarded.
See your router's manual. Keywords to start are port forwarding, DMZ – Demilitarized Zone, Filters and Rules.
Many routers also have built in firewalls so be sure to set the appropriate ports (see Firewall) there, too.

Note:
When using a router in a network the option DHCP - Dynamic Host Configuration Protocol in the router should be turned off. Assign static IPs to each client in the network. This can be done in Window's Network Connections -> LAN Connection -> Properties -> TCP/IP . Deactivate the automatic IP assignment and enter an IP in the range of 192.168.xxx.xxx. Different types of router have different home IP ranges, this is noted in the routers manual.
After entering a valid IP the Subnet Mask field automatically changes to 255.255.255.0. Last step is to enter your router's IP as Standard Gateway.

If you care to help other users and know how to handle your type of router, write a little guide and send it to Monk@emule-project.net

Note:
If your type of router is not listed have a look at the examples anyway as the configuration works quite similar among the different types of routers. Also good source for setting up routers can be found at portforward.com.

Last update on: 2003-03-22 by Monk

The following list shows the ports used by eMule when using it's default settings. If you change anything in Preferences -> Connection you will have to take the changes into account when configuring your firewall or router.
1) Local Port: 4662
Remote Port: any
Protocol: TCP
Direction: incoming
Purpose:

Client Port / Connections from other clients, Client to Client Source Exchange
Note:

You can change this port in Preferences -> Connection -> Client Port
This port has to be forwarded in a router. Changing this port in Preferences you must also change the forwarding in the router


2) Local Port: any
Remote Port: 4662
Protocol: TCP
Direction: outgoing
Purpose:

Client Port / Connections to other clients, Client to Client Source Exchange
Note:

4662 is the default port, but other clients may have different settings. Change the remote port to any when configuring a firewall


3) Local Port: 4672
Remote Port: any
Protocol: UDP
Direction: incoming
Purpose:

Clients source asking / extended eMule protocol, Queue Rating, File Reask Ping
Note:

This port has to be forwarded in a router. Changing this port in Preferences you must also change the forwarding in the router.
If you are not able to forward this port check the disable box in Preferences -> Connection -> UDP Port


4) Local Port: any
Remote Port: 4672
Protocol: UDP
Direction: outgoing
Purpose:

Clients source asking / extended eMule protocol, Queue Rating, File Reask Ping
Note:

4672 is the default port, but other clients may have different settings. Change the remote port to any when configuring a firewall
5) Local Port: any
Remote Port: 4661
Protocol: TCP
Direction: outgoing
Purpose:

Connection to server
Note:

4661 is the default port of a server. Many server use different ports. Configuring a firewall the remote port again changes to any.


6) Local Port: any
Remote Port: 4665
Protocol: UDP
Direction: outgoing
Purpose: Source asking on servers
Note:

Servers using the default port 4661 TCP (see #5) automatically set their port for source asking to 4665 UDP. If a server uses a different port in #5 the corresponding UDP port is set to [Connection Port + 4]. For firewalls the remote port here is any.


7) Local Port: 4711
Remote Port: any
Protocol: TCP
Direction: incoming
Purpose: Webserver
Note: This is the default port for the web interface. When using a router this port has to be forwarded or no connection to the webserver will be possible.
N/A

Edonkey problem

Many thanks for your reply.

Managed to sort it - I thought that by disabling Norton Firewall that would work BUT that wasn't the case - under the Configurations options it was showing 'Block All' against edonkey .. changed it to 'Permit All' and that was that.

Now got the Voyager Configuaration Manager Port Forwarding set up with quite a few ports - some are probably not required , so will delete one a time to see which ones are required.