cancel
Showing results for 
Search instead for 
Did you mean: 

Asterisk@Home

N/A

Asterisk@Home

Has anyone yet got a trunk set up in Asterisk@Home for inbound and outbound calls through plustalk. If so please you you post your trunk details. Have been playing for ages and it is starting to piss me off.

Thanks

Rob
11 REPLIES
N/A

Asterisk@Home

I have to power up the asterisk@home server to do this tomorrow night but I have got it working with trunks using both sipgate and Plusnet.

Ian
N/A

Thanks for reply

Hi thanks for your reply, i have been playing with it this evening and seem to have got both inbound and outbound working with plustalk but my config are just guess work. If you could then would be useful to see what you have entered so i can try to make more sense of what i have entered.

Thanks very much

Rob.
N/A

Asterisk@Home

Here goes.

Add a new SIP trunk . In outband caller ID enter your telephone number (The 0845 one). In trunk incoming, name it plustalk-incoming. The peer details are:

canreinvite=no
fromdomain=account.plus.com
fromuser=plustalk
host=sip.plus.net
insecure=very
nat=yes
qualify=yes
secret=mypassword
type=friend
username=plustalk@account.plus.com

Where account is your plusnet account name and mypassword is the account password.

In outgoing, name the peer plusnet. The peer settings are:
canreinvite=no
context=from-pstn
fromdomain=account.plus.com
fromuser=plustalk
host=sip.plus.net
insecure=very
nat=yes
qualify=yes
secret=mypassword
type=friend
username=plustalk@account.plus.com

The qualify=yes allows you to do a sip show peers from within Asterisk to show peer connectivity.

Now the register string is:
plustalk@account.plus.com:mypassword@sip.plus.net/plustalk

Now save the settings. Click on outbound routing and add a route. I prefix all calls to Plustalk with an 8, so my dial rules are "8|." (without quotes but WITH the fullstop)

Set the trunk sequence, I use 0 = SIP/plustalk (the name you gave the outgoing peer above)

In inbound routing I found a problem when I tried to use digital receptionist so I have force the default route to be to call extension 200 (my internal extension). I recommend not using immediate answer as this will charge incoming callers from the time that the line connects including during the initial ringing phase.

Ian
sgbirch
Dabbler
Posts: 17
Registered: 11-10-2007

Asterisk@Home

Wow!! I guess we were supposed to just guess this setup! I have been very happy with plus for many years but they do need to work on the plus talk documentation.

Anyway .. MANY MANY thaks for the instructions, I now have asterisk working with plustalk. Very cool indeed.

Steve
N/A

type=friend

Should this setting in the outgoing section be type=peer ? This should then appear in the peer list.

My outgoing calls are working fine but incoming calls go straight to Plustalk voicemail. I am using exactly the settings that you recommended above for outgoing.
N/A

Incoming calls from Plustalk to my Asterisk box

An update.

I have managed to get incoming calls to work intermittently. Plustalk will deliver incoming 0845 calls to my Asterisk box for hours then it will mysteriously start diverting 0845 calls to Plustalk voicemail and that will continue for hours. Rebooting my Asterisk box will not rectify the problem.

I seem to have reached a dead end with this problem and the 0845 number isn't useable in this situation. I suspect the problem may be with Plustalk voicemail and it would be useful to be able to cancel that voicemail service.
N/A

Re: Incoming calls from Plustalk to my Asterisk box

Quote
I seem to have reached a dead end with this problem and the 0845 number isn't useable in this situation. I suspect the problem may be with Plustalk voicemail and it would be useful to be able to cancel that voicemail service.


Are you getting registration timeouts? Turn on verbose logging to see. Also, make sure you have "qualify = yes" in your sip.conf and look at "sip show peers" and "sip show registrations" at times when you're having the problem.

I get a fair number of these caused by sip.plus.net:

Apr 27 12:28:49 WARNING[11623]: chan_sip.c:9633 handle_response_register: Got 200 OK on REGISTER that isn't a register

And sip.plus.net occasionally goes unreachable. I believe the "200 OK on REGISTER" message I'm getting is down to the plustalk server sending duplicate replies to the registration packets for some reason.

It's also worth noting that PN have a cluster of 4 SIP servers with the name sip.plus.net - the one Asterisk will use is picked at startup/reload time and doesn't change, even if that server stops working (I've had instances where one of the servers has stopped responding to SIP traffic and another server is sending ICMP port unreachable replies and Asterisk just keeps banging on at the same broken servers - doing "sip reload" causes it to choose another server).

That said, I'm not using PlusTalk for my inbound calls, only the outbound ones at the moment, so whilest I know the inbound number does work, I don't know how stable it is.
N/A

Asterisk@Home

Thanks for point this out. I can now see the problem with the Plustalk servers.

I've spent hours and hours fiddling around with the Asterisk configuration as I thought the problem may be at my end. Anyway, I'll keep using Sipgate for my incoming calls and Plustalk for outgoing for now.
N/A

Asterisk@Home

Quote
Thanks for point this out. I can now see the problem with the Plustalk servers.

I've spent hours and hours fiddling around with the Asterisk configuration as I thought the problem may be at my end. Anyway, I'll keep using Sipgate for my incoming calls and Plustalk for outgoing for now.


What's the stability of SIPgate like ATM? I saw a lot of failed registrations up until a few weeks ago - haven't noticed anything in the past couple of weeks but I've had my logs flooded with the PlusTalk warnings so may have missed it. Smiley
(I'm not currently actively using my SipGate account so wouldn't notice any problems)
N/A

Sipgate incoming calls

Its been better in the last week or so. Previously only 1 in every 4 calls to my 0207 number were getting through.

BTW, in case you didn't see another post of mine regarding Plustalk call quality, my default setting in sip.conf was to allow codecs glaw, alaw and gsm. I noticed that Plustalk always opted for gsm and my Plustalk calls sounded muffled. I deleted the gsm option in sip.conf and there has been a significant improvement in Plustalk call quality.
N/A

Re: Sipgate incoming calls

Quote
Its been better in the last week or so. Previously only 1 in every 4 calls to my 0207 number were getting through.


Hmm.. right. I want to start using SIP for my inbound calls too (I've currently get an FXO card plugged into my BT line and suffer badly from echo so the sooner I can ditch that the better) but I obviously need a geographic number. SipGate seemed n obvious choice but I was uncertain about the reliability so I'll keep an eye on it.

Quote
BTW, in case you didn't see another post of mine regarding Plustalk call quality, my default setting in sip.conf was to allow codecs glaw, alaw and gsm. I noticed that Plustalk always opted for gsm and my Plustalk calls sounded muffled. I deleted the gsm option in sip.conf and there has been a significant improvement in Plustalk call quality.


Yes, I noticed the same and I now force my PlusTalk calls to ulaw. GSM is great if you want to use as little bandwidth as possible but I'm quite happy to dedicate ~64Kbps to my phone calls so ulaw it is. I would use Speex if I could get it to work properly under Asterisk (it seems Asterisk has poor support for Speex - it breaks if I try and use Speex with Asterisk and Ekiga together).